4.3 Beta 2 (v4.30.0.0213) available

Page 1 of 3 (47 items) 1 2 3 Next >
This post has 46 Replies | 1 Follower

Posts 4077
Melissa Snyder | Forum Activity | Posted: Tue, Apr 5 2011 4:04 PM | Locked

4.3 Beta 2 (v4.30.0.0213) is available for testing.

To upgrade to Beta 2 now, use the "Update Now" command if you’ve switched to the beta channel before, or the "Set Update Channel to Beta" command if you're on a stable version (such as 4.2a SR-3). To install Beta 2 from scratch, use this download link: http://downloads.logos.com/LBS4/LBS4MacInstallerBeta/Logos4Mac.dmg.

For Release Notes see: http://wiki.logos.com/Logos_4.3_Beta_2.  Note: Additional bug fixes have been added to Release Notes for 4.3 B2 since this posting.

Posts 656
Jeremy | Forum Activity | Replied: Tue, Apr 5 2011 5:04 PM | Locked

When I hit update, the update would not download. When I tried to install from scratch, the update stalled at 1%.

Posts 143
Steven Baxley | Forum Activity | Replied: Tue, Apr 5 2011 5:28 PM | Locked

Well, my download never goes beyond 0%.  I have super-fast Verizon FiOS, so that is definitely not the issue.  This is the second beta in a row that's had issues from the get-go.  Sad

Posts 62
George W Raduano | Forum Activity | Replied: Tue, Apr 5 2011 6:36 PM | Locked

I moved from stable to Beta 2 to give it a try. Just like B1, using saved layouts caused the program to crash.

So, I removed the Beta 2 and have returned to the Stable channel. Fortunately, I have fast Internet and a new MBP with a SSD, so the process does not take as long as it used to.

Actually, the stable version was running very fast on my new machine. Logos4Mac took less than 10 seconds to launch and intense layouts were also loading in less than 10 seconds. And, I was operating virtually crash free. I am still wondering why I ventured back to the "Beta side"?????

Blessings,

George

Posts 5
Lou | Forum Activity | Replied: Tue, Apr 5 2011 6:37 PM | Locked

I'm still having the same update issues as well even after updating to Beta 2. I actually can download the file myself (it's actually 2009-10-26T22_22_11Z.lbsevp to be exact). However, I can't even run the scan command to add it manually. Any further assistance would be greatly appreciated! :)

Posts 10837
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Apr 5 2011 6:38 PM | Locked

Jeremy:

When I hit update, the update would not download. When I tried to install from scratch, the update stalled at 1%.

Beta 1 had such severe download freezes that I resorted to Stable. If you  are on that version, you may need to download the disk image to get Beta 2 installed.

Posts 5
Lou | Forum Activity | Replied: Tue, Apr 5 2011 6:41 PM | Locked

I'm contemplating moving back to stable ... although I'm a little weary of indexing my entire library all over again. If I can't get the 4.3 beta issues squared by the weekend, then maybe I'll go back to stable. 

Posts 10837
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Apr 5 2011 6:42 PM | Locked

Melissa Snyder:
4.3 Beta 2 (v4.30.0.0213) is available for testing.

Melissa

The release notes do not mention the download freeze problems experienced by multiple users of Beta 1. Does that mean that this issue has not been addressed? The Mac Development Team has been conspicuously absent from these threads.

Posts 1567
Ben | Forum Activity | Replied: Tue, Apr 5 2011 6:45 PM | Locked

First froze around 20%. Tried again, stuck at 2.

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 1416
Wes Saad | Forum Activity | Replied: Tue, Apr 5 2011 8:20 PM | Locked

It froze for me as well. Downloaded the package manually and ran it; updated fine that way. Shouldn't *have* to do that, but this is beta...

Posts 156
Andrew Mitchell | Forum Activity | Replied: Wed, Apr 6 2011 12:49 AM | Locked

MIne froze at 39% so I downloaded it manually, only to find an instant crash on loading a layout, as Beta 1. See thread http://community.logos.com/forums/t/31941.aspx

This is still unusable for me. I am contemplating downgrading to stable release, but not sure of the consequences of this. 

Posts 1084
Martin Folley | Forum Activity | Replied: Wed, Apr 6 2011 8:33 AM | Locked

My download froze again ... noting new there.

I downloaded the file from feed://clientservices.logos.com/update/v1/feed/logos4-mac/beta.xml

This download had to be restarted several times (using safari) because of 'timeouts'. No other downloads seem to have this issue, only those from Logos. Fortunately, Safari allowed me to pick up from where it stopped.

I am now confused as to what I have downloaded though. L4Mac tells me that there is still a 75.5Mb download to come. My resources are up to date (I have scanned a folder from another installation, restarted etc.) so what is this?

'About Logos' gives me Logos Bible Software 4.3 Beta 2 (4.30.0.0213)  which is, as far as I can tell the latest version so there should be no additional updates. 

As an aside, when L4Mac loads, the 'breadcrumbs' are still collapsed/lost. Showing the reading lists, or the help file, causes the panels to redraw and the breadcrumbs populate normally.

 

 

2010 17" MBP with High Sierra, iPad4 with iOS10.

Posts 97
Tom Gindrup | Forum Activity | Replied: Wed, Apr 6 2011 9:38 AM | Locked

Mine's stuck at 2% as well

Posts 844
Dewayne Davis | Forum Activity | Replied: Wed, Apr 6 2011 9:50 AM | Locked

Mine stuck as well, but I did a manual download of the .dmg image and copied Logos into the application folder myself. Worked for me.

“... every day in which I do not penetrate more deeply into the knowledge of God’s Word in Holy Scripture is a lost day for me. I can only move forward with certainty upon the firm ground of the Word of God.”

Posts 214
Jeffrey S. Robison | Forum Activity | Replied: Wed, Apr 6 2011 10:07 AM | Locked

No problem here with the download....

Posts 214
Jeffrey S. Robison | Forum Activity | Replied: Wed, Apr 6 2011 10:21 AM | Locked

Install and first run seem fine...

Posts 1539
Terry Poperszky | Forum Activity | Replied: Wed, Apr 6 2011 11:09 AM | Locked

Stuck at 0%, resorting to manual download.

 

 

Posts 248
Daniel Arnott | Forum Activity | Replied: Wed, Apr 6 2011 11:26 AM | Locked

do they do any internal testing????? or just leave it up to us?

Posts 1416
Wes Saad | Forum Activity | Replied: Wed, Apr 6 2011 12:21 PM | Locked

Daniel Arnott:

do they do any internal testing????? or just leave it up to us?

Daniel,

This is the entire purpose of the beta cycle, to let users join in on the testing. Microsoft does it. Apple does it. Adobe does it. Scads of other development groups do it. Logos does it. One difference is Logos lets users in on the beta earlier than groups like Microsoft and Apple, meaning users will see more bugs.

I don't know what their internal testing procedures are, but it can't beat putting the software in the hands of users who run on a much wider variety of platforms and have a much wider variety of ways they use the software. So there is a beta program for those users that don't mind using unstable software (something Logos repeatedly tries to remind people before they use the beta version) and the tradeoff is beta users get to start playing with new features even sooner. 

So it strikes me as odd to make a comment like this about leaving bug testing up to users... when posting in a beta forum about beta software where the whole point is for users to find bugs...

Posts 1539
Terry Poperszky | Forum Activity | Replied: Wed, Apr 6 2011 12:44 PM | Locked

Chris Roberts:
So it strikes me as odd to make a comment like this about leaving bug testing up to users... when posting in a beta forum about beta software where the whole point is for users to find bugs...

 

It strikes me as odd that you chasten him for making it. It simply looks like an expression of frustration to me. 

 

 

Page 1 of 3 (47 items) 1 2 3 Next > | RSS