Re-editing PB requires restart?

Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 3163
Dominick Sela | Forum Activity | Posted: Sun, Aug 21 2011 2:31 PM

It seems like there are times when a build will fail when I delete the book from a PB catalog entry, and then re-add a revised version to build. It might be when I have left the Word doc open, even if I have subsequently closed the Word file, it will never build again until I close Logos and restart it.

Anyone else seeing this?

Posts 179
Wesley Crouch | Forum Activity | Replied: Sun, Aug 21 2011 2:39 PM

I did have a lot of problems doing just that. I found out that i was going through too many steps. And the PB wasn't closed.

One interesting thing I found out was that I didn't need to delete the book from a catalog entry. All I have had to do is save the changes made in my .docx then hit the Build Book button and it would change itself.

 

Posts 2745
Bohuslav Wojnar | Forum Activity | Replied: Sun, Aug 21 2011 2:46 PM

You are right. If you save changes to your docx file and hit Build the book button, it works, even you do not close Word with the docx file opened.

It might be that if you delete the project and want to start a new one with the same file creates that problem Dominic is speaking about since the file is still linked to the original location in Logos.

Bohuslav

Posts 3163
Dominick Sela | Forum Activity | Replied: Sun, Aug 21 2011 3:53 PM

I'll try just hitting the Build button again. FYI I was deleting the file within the project, not the project.

 

Thanks!

Posts 116
Gary Pajkos | Forum Activity | Replied: Sun, Aug 21 2011 4:09 PM

I have the same problem.  If I try to build the book again after making changes to the docx file, Logos give me an error.  If I delete the book and re-upload it and try to build it I get the same error.  Only after closing Logos and re-opening it up am I able to upload the book and build it again. 

Posts 27043
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Aug 21 2011 4:25 PM

Bohuslav Wojnar:
You are right. If you save changes to your docx file and hit Build the book button, it works, even you do not close Word with the docx file opened.

That is also my experience, but I run into a Build Failure because the resource cannot be deleted. Then I have to close Search panel or another panel in which it was used, or restart L4.

Dave
===

Windows 10 & Android 8

Posts 97
Andreas Holmberg | Forum Activity | Replied: Mon, Aug 22 2011 1:13 PM

Same problem here. I don't see any definite pattern.

It mostly works with the file still open in Word. I sometimes delete the docx-files from the "Body files"-section and then add them again. But even doing this I will sometimes get failed compilations. So I usually just close and restart Logos. Then it usually works for 2-4 rebuildings before "crashing" again.

Pastor in Stockholm, Church of Sweden

Posts 2745
Bohuslav Wojnar | Forum Activity | Replied: Mon, Aug 22 2011 1:27 PM

A few times when I got the error message, I re-added the file to the project (without deleting it first) and waited a while and it compiled the book succesfully after that. Some times however it did not help and I got error again. Swometimes it helped to restart the PBB Tool, but again, not always. So I am not able to say what is it really.

Bohuslav

Page 1 of 1 (8 items) | RSS