Why Logos 4.2 does not update to 4.3

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 242
Nielsen Tomazini | Forum Activity | Posted: Tue, Aug 23 2011 3:14 PM

Hello,

I am not sure what is happening, I am missing something. 
A friend of mine has Logos 4.2 installed and running but when he types in the Command Box "Update Now" the program says that there are no updates available. Why?

I checked his Program Settings and he has the Automatic Update as "Yes"

Any idea what is going on? What is the solution.

Thanks! 

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 11639
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Aug 23 2011 3:16 PM

Beta Channel? Look for the exact L4 version under ? / About Logos Bible SW in the menu, it will tell you. EDIT: Screenshot

Running Logos 9 latest (beta) version on Win 10

Posts 847
Praiser | Forum Activity | Replied: Tue, Aug 23 2011 3:21 PM

Nielsen Tomazini:

Any idea what is going on? What is the solution.

 

Try closing Logos4 and reopening it. It will then probably tell you that an update is available. I have had the same thing happen and closing and restarting Logos pushed the update. I don't know why "update now" doesn't always seem to work.

Posts 242
Nielsen Tomazini | Forum Activity | Replied: Tue, Aug 23 2011 3:22 PM

Hy NewbieMick, 

No, it is not Beta Channel. As far as I know the 4.3 has been released and it is an update for everyone, isn't it? So, there is no need to be in Beta Channel.

www.aprendalogos.com 
Youtube: AprendaLogos

Posts 5337
Kevin Becker | Forum Activity | Replied: Tue, Aug 23 2011 3:28 PM

You can run the installer again to force an update if the program isn't recognizing it

http://downloads.logos.com/LBS4/Installer/Logos4Setup.exe

Posts 11639
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Aug 23 2011 3:31 PM

Nielsen Tomazini:
As far as I know the 4.3 has been released and it is an update for everyone, isn't it? So, there is no need to be in Beta Channel.

 Yes, that's right. However, if he was on Beta, he'd not receive the latest stable release - however, I was confused since on Beta he'd now have a 4.3 RC and only miss the SR 1. 

You say you've checked the download settings, right?

If restarting Logos doesn't help, maybe he'll need to download and install the 4.3 engine manually. EDIT: that's the link Kevin posted while I was typing.

Running Logos 9 latest (beta) version on Win 10

Posts 26512
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Aug 23 2011 3:55 PM

Nielsen Tomazini:
I checked his Program Settings and he has the Automatic Update as "Yes"

Use Internet has to be "Yes" and make sure (in "About Logos") that it does not state "Update Channel Beta".  If it is still not updating enable logging and use the web installer. Post some logs if there are issues.

EDIT: sorry, I missed the last 2 posts.

Dave
===

Windows 10 & Android 8

Page 1 of 1 (7 items) | RSS