BUG: Logos *still* starts up in bottom-left corner

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 524
Stuart Robertson | Forum Activity | Posted: Tue, Nov 22 2011 2:52 PM | Locked

This happens most times when I start Logos. Very annoying. Have to manually "maximise" window/s each time.

4.5 beta 7, OS X 10.7.2 - see screenshot:

Posts 201
Garrett Ho | Forum Activity | Replied: Tue, Nov 22 2011 2:55 PM | Locked

I can't speak to the beta, when whenever I close Logos 4 Mac while it is minimized, that happens when it opens the next time. I just make sure to close the program while maximized, or after I've already closed the Logos window. Hopefully that will help.

Posts 524
Stuart Robertson | Forum Activity | Replied: Tue, Nov 22 2011 3:02 PM | Locked

I'd prefer a fix... but will try the "work-around" in the meanwhile.

Posts 128
Doug Dunbar | Forum Activity | Replied: Wed, Nov 23 2011 4:02 PM | Locked

I'm having the same issue, but one additional step, it starts minimized to the tray. Then I click on that window and it hops over to the bottom left of the screen as in your screen shot, then I have to maximize.

Posts 128
Doug Dunbar | Forum Activity | Replied: Wed, Nov 23 2011 4:03 PM | Locked

And I am closing the program maximized.

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Nov 28 2011 3:23 PM | Locked

Anyone from Logos care to acknowledge this bug? Or is there a better way to report bugs? Perhaps calling the help desk multiple times each day will help?

Posts 29256
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Nov 28 2011 3:55 PM | Locked

Stuart - I have experienced this from time to time, but it has not reappeared for me in a while. Perhaps you should upload a log. 

macOS, iOS & iPadOS | Logs |  Install

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Nov 28 2011 4:13 PM | Locked

I can upload a log. But I am wondering, lately, whether there is any benefit to continuing to assist Logos with bug reports. I simply want to use Logos (and have it be a pleasure to use). I don't want to work for Logos as a QA resource. If there was a rapid, direct correlation between working for Logos for free (reporting bugs, uploading logs, etc) and bug resolution then I wouldn't mind. But the long delays and unnerving silence from Logos and its developers makes me think I'm simply wasting my time.

This bug has been reported before almost a year ago.

Posts 29256
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Nov 28 2011 5:00 PM | Locked

Stuart Robertson:
This bug has been reported before almost a year ago.

I had the problem almost a year ago, but it has since stopped. It would be helpful for you to upload a log.

macOS, iOS & iPadOS | Logs |  Install

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Tue, Nov 29 2011 2:11 AM | Locked

Doug Dunbar:

And I am closing the program maximized.

Wonder what happens if resize Logos window slightly smaller than maximized before closing ?

Keep Smiling Smile

Posts 29256
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Nov 29 2011 4:09 AM | Locked

I also wonder what computers are being used. When I first got Logos, I used both my MacBook Pro and my iMac. Their specs were similar, but the iMac had more ram. I have since upgraded the ram in the MacBook, and use it almost exclusively. I have not experienced the problem regularly in quite a while and am wondering if the issue relates to switching between the two computers (with different monitor sizes).

macOS, iOS & iPadOS | Logs |  Install

Posts 524
Stuart Robertson | Forum Activity | Replied: Tue, Nov 29 2011 4:44 AM | Locked

Macbook Pro 17", late 2010 model, 8GB RAM, 1920x1200

Posts 29256
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Nov 29 2011 5:03 AM | Locked

Stuart Robertson:
Macbook Pro 17", late 2010 model, 8GB RAM, 1920x1200

Stuart - That is identical to my #1 computer. I really do not use my iMac for Logos right now (mostly because of its current location), but I do start it up to update it regularly. 

macOS, iOS & iPadOS | Logs |  Install

Posts 396
Fernando A Gonzalez | Forum Activity | Replied: Thu, Dec 1 2011 8:36 AM | Locked

Stuart Robertson:

This happens most times when I start Logos. Very annoying. Have to manually "maximise" window/s each time.

4.5 beta 7, OS X 10.7.2

I had this happening with B7, updating to B8 fixed it.

Blessings, Fernando

Posts 29256
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Dec 1 2011 10:56 AM | Locked

Oh Fernando, I have missed your fawning over the next beta release. Hopefully 4.5 will go live soon so we can get some more Wilted Flower from you. Smile

macOS, iOS & iPadOS | Logs |  Install

Posts 1432
Tonya J Ross | Forum Activity | Replied: Thu, Dec 1 2011 3:33 PM | Locked

Stuart~ This issue was reported and subsequently fixed previously.  The reoccurrence seems to be a different issue displaying the same errant behavior; it may now be more related to Lion compatibility issues as it does not seem to be reproduceable on any other OS.  In fact,  I did run across this issue early on in Lion compatibility testing and it was reported once more to Development at that time.  If anyone has experienced the issue recently on a different OS that would be very useful information to know.

Over the last few days I've done some more testing on several different systems trying to further pin down when this issue seems to appear.  I've tested the situations included in this thread, as well as the ones I have suspected in the past, and as Fernando mentioned, the issue has not reappeared in 4.5 Beta 8 for me.  

If you, or anyone else for that matter, are still seeing this issue in Beta 8 then the best thing we can provide to Development is going to be your layouts.db file and a screencast of the program being shown open (including all floating windows) and then closed/reopened where the problem occurs.  This can be accomplished either using a free utility like Jing or by calling our Customer Support Department and allowing a tech to remote into your computer and capture information about your particular computing environment on Development's behalf.  

I realize that is asking for more effort on the user's part, but without being able to recreate the problem internally there isn't another feasible option for collecting the necessary information to resolve the issue.

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Dec 1 2011 5:22 PM | Locked

Ok - I will see what beta 8 brings. If the bug is still there I'll upload layouts.db, etc. 

Posts 524
Stuart Robertson | Forum Activity | Replied: Tue, Dec 6 2011 2:11 PM | Locked

8156.LogosLogs Stuart Robertson 20111206-093700.gz

Bug is still there in beta 8. Tried 3 times to upload layouts.db (5.5MB) or layouts.db.zip (5.1MB) but the upload fails each time with "An error occurred while processing your request.". After today's 4 crashes and 1-minute startup time my irritation with Logos as a product is high enough that I'm not going to ask how else I can get the layouts.db file to Logos. To tell the truth I don't know why I have even bothered with this bug report. But here are the screenshot and log files.

 

 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 7 2011 12:53 AM | Locked

Stuart Robertson:
To tell the truth I don't know why I have even bothered with this bug report. But here are the screenshot and log files.

Apologies: attached file has old logs (e.g. Logos4.log is from 2 Dec 2011); please see reply => http://community.logos.com/forums/p/41780/311365.aspx#311365

Wonder if can email zip file to Logos Mac Support => http://www.logos.com/about/contact with reference to this thread ?

Screen shot is helpful; noticed double arrow in upper right corner, wonder if can resize Logos Bible Software 4 window, then update layout, close and open Logos 4 Mac.

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Dec 7 2011 3:02 PM | Locked

After receiving a Resource Installer pop-up, closed Logos 4.5 Beta 8 running on Snow Leopard (10.6.8 with ATI Radeon HD 5750 graphics).  Personally launch to Home Page so nominally not see desktop image in this screen shot (nomimal window size is bit less than maximized):

Resized Logos Bible Software 4 to nominal size, then closed, attaching Logos4.log file:

0116.Logos4.log.zip

Console Messages had one line before earlier close (used command + Q to close instead of resource installer):

7-12-11 7 Dec 11 @ 3:17:51 PM Logos Bible Software 4[313] NativeWorkState destructed

Attaching Logos4.log with close a minute after console message:

7624.Logos4.log.zip

Next launch had nominal size with window displaced slightly to the right (when closed, had no gap):

Keep Smiling Smile

Page 1 of 1 (20 items) | RSS