LOGOS4 Update contains virus TR/Dropper.Gen5

Page 1 of 1 (16 items)
This post has 15 Replies | 2 Followers

Posts 471
Leo Wee Fah | Forum Activity | Posted: Thu, Jan 26 2012 4:26 AM

I was trying to update LOGOS4, but the anti-virus detected a virus with the file Logos4.com : contains virus TR/Dropper.Gen5

What must I do..?

 

Thanks.

Posts 23213
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Jan 26 2012 4:34 AM

Hi Leo

There have been a number of people experiencing these issues with various virus checkers. It is a false positive and you need to arrange for  Logos4\Logos4.exe and  Logos4\System\Logos4.exe  configured as exceptions to scanning

See http://community.logos.com/forums/t/44286.aspx for another discussion on this

Hope this helps

Graham

 

Posts 471
Leo Wee Fah | Forum Activity | Replied: Thu, Jan 26 2012 6:06 AM

Thanks.. I have set the exception in Avira.. but after restarting my PC, it still showed virus when I tried to click on LOGOS.. I then restored the logos4.exe from Avira to Logos4\ and LOGOS4\System\ (not realising they are actually different file sizes). Now I can not start LOGOS4 at all..!

I tried to copy a Logos4.exe from my laptop to PC's LOGOS4\System, but still can not start LOGOS4, what remedy could be done now...??

Help........

 

Posts 5337
Kevin Becker | Forum Activity | Replied: Thu, Jan 26 2012 6:29 AM

Try disabling your antivirus and reinstalling Logos from:
http://downloads.logos.com/LBS4/Installer/Logos4Setup.exe

Posts 471
Leo Wee Fah | Forum Activity | Replied: Thu, Jan 26 2012 6:47 AM

I tried the Logos4Setup.exe.. and it showed "Logos Bible Software is up-to-date"..

When I tried to run LOGOS, it stopped with this remark: "Logos Bible Software 4 has stopped working"..

Posts 569
J. Morris | Forum Activity | Replied: Thu, Jan 26 2012 6:57 AM

A bit off topic but...  I am in need of a change in anti-virus software.  I haven seen this particular problem pop up on the forums over the past few days and I want to make sure I don't get the virus software that is cause so much issue with Logos. 

Is it only one particular software program that is causing this and if so, what is the name of it so I can make sure and avoid it.

Thanks muchly

Posts 18902
Rosie Perera | Forum Activity | Replied: Thu, Jan 26 2012 7:08 AM

J. Morris:

A bit off topic but...  I am in need of a change in anti-virus software.  I haven seen this particular problem pop up on the forums over the past few days and I want to make sure I don't get the virus software that is cause so much issue with Logos. 

Is it only one particular software program that is causing this and if so, what is the name of it so I can make sure and avoid it.

People have reported false positives with Avira and Webroot in the past. Any very thorough anti-virus program will occasionally come up with false positives. The thing is you want one where there are frequent updates of the virus database, and the developers are very responsive to adding new/unfamiliar software to their database of trusted programs when people report them as false positives.

I am using AVG and am very happy with it, but I also have Malwarebytes installed just as a virus checker for downloaded programs from freeware sites, where I'm nervous about running them before a double check.

Posts 8692
LogosEmployee

Leo Wee Fah:

Thanks.. I have set the exception in Avira.. but after restarting my PC, it still showed virus when I tried to click on LOGOS.. I then restored the logos4.exe from Avira to Logos4\ and LOGOS4\System\ (not realising they are actually different file sizes). Now I can not start LOGOS4 at all..!

I tried to copy a Logos4.exe from my laptop to PC's LOGOS4\System, but still can not start LOGOS4, what remedy could be done now...??

In the Logos4\Install\Installers folder, you should find Logos4.msi. Right-click this and choose Repair; it should repair all the files to the versions that were originally installed.

Posts 8692
LogosEmployee

J. Morris:

A bit off topic but...  I am in need of a change in anti-virus software.  I haven seen this particular problem pop up on the forums over the past few days and I want to make sure I don't get the virus software that is cause so much issue with Logos. 

Is it only one particular software program that is causing this and if so, what is the name of it so I can make sure and avoid it.

There are two different antivirus programs causing problems with this update: Avira and Webroot.

There are good, free antivirus programs out there; probably the two most popular are avast! Free Antivirus, AVG Anti-Virus FREE, and Microsoft Security Essentials. I've used both avast and MSE (not on the same computer!) and haven't had them report a problem for Logos 4 (so far... Smile).

Posts 471
Leo Wee Fah | Forum Activity | Replied: Thu, Jan 26 2012 7:57 AM

Dear Bradley, I looked into my Logos4\install, it did not contain any file or subfolder..

Posts 5
Jean Wilson | Forum Activity | Replied: Thu, Jan 26 2012 9:27 AM

Hi Leo:

Try the "other" Logos4\install folder....

C:\Users\"your login ID"\AppData\Local\Logos4\Install

 

Posts 1178
David Wilson | Forum Activity | Replied: Thu, Jan 26 2012 9:32 AM

More specifically: the "Installers" folder.... Smile

C:\Users\"your login ID"\AppData\Local\Logos4\Install\Installers

Posts 471
Leo Wee Fah | Forum Activity | Replied: Thu, Jan 26 2012 3:55 PM

Thank you all for your generous offers of assistance.. my Logos is up and running now.

THANKS..!

 

Posts 471
Leo Wee Fah | Forum Activity | Replied: Thu, Jan 26 2012 4:24 PM

I spoke too soon.. while moving around in Logos.. system stopped again when I tried to see the details of 25th Jan update.. malware deteted again in Logos4\Logos4.exe.. checked  Avira `exception' - blank' (actually I had set the exception yesterday).. input back Logos4\Logos4.exe and Logos4\System\Logos4.exe

Still blocked by Avira.. so I ran from Logos4\System\Logos4.exe, and it worked.. for a short while..

I tried logos.msi 2nd time, and straight away Avira detected malware in Logos4\Logos4.exe.

Now waht must I do...?

 

Posts 1178
David Wilson | Forum Activity | Replied: Thu, Jan 26 2012 8:31 PM

Change to different anti-virus software Embarrassed

Posts 25864
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jan 26 2012 10:32 PM

Leo Wee Fah:

Still blocked by Avira.. so I ran from Logos4\System\Logos4.exe, and it worked.. for a short while..

I tried logos.msi 2nd time, and straight away Avira detected malware in Logos4\Logos4.exe.

Now waht must I do...?

Try this fix  http://community.logos.com/forums/p/44395/330581.aspx#330581

Dave
===

Windows 10 & Android 8

Page 1 of 1 (16 items) | RSS