Logos 4 Upgrade

Page 1 of 1 (12 items)
This post has 11 Replies | 1 Follower

Posts 10
Christopher Heil | Forum Activity | Posted: Wed, Nov 11 2009 3:09 PM

I just committed a help desk offense and tried to describe the problem I was having from memory rather than while working through it on the computer and consequently got my initial description of the problem completely wrong.  Here is my REAL problem:

Logos 4 completed the app install.  Upon first startup (and all subsequent start ups), I immediately get an error dialog that "Logos 4 has stopped working."  The app never opens at all.  Reading through other threads, I tried to hold down CTL while starting, which did nothing different.  I went to rename my shortcuts.db file, but I did not have a documents folder.  I also tried to turn on debugging, but again with no documents folder, I do not know where the log file would be put.  Any other suggestions?

I am running Vista Enterprise SP2 with 4GB RAM.

Thanks in advance!

***

Ignore everything below this - my original post!

Do I have to have Logos 3 installed already on a computer to do an "upgrade" to Logos 4?  I had Logos 3 installed on my computer at home and completed the upgrade to Logos 4.  (I love it!)  I just received a new laptop at work and had not reinstalled Logos 3 on it.  I tried to do the same upgrade, but the installation process crashes at the point that I thought the other install was starting to index resources, but not sure.

Thanks in advance for you help.

Posts 235
Tom Geswein | Forum Activity | Replied: Wed, Nov 11 2009 3:23 PM

Logos 4 is a stand-alone product and does not require an installation of Logos 3, although having L3 installed could help when installing new resources from a CD.  Yesterday I installed Word Biblical Commentary and had to run the installer through Logos 3, then I synced my licenses, and then Logos 4 saw my licenses on the Logos server and downloaded the files for me. (I currently don't know any other way of doing this besides calling Logos on the phone...)

But to answer your original question, No, it is not required.

"It seems our problems solve themselves when we look beyond us to those truly in hell."  -  Beyond Our Suffering - AILD

Posts 97
Greg Gray | Forum Activity | Replied: Wed, Nov 11 2009 3:25 PM

No you don't need V3 installed.

 

Check out this thread to simplify multiple instillations for you:

http://community.logos.com/forums/t/3629.aspx

Posts 5337
Kevin Becker | Forum Activity | Replied: Wed, Nov 11 2009 3:28 PM

Having 3 installed could mean a smaller download. It depends on how many resources that you own under LSDS 3 that have been optimized/rebuilt for L4. However, if the CDs you use to install 3 are old chances are most of your resources have been updated and will just download again.

My recommendation: don't install LSDS 3 unless you need one of its features that isn't in Logos 4 yet.

Posts 24454
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Nov 11 2009 6:39 PM

ChristopherHeil:
Logos 4 completed the app install.  Upon first startup (and all subsequent start ups), I immediately get an error dialog that "Logos 4 has stopped working." 

Please describe the installation in detail  eg. installed from {DVD, web site} then came a big download? + lengthy indexing that completed OK?

Did you make a custom install to a folder of your choice?

You might need to perform logging at some time so unzip the attached file into "\My Documents\Logos Log Files"  (if you have to create the folder then you need to enable logging before you next start L4). Zip any log files and attach them to a post when requested.

4747.EnableLogging.zip

Dave
===

Windows & Android

Posts 10
Christopher Heil | Forum Activity | Replied: Wed, Nov 11 2009 7:55 PM

Hi Dave.  I downloaded the PC version of the install file from logos.com and ran that.  It installed the logos 4 prerequisite install and the logos 4 main app install, but did not appear to even start the longer download process and indexing.  (I installed this on my home computer and remember that long download and index process and it did not happen with this.)

In terms of directory, I chose the typical install and the app was installed to the default directory (C:\Users\CERCPH\AppData\Local\Logos4).

I do not have a My Documents directory only a Documents directory.  (Not sure if that matters).  I tried to enable the logging prior to last starting the app, but I'll try what you have suggested.

Posts 10
Christopher Heil | Forum Activity | Replied: Wed, Nov 11 2009 7:58 PM

I unzipped the zip file to \Documents\Logos Log Files, ran the enable file and re-started Logos.  It crashed again and I did not get any log files.

Posts 8601
TCBlack | Forum Activity | Replied: Wed, Nov 11 2009 8:11 PM

ChristopherHeil:
I downloaded the PC version of the install file from logos.com and ran that.  It installed the logos 4 prerequisite install and the logos 4 main app install, but did not appear to even start the longer download process and indexing.

That sounds like a firewall is blocking the outbound connection (or perhaps the inbound...)  have you got a firewall on this computer?

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 10
Christopher Heil | Forum Activity | Replied: Wed, Nov 11 2009 8:42 PM

This is a work laptop and the administrator does have Windows Firewall enabled.  I added Logos 4 to the exception list though and still getting the same exact symptoms.

Posts 7906
LogosEmployee

ChristopherHeil:

This is a work laptop and the administrator does have Windows Firewall enabled.  I added Logos 4 to the exception list though and still getting the same exact symptoms.

A crash immediately on starting the program (without even seeing the Sign In screen, and with no log files being generated) is typically due to one of two things:

1) Bad installation of the .NET Framework. Microsoft was supposed to take care of this for us Smile, but that doesn't seem to always be the case. Try repairing .NET Framework 3.5 SP 1 from Add/Remove Programs, or uninstall and reinstall.

2) Compatibility Mode. Right-click the Logos 4 shortcut and ensure that no Compatibility settings are enabled.

 

Posts 10
Christopher Heil | Forum Activity | Replied: Fri, Nov 13 2009 11:26 AM

I first tried to do a repair fo the .NET framework and when that did not work, did the uninstall/reinstall you recommended.  I am up and running with Logos 4 on my laptop now.  Thanks so much for all the suggestions and help!

Also just wanted to reiterate how happy I am with Logos 4.  My only complaint is that I am already behind on my reading plan because the home page keeps pulling me in 20 other directions in my library for reading and study.  Stick out tongue  I'm learning about things I never even knew I did not know about all because of the articles on the home page.  Great, great work!

Posts 19
Diederick Rudolph Schwartz | Forum Activity | Replied: Sat, Nov 14 2009 2:19 AM

i have exactly the same problem.  After installing the program it worked well, albeit a bit slow, i must say!  Then the tray icon alerted me to an update for the program.  I downloaded the update, i ever since i get this annoying message.  Logos4 does not work, and I am in a bit of a problem with Sunday approaching!  I uninstalled Logos 4 from the control panel and tried again - the result is just the same.

I am a bit disappointed!

Rudi

Page 1 of 1 (12 items) | RSS