Search problem

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 1
Todd M. Dick | Forum Activity | Posted: Wed, May 23 2012 12:52 PM

When I search Bible text, my search engine does not retrieve verses according to my search parameters.  In fact, the results make no sense.  Letters are highlighted that have nothing to do with what I searched and the "found" letters are inconsistent.  

I am using Logos 4.2a on my macbook.  This problem just started a few days ago and I cannot correct the problem.  

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 23 2012 1:18 PM

Todd M. ***:
I am using Logos 4.2a on my macbook.

Welcome Big Smile

The current stable Logos 4 Mac release is 4.5b SR-2; wonder about upgrading Logos 4 Mac application ? Wiki Mac Troubleshooting has => Update Error that includes current download links for stable and beta Logos 4 Mac releases.

Todd M. ***:
When I search Bible text, my search engine does not retrieve verses according to my search parameters.  In fact, the results make no sense.  Letters are highlighted that have nothing to do with what I searched and the "found" letters are inconsistent.  

Please elaborate a bit since would like to try replicating Bible search.

Wonder about search parameters ?

One option is attaching screenshot showing search parameters and results.

Keep Smiling Smile

Posts 28475
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, May 23 2012 1:55 PM

Todd M. ***:
I am using Logos 4.2a on my macbook.

Todd, as KS4J wrote, the current version is 4.5b SR2. Your installation is more than a year old. Out of curiosity, do you have automatic updates enabled?

OSX & iOS | Logs |  Install

Posts 22
Joe Smysor | Forum Activity | Replied: Thu, May 24 2012 7:54 PM

Sorry to steal your thread Todd, but I'm having search issues too.  I can search once, but anytime I search a second time the entire program crashes.   I'm using  4.5c Beta 1  but it's been doing that the last month or two.

Posts 757
Fr. Charles R. Matheny | Forum Activity | Replied: Thu, May 24 2012 8:05 PM

Having issues here as well.

Just sayin.

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, May 24 2012 9:24 PM

Joe Smysor:
 I can search once, but anytime I search a second time the entire program crashes.   I'm using  4.5c Beta 1  but it's been doing that the last month or two.

Suggest updating to Logos 4.5c Beta 2, then if program crashes again, please start a new thread in Mac Beta forum that includes search description; would like to look at diagnostic log files for insight about crash.  Also would like to try replicating crash.  Using Logos 4.5c Beta 2, started a Syntax Search that has many results that pegged CPU to 100 % for several minutes, planning to see if can replicate search issue, then post in Mac Beta forum.

Could enable diagnostic logging, restart Mac, launch Logos 4 Mac.  If crash repeats, then compress log files and attach to a forum reply.

Optional: download and use 5504.Logos4MacLogging.app.zip to display your logging setting, then change to enable logging.

 Wiki Mac Troubleshooting has => How to Report Bugs in Logos 4 Mac

Keep Smiling Smile

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Thu, May 24 2012 9:25 PM

Fr. Charles R. Matheny:
Having issues here as well.

Any search examples to share ? for those who like to try replicating issues ?

Keep Smiling Smile

Posts 3173
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, May 25 2012 9:05 AM

Keep Smiling 4 Jesus :):
ny search examples to share ? for those who like to try replicating issues ?

 

Just repeating what KS4J said so I can get this on my list of recent "your discussions" so I can follow the thread. 

 

 

Posts 757
Fr. Charles R. Matheny | Forum Activity | Replied: Fri, May 25 2012 9:04 PM

I don't know what "so I can get this on my list of recent "your discussions" so I can follow the thread. " means. ( Am I on some bad list or something?)

But here goes: at times when trying to use the Search function, the drop down menu's get "scrambled" , "stop working' ( won't open to show drop down) and/or, allow change.

At times, I change the search criteria ( areas ) and yet, the change apparently does not "take" .

When this happens, (even though visual indicators allow me to think I have changed the search areas) I get results that make no sense considering what I was looking for.

At other times, I get results that may be related, but in areas not expected.

The only cure I have found is to close out of search completely and try again, if still having issues : Close Logos, Restart, Change Open texts ( which changes all open guides), then go back to search.

At this point I usually have a "clean" search box and usually don't have an issue.

Only things I have noticed that may or, may not be of any help is: I wonder if the "sync" function is having any bearing, never seem to get through a working session without that thing going into the "Yellow Triangle-Sync Failed Mode" .

And/or : if this is some sort of "Memory Hang" issue. The reason I put this forward is because it seldom happens with my "First" search, but with later searches.

Is it possible that when starting a new search, part of the commands from the last one are being "hung-over" into the new one thus not allowing the changes in area/book etc, even when the visual indication is that the change has been made. Would this explain the whole search menu area getting all "scrambled" at times?

As far as a list of my discussions (complaints) : I just want what bought and am buying,  to work as advertised, somehow, I feel like that is a reasonable expectation on my part.

I am using latest stable release.

Blessings



Posts 28475
Forum MVP
JT (alabama24) | Forum Activity | Replied: Fri, May 25 2012 9:14 PM

Fr. Charles R. Matheny:
I don't know what "so I can get this on my list of recent "your discussions" so I can follow the thread. " means. ( Am I on some bad list or something?)

He just meant so that he could follow & find the thread. It is a feature of the forums. He didn't mean any ill intent. 

OSX & iOS | Logs |  Install

Posts 757
Fr. Charles R. Matheny | Forum Activity | Replied: Fri, May 25 2012 9:33 PM

Thanks Alabama: Yes,  Mr. Ball has been very kind to me, has followed up well. He is most of the reason I have not called and asked for a refund.

Thus: My apologies Tommy ( and all ) for being caustic , please forgive.

Just tired of it all. 

BTW, FWIW in trying to make things better: 5 or 6 crashes this week.

Search dysfunction not related to crashes, separate issues ( I think ).

Blessings

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, May 25 2012 11:37 PM

Fr. Charles R. Matheny:

At times, I change the search criteria ( areas ) and yet, the change apparently does not "take" .

Question for Logos: does search have any hidden confirmation design like Text Comparison ? thread => http://community.logos.com/forums/p/45994/370784.aspx#370784

Fr. Charles R. Matheny:

Only things I have noticed that may or, may not be of any help is: I wonder if the "sync" function is having any bearing, never seem to get through a working session without that thing going into the "Yellow Triangle-Sync Failed Mode" .

And/or : if this is some sort of "Memory Hang" issue. The reason I put this forward is because it seldom happens with my "First" search, but with later searches.

Is it possible that when starting a new search, part of the commands from the last one are being "hung-over" into the new one thus not allowing the changes in area/book etc, even when the visual indication is that the change has been made. Would this explain the whole search menu area getting all "scrambled" at times?

Concur about sync hypothesis, especially since current design uploads, then downloads sync items, which could interact with search usage (sync client applying downloaded change while an interactive change in progress).

One way to test hypothesis is working offline for awhile, which includes a number of searches.

Changing open resources changes drop down list in search.  From description, wondering if guides and resources are linked ?

Logos 4.5c Beta 2 has an issue with clicking Analysis for Search results, which has an error in Logos4.log file plus effectively disables a number of items so need to restart Logos 4 Mac.

Fr. Charles R. Matheny:
I just want what bought and am buying,  to work as advertised, somehow, I feel like that is a reasonable expectation on my part.

+1 Yes especially would appreciate Logos 4 Mac becoming more "Mac" like for reliable usability.

Personally disappointed by the number of feature regressions in the current 4.5b stable release, which has been followed by => Feature Parity list expanding a lot, which now has 44 open items (with links to forum threads for issue replication) plus 4 items with Logos responses.

Keep Smiling Smile

Posts 1729
LogosEmployee
Hunter Clagett | Forum Activity | Replied: Sat, May 26 2012 12:33 PM

Fr. Charles R. Matheny:

Thanks Alabama: Yes,  Mr. Ball has been very kind to me, has followed up well. He is most of the reason I have not called and asked for a refund.

Thus: My apologies Tommy ( and all ) for being caustic , please forgive.

Just tired of it all. 

BTW, FWIW in trying to make things better: 5 or 6 crashes this week.

Search dysfunction not related to crashes, separate issues ( I think ).

The application is crashing? In order to diagnose the cause it would be very helpful to see your log files. 

If you could, gather and post your log files to this thread per the instructions here: http://www.logos.com/support/mac/L4/logging

 

Thanks,

- Hunter Clagett

Logos 4 Bug Report - Mac | PC

Proclaim - Mac/PC

Posts 757
Fr. Charles R. Matheny | Forum Activity | Replied: Sat, May 26 2012 4:01 PM

Dear Hunter: I just cleaned my computer ( old log files etc ) thus, it will have to wait until I have a couple more crashes.

However, Logos already has my log files ( old and recent ) which should show plenty of crashes. Crashing and/or hanging which requires a "force quit" has never been uncommon for me.

Will get you a log as soon as I can.

KSFJ: Thanks for the info, will try turning internet off and see if that helps with the search issues.

Blessings all

Posts 757
Fr. Charles R. Matheny | Forum Activity | Replied: Sat, May 26 2012 7:40 PM

New Search issue or, my ignorance.

Searching all text, in catholic resources, for pentecost.
I get a nice panel with results, however, at bottom of panel, it shows there are three pages of hits. Page 2,3,4 are light blue and when I hover over them, I get the little "hand cursor".

Problem: clicking on 2,3,4 does absolutely nothing, I cannot get to the other search rests from here.

Just sayin. 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Sat, May 26 2012 9:32 PM

Fr. Charles R. Matheny:
Problem: clicking on 2,3,4 does absolutely nothing, I cannot get to the other search rests from here.

Apologies: unable to replicate (however did find one UI bug in 4.5c Beta 2).

Wonder if diagnostic logs have any interesting messages when 2,3,4 lacks usability ?

Keep Smiling Smile

Posts 3173
LogosEmployee
Thomas Ball | Forum Activity | Replied: Mon, May 28 2012 9:19 AM

'Bama: Thank you for defending my honor :-)

Fr. Charles: I took no offense to your confusion. I'm sorry for being opaque. In addition, I'm emailing you concerning your searching problems. 

 

Page 1 of 1 (17 items) | RSS