Repeating Crash - Logos Unusable

Page 1 of 2 (24 items) 1 2 Next >
This post has 23 Replies | 2 Followers

Posts 2279
Andy | Forum Activity | Posted: Wed, May 30 2012 1:49 PM

I left L4 open with a simple layout. On trying to close said layout, L4 crashed. I am now unable to open the programme without it crashing. I am able to open to a blank layout, but as soon as I try and open any resource, L4 crashes again. It is unusable at the moment.

I have attached the logs and wonder if anyone is able to cast any insight into how I may fix this?

I updated yesterday to the latest service release.

Thanks in anticipation.

Andy

 

65865.Archive.zip

2425.Logos4Crash.txt.zip

Posts 2279
Andy | Forum Activity | Replied: Wed, May 30 2012 2:22 PM

Actually, having played around with this problem a little more, I have discovered L4 only crashes when I try and open a bible. All other resources, as far as I can tell, appear to work.

I thought I remember reading about someone encountering a problem where the Bible index/database corrupted. I seem to recall that the fix involved deleting a file and forcing L4 to rebuild.

Posts 8639
TCBlack | Forum Activity | Replied: Wed, May 30 2012 2:51 PM

You should be able to fix a broken bible index by typing the following command in the command box:

rebuild bible index

Hmm Sarcasm is my love language. Obviously I love you. 

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 30 2012 3:01 PM

Andy Evans:
I updated yesterday to the latest service release.

Looking at Logos4Crash.txt, the error message "Failed to read past end of stream" is the same as another Logos 4 Mac user; suggest calling Logos Tech Support => http://www.logos.com/about/contact that is in the Logos 4 Windows forum => http://community.logos.com/forums/p/50369/371610.aspx#371610

By the way, the archive file does not have Logos diagnostic logs: Logos4.log and Indexer.log

Optional: download and use 5504.Logos4MacLogging.app.zip to display your logging setting, then change to enable logging.

Keep Smiling Smile

Posts 164
Rick Harrell | Forum Activity | Replied: Wed, May 30 2012 3:58 PM

Had a similar problem yesterday - contacted tech support and was passed on to level 2 support. The tech (who was patient and persistent and polite) tried a number of things and finally deleted my NIV. Logos runs now, sans NIV. He said he will get back to me when he figures out the problem. 

Posts 164
Rick Harrell | Forum Activity | Replied: Wed, May 30 2012 3:59 PM

I like NASB better anyway

Posts 3173
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, May 30 2012 4:16 PM

Keep Smiling 4 Jesus :):

Andy Evans:
I updated yesterday to the latest service release.

Looking at Logos4Crash.txt, the error message "Failed to read past end of stream" is the same as another Logos 4 Mac user; suggest calling Logos Tech Support => http://www.logos.com/about/contact that is in the Logos 4 Windows forum => http://community.logos.com/forums/p/50369/371610.aspx#371610

By the way, the archive file does not have Logos diagnostic logs: Logos4.log and Indexer.log

 

Optional: download and use 5504.Logos4MacLogging.app.zip to display your logging setting, then change to enable logging.

 

Keep Smiling Smile

 

+1

 

Posts 2279
Andy | Forum Activity | Replied: Wed, May 30 2012 10:50 PM

Thanks, everyone, for the assistance.

Keep Smiling 4 Jesus :):
By the way, the archive file does not have Logos diagnostic logs: Logos4.log and Indexer.log

Apologies, KS4J, I thought I had pressed command on start up in order to initiate diagnostic logging. I used your superb script and have now attached all of the logs available.

I presume, from your response, that 'Rebuild Bible Index' is unlikely to work? Is there anything else you are able to suggest? I am happy to try hiding the NIV, but note that L4 crashes when I attempt to open any bible (or open the home page, which has bible passages embedded).

I will call technical support if there is no other alternative, but with the difference in timezones, this can make things tricky.

Thanks again for you kind assistance.

46046.Archive.zip

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 30 2012 11:13 PM

Andy Evans:

I presume, from your response, that 'Rebuild Bible Index' is unlikely to work? Is there anything else you are able to suggest? I am happy to try hiding the NIV, but note that L4 crashes when I attempt to open any bible (or open the home page, which has bible passages embedded).

I will call technical support if there is no other alternative, but with the difference in timezones, this can make things tricky.

Looking at Logos4.log file, noticed error "Failed to read past end of stream" for a media item on the Home Page.

My apologies: personally not know how to resolve "Failed to read past end of stream" error, which has been posted by three Logos 4 Mac users.  Suspect Sync Manager is encountering an error while processing a downloaded sync item.

Wonder if can work offline ? possibly a workaround until can connect with Logos Tech Support

Keep Smiling Smile

Posts 2279
Andy | Forum Activity | Replied: Wed, May 30 2012 11:29 PM

Keep Smiling 4 Jesus :):
Wonder if can work offline ? possibly a workaround until can connect with Logos Tech Support

Thanks for your patience, KS4J.

I have tried working off line, alas, the crash persists.

I will try and call technical support later.

Thank you once again for your assistance. As alway, it is very much appreciated. Have a good day.

Andy

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, May 30 2012 11:42 PM

Wonder if crash repeats when open to a blank layout ?

Keep Smiling Smile

Posts 2279
Andy | Forum Activity | Replied: Thu, May 31 2012 4:51 AM

Keep Smiling 4 Jesus :):

Wonder if crash repeats when open to a blank layout ?

This is the first thing I tried. I am able to open to a blank layout and even able to open resources. As soon as I touch a bible or try to move to the home page, L4 shuts down suddenly and unexpectedly.


 

Posts 3173
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, May 31 2012 10:32 AM

Hi Andy,

I'm going to contact you offline regarding this issue. 

Nevermind, it seems you've called us.

 

Posts 2279
Andy | Forum Activity | Replied: Thu, May 31 2012 11:00 PM

Thanks, Tommy. I am about half way through reindexing and am hopeful that this will address the problem.

Thank you again for your assistance.

Posts 1875
Paul-C | Forum Activity | Replied: Fri, Jun 1 2012 6:22 AM

Hi Andy, are you hoping this issue will be resolved by doing a full re-index?  Just checking for future reference!  Very best of luck with that!

Posts 2279
Andy | Forum Activity | Replied: Fri, Jun 1 2012 10:27 AM

Paul Clarke:
are you hoping this issue will be resolved by doing a full re-index?  Just checking for future reference! 

Hi Paul,

Just to confirm that rebuilding the index did successfully fix the problem. I do wonder, with hindsight, whether just rebuilding the Bible index would have fixed the problem (as the crash occurred when selecting Bibles).

Paul Clarke:
Very best of luck with that!

It took around 20 hours to reindex 5630 resources on the recent MBA... 

I am very pleased to have Logos back and working.

Thank you to the tech team for the excellent customer support.

Posts 1875
Paul-C | Forum Activity | Replied: Fri, Jun 1 2012 3:01 PM

Glad it's all worked out Andy! Yes

Posts 61
Jason Brueckner | Forum Activity | Replied: Sat, Jun 2 2012 1:17 PM

Mine is repeatedly crashing -- I can open it to a blank document, but it crashes every time that I try to click on any resource or even load the HOME screen.

 

I am about to just delete and reinstall the whole thing, but it takes so darn long.

Posts 61
Jason Brueckner | Forum Activity | Replied: Sat, Jun 2 2012 1:21 PM

1016.Indexer.log7762.Logos4Crash.txt7652.Logos4Error-2.logHere are my logs ... just in case someone has some input.

 

8321.Logos4Error.log

Posts 2279
Andy | Forum Activity | Replied: Sat, Jun 2 2012 3:09 PM

Jason B.:
I am about to just delete and reinstall the whole thing, but it takes so darn long.

Hi Jason,

I am not proficient enough in reading logs to be able to diagnose whether your issues are the same as mine. I thought, however, it was worth clarifying that a complete reindex fixed the issues I was experiencing. I do wonder whether the command, 'rebuild bible index', would have achieved a positive result as the error only occurred when I accessed bibles. This would have taken considerably less time than a complete reindex. Most significantly, I did not need to uninstall/reinstall L4. 

I am not advising that you reindex (which will not do any harm, but will take a very long time), but would caution you against taking the drastic step of reinstalling unless you have absolutely no choice whatsoever. 

I appreciate that tech support is closed over the weekend, but I am sure they will be able to assist should you be able to wait until Monday.

In summary, I would caution you to only reinstall as a last resort. It may well be that another forum user can make sense of your log files and advise accordingly.

God bless,

Andy

Page 1 of 2 (24 items) 1 2 Next > | RSS