Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 68
vandevsr | Forum Activity | Posted: Mon, Jul 23 2012 7:52 AM

Running a rooted Sony ereader (PRS-T1), with Android 2.2, and Logos Bible App build 47 seems to crash.

App works great the first time running.  But after some moves (going to library, or home, or search or settings) that set of menu options stops working.  Upon selection of Library, Search, Home or Settings, it will always just go back to reading view. 

Please see if there's something in this attached CatLog:8284.2012-07-23-09-34-52.txt

Posts 68
vandevsr | Forum Activity | Replied: Thu, Jul 26 2012 11:51 AM

Maybe I should have had the word "Bug" in the subject line.  There's been no response so far.

Posts 24842
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Jul 26 2012 7:16 PM

Steve Vandevelde:

Maybe I should have had the word "Bug" in the subject line.  There's been no response so far.

"Crash" should be sufficient as they could still be analysing the log that you included without being prompted.

Dave
===

Windows & Android

Posts 68
vandevsr | Forum Activity | Replied: Sun, Aug 12 2012 8:09 PM

Update:

To make it easier on myself (rather than install and try it out and then restore to previous version of the app) I try out the Vyrso app on the rooted Sony Ereader.

The Vyrso app behaves in the same way for me.  I'm now on version 2.0.7 (Build 40).  Surprisingly, I can (momentarily) get the menu to become responsive again by recalling a "Favorite".  This is how I do it: when I'm reading a resource I can get the "lesser" menu by touching somewhere in the open resource (not using the menu button).  [It has the "+ * aA" buttons and reading progress bar].  I can use the "+" action button to add a favorite, then use the "*" favorite button to recall the favorite.  I wouldn't count this a work-around but maybe it will help in the software development and troubleshooting of this bug.

Posts 2691
DominicM | Forum Activity | Replied: Mon, Aug 13 2012 8:06 AM

is build 47 last build for 2.x  its just we are in buld 51 now.. maybe has been fixed in later build 

Never Deprive Anyone of Hope.. It Might Be ALL They Have

Posts 327
LogosEmployee
David Schwegler (Faithlife) | Forum Activity | Replied: Mon, Aug 13 2012 12:07 PM

Steve Vandevelde:
The Vyrso app behaves in the same way for me.  I'm now on version 2.0.7 (Build 40). 

Hi Steve,

Can you clarify what you mean by "not responsive"? I.e. do other parts of the app still respond after this occurs, or do you get an ANR ("Application is not responding" dialog with an option to force close the app)?

Thanks!

Posts 68
vandevsr | Forum Activity | Replied: Sat, Aug 18 2012 1:40 PM

I just installed and tried out Vyrso 2.0.9 (Build 42).  It has the same problem.

To say it's unresponsive is not quite right.  And I do not get an ANR.  All menu functions simply return me to the reading mode.  By all menu I mean all the real-estate given to the menu so in this case 80% of the screen is devoted to 4 tabs of menu (library,search, news, settings) and off to the right there is a vertical portion of the reading view.  If I press anywhere in the 80% area (the tabs themselves, or sub-menu items like favorites and search) the app responds only in one way: returns me to reading view.  In fact, once the menu has been called up there is only one action from that screen (touching anywhere on that screen) the app returns me to reading view.

Does this help, or do would you like a another log-file?

Posts 582
Gary O'Neal | Forum Activity | Replied: Fri, Sep 21 2012 2:30 PM

Steve

 

I know this is an old thread, but I was searching for help on loading Logos Bible app on my Sony prs-t1. Could you point me to a guide on how you accomplished this? I've tried to follow the instructions from D. Miller, but there are a couple of places he points you to a site with German instructions.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 6481
Forum MVP
Lynden Williams | Forum Activity | Replied: Fri, Sep 21 2012 2:48 PM

Gary, depending on which version of Android you are running, go here and download the file if you do not have access to the google store. http://community.logos.com/forums/96.aspx

Everything ever written in Religion and Theology formatted for Logos Bible Software.Logos Youtube Channel

Posts 68
vandevsr | Forum Activity | Replied: Fri, Sep 21 2012 3:05 PM

It's been a few months, so it's not fresh anymore.  I assume you are talking about rooting the e-reader.  I remember it took me a bit to get where my e-reader is now.  To be clear, I can only get Logos 1.13 working (Logos build 43).  Even though the Sony e-reader comes with Android 2.2.1 it does not run the newer version of the app. (everything defaults to reader mode, no setting or library function).

The site http://wiki.mobileread.com/wiki/PRST1_Rooting_and_Tweaks is the one I went with.  I definitely had to repartition (which is risky business).  I used a free MiniTool Partition Wizard. (trick is to restart this program between applying steps, http://www.mobileread.mobi/forums/showthread.php?t=178199&page=2 and unplugging usb and reinserting, due to no-refresh issues I've had).

The package i went with was Rupor's stable release listed here http://sonyfmngr.sourceforge.net/prsT1.htm. It downloads as rupor-minimal.7z which is hard to unzip.

Count on a day of messing around if you are not scared by adventure.  It's also quite possible to brick it.

Posts 582
Gary O'Neal | Forum Activity | Replied: Fri, Sep 21 2012 7:26 PM

Steve Vandevelde:
To be clear, I can only get Logos 1.13 working (Logos build 43).  Even though the Sony e-reader comes with Android 2.2.1 it does not run the newer version of the app. (everything defaults to reader mode, no setting or library function).

Ok -- that was probably my problem. I tried both of the current versions (2.0.11 and 1.14). I'll try 1.13.

I did get the SD partitioned and rooted the PRS-t1. Did you have to use the Link2SD app also?

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 582
Gary O'Neal | Forum Activity | Replied: Sat, Sep 22 2012 5:41 PM

Ok -- I got it working. I had previously rooted the reader and partitioned the SD card. I pretty much followed the instructions at - http://www.mobileread.com/forums/showpost.php?p=2147654&postcount=1 . I restored it with the restore package at http://projects.mobileread.com/reader/users/porkupan/PRST1/flash_packages/ .

I then rooted it with the minimal package from http://sonyfmngr.sourceforge.net/prsT1.htm . I also used the App2SD package from the same page. After that I installed Bible app 1.13 and moved it to the SD card. Everything worked fine.

At the moment, I'm playing with the latest update of the Bible app and I'm not having the trouble you mentioned above.

 

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 68
vandevsr | Forum Activity | Replied: Sat, Sep 22 2012 8:21 PM

Gary, can you confirm that it a new version (2.x) of the Bible app works for you?  For me, I have trouble using the menu, after this sequence.  Read a book.  Change a setting, read a book, go to library.  Immediately the menu stops working for me and only sends me back to reading mode.

It only takes a minute for you to check that, and if you can confirm it works or doesn't for you, I'd be grateful.

Posts 582
Gary O'Neal | Forum Activity | Replied: Sun, Sep 23 2012 3:09 AM

Shortly after I posted above I noticed that it was doing exactly like you described. I've reinstalled the older version.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 68
vandevsr | Forum Activity | Replied: Mon, Dec 31 2012 8:00 AM

FIX?!!

Out of desperation I've tried a number of things to get the newer versions of Bible and Vyrso to work on my Sony E-reader PRS-T1.

The Problem: menu fails to work after successive attempts, and always renders reading view.  See previous posts in this thread.

The Solution? Make a multi-fingered gesture in the menu portion of the screen.  I use two fingers (one above the other) then pivoting on one, I slide the other finger in a semi-circle.  The gesture for rotating a picture 90 degrees.  This tempts the reading view, but then cancels the reading view.  Now the menu tabs become available.

Can anyone confirm this works for them, on both Bible or Vyrso?

Posts 582
Gary O'Neal | Forum Activity | Replied: Mon, Dec 31 2012 5:08 PM

I'll try to play with this later tonite--I've been wanting to update my version but have held off because of the previous problems.

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Posts 582
Gary O'Neal | Forum Activity | Replied: Mon, Dec 31 2012 10:43 PM

I got the updated Bible app loaded--using the twisting motion you described did enable me to access the menu. I also found that other motions worked--the easiest for me was a long downward motion then sweeping either left or right. I don't have Vyrso loaded.

 

πάντα εἰς δόξαν θεοῦ ποιεῖτε

Page 1 of 1 (17 items) | RSS