B2 BUG: Very Odd Behaviour in Morph Visual Filters

Page 1 of 1 (12 items)
This post has 11 Replies | 0 Followers

Posts 804
Richard Lyall | Forum Activity | Posted: Thu, Nov 26 2009 6:59 PM | Locked

I'm working on a Visual Filter to highlight Verb Tenses in GRAMCORD Greek Bibles.

Unless I'm missing something important, there is something quite odd going on.

  1. The morph code @V??A is supposed to highlight all the aorists. But nothing shows up.
  2. If I change to @V??P all the PARTICIPLES highlight, with no other settings changed. I think the morph code for participles in GRAMCORD should be @V????P i.e. 
  3. As soon as I type the "P" in "@V??P" it is PARTICIPLES in column 6 that highlights, not "Present" in column 4.
  4. ... Both @V??P and @V????P highlight the participles! This is surely wrong.
  5. There is no way to highlight all the verbs of a particular tense without adding soemthing else e.g. Mood later on in the string e.g. @V??A?I

Summary - morph codes of form @V??X (where X = A,P etc) do not work.

Please see below ...

Could someone please confirm this - apologies if I've missed something important, but it seems like there's a problem here.

Thanks
Richard

So I tick a few moods, and it works as intended:

P.S. One V.Filter searches in "1GreekBibles", the other in "All Resources" - it doesn't matter.

 

Posts 4508
Robert Pavich | Forum Activity | Replied: Fri, Nov 27 2009 1:38 AM | Locked

Richard,

I can confirm all of this behavior... Tongue Tied

Robert Pavich

For help go to the Wiki: http://wiki.logos.com/Table_of_Contents__

Posts 804
Richard Lyall | Forum Activity | Replied: Sat, Nov 28 2009 5:43 AM | Locked

Just bumping this one to make sure Logos picks it up - is this on the fix list?

Thanks
Richard

Posts 4
tom csora | Forum Activity | Replied: Mon, Nov 30 2009 11:13 AM | Locked

I too have experienced this.  How do we send this to Logos as needed fix?

Posts 725
Chris Elford | Forum Activity | Replied: Mon, Nov 30 2009 11:50 AM | Locked

tomcsora:

I too have experienced this.  How do we send this to Logos as needed fix?

You just did. They read all these threads and will pick it up.

Chris

Posts 5337
Kevin Becker | Forum Activity | Replied: Mon, Nov 30 2009 11:50 AM | Locked

Richard Lyall:

I'm working on a Visual Filter to highlight Verb Tenses in GRAMCORD Greek Bibles.

Unless I'm missing something important, there is something quite odd going on.

  1. The morph code @V??A is supposed to highlight all the aorists. But nothing shows up.
  2. If I change to @V??P all the PARTICIPLES highlight, with no other settings changed. I think the morph code for participles in GRAMCORD should be @V????P i.e. 
  3. As soon as I type the "P" in "@V??P" it is PARTICIPLES in column 6 that highlights, not "Present" in column 4.
  4. ... Both @V??P and @V????P highlight the participles! This is surely wrong.
  5. There is no way to highlight all the verbs of a particular tense without adding soemthing else e.g. Mood later on in the string e.g. @V??A?I

I've ran into this bug with the present. I fooled the program by using @V??P??? to help it differentiate between Present and Participle.

Posts 4
tom csora | Forum Activity | Replied: Mon, Nov 30 2009 12:15 PM | Locked

Thanks Kevin.  I'll give it a try.  The famous work around, I only though that was used for MS products Stick out tongue

Posts 8016
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Tue, Dec 8 2009 11:45 AM | Locked

Richard Lyall:

Just bumping this one to make sure Logos picks it up - is this on the fix list?

Yes, this has been added to our bug database.

As a workaround, you could use the NA27 with Logos morphology. Searching it for "@VA", "@VP", etc. works correctly.

Posts 1
Jeff Sensenstein | Forum Activity | Replied: Wed, Dec 16 2009 11:26 AM | Locked

Same problem, using the work around seems to help.  Having to type @V??P?? seems a little odd. Thanks for adding to the fix list.

Posts 8016
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Wed, Dec 16 2009 12:56 PM | Locked

Bradley Grainger:

Yes, this has been added to our bug database.

This will be fixed in 4.0b.

Posts 1366
Ben | Forum Activity | Replied: Tue, Jan 26 2010 5:31 PM | Locked

Hey, how do you get that nice morphology drop-down panel to appear?

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 5337
Kevin Becker | Forum Activity | Replied: Tue, Jan 26 2010 6:10 PM | Locked

Ben:

Hey, how do you get that nice morphology drop-down panel to appear?

Type @, the morph picker should show up.

Page 1 of 1 (12 items) | RSS