BUG: Footnotes do not appear when exported into MS Word

Page 1 of 1 (18 items)
This post has 17 Replies | 2 Followers

Posts 501
John Duffy | Forum Activity | Posted: Tue, Jan 29 2013 3:53 AM

Hi, I've seen that the problem of exporting footnotes into MS Word was said to have been resolved in Logos 4.5  (see this post and its links; http://community.logos.com/forums/p/26210/193255.aspx#193255) 

However, I haven't been able to see any footnotes (from the Pillar commentary on Mark or the NAC on Mark) appear in an actual Word 2010 new document, even though the footnotes appear correctly in the Print/Export preview page.  The superscript appears in the text in the Word doc, but there are no footnotes.  I'm using Logos 5.0a SR-4 with footnotes and citations both set to 'yes' in the settings.

I searched and did not see this as a known issue.  Is it just happening for me, or do others have the same problem too?

As a workaround, I can select the text and copy, and then paste it into a Word doc (highlighting and dragging selected text from L5 into a Word doc doesn't copy footnotes, but copy and paste does).

Posts 1646
SteveF | Forum Activity | Replied: Tue, Jan 29 2013 6:50 AM

John Duffy:
(highlighting and dragging selected text from L5 into a Word doc doesn't copy footnotes, but copy and paste does).

In a different thread on the Forums one of the "Stars" [Rosie?] agrees with your experience?

 

Regards, SteveF

Posts 501
John Duffy | Forum Activity | Replied: Tue, Jan 29 2013 7:04 AM

SteveF:
In a different thread on the Forums one of the "Stars" [Rosie?] agrees with your experience?

Hi SteveF, any idea which thread?  I couldn't find anything recent by searching the forum.

Posts 8893
fgh | Forum Activity | Replied: Tue, Jan 29 2013 7:21 AM

This one perhaps: Logos 5 Footnotes???

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 501
John Duffy | Forum Activity | Replied: Tue, Jan 29 2013 8:26 AM

fgh:
This one perhaps: Logos 5 Footnotes???

Thanks fgh. It's somewhat relevant, but it doesn't really focus on the problem in print/export.

I often struggle with the search feature on the forum, since it doesn't always return relevant results.  For example, I did a search for both 'Rosie' and 'Footnote' but it didn't turn up any results initially, and there now after your post another search only turned up one result that was not relevant - the difference between the searches was only that I reversed the order of the words.  Strange.  Ah well.

Posts 18860
Rosie Perera | Forum Activity | Replied: Tue, Jan 29 2013 8:48 AM

John Duffy:

fgh:
This one perhaps: Logos 5 Footnotes???

Thanks fgh. It's somewhat relevant, but it doesn't really focus on the problem in print/export.

Yes it was that thread; this is my post in that thread in which I mentioned that old bug that has been around since the print/export feature was first implemented: http://community.logos.com/forums/p/65214/456170.aspx#456170

I have also nagged the powers that be about it. Hopefully it'll get some attention.

Posts 501
John Duffy | Forum Activity | Replied: Tue, Jan 29 2013 9:25 AM

Rosie Perera:
Yes it was that thread; this is my post in that thread in which I mentioned that old bug that has been around since the print/export feature was first implemented: http://community.logos.com/forums/p/65214/456170.aspx#456170

Thanks Rosie, I missed your comments on print/export in the middle of that post when I read the thread first time round.

It seems that Logos is under the impression that this has been resolved, as Bradley Grainger commented "This is available in Logos 4.5." on the Logos Uservoice, and the item has been classified as 'Completed.' (http://logos.uservoice.com/forums/42823-logos-bible-software-4/suggestions/1118839-print-footnotes?ref=title)  

Is it possible that the problem is working in some contexts but not in other?  That is, are footnotes copied across on Apple computers, or in Windows XP but not in Windows 7?  Or does it work in Word 2003/2007/2013 but not in 2010?  (I'm using Word 2010 in Windows 7.)

Yet, with the workaround of Ctrl+C and Ctrl+V, footnotes can be copied, although it is not as straightforward for longer sections.

Posts 25576
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Jan 29 2013 2:12 PM

John Duffy:
Is it possible that the problem is working in some contexts but not in other?  That is, are footnotes copied across on Apple computers, or in Windows XP but not in Windows 7?  Or does it work in Word 2003/2007/2013 but not in 2010?  (I'm using Word 2010 in Windows 7.)

Nothing convoluted - it only works if you export to an XPS document with "show footnotes on page" ticked.

Dave
===

Windows 10 & Android 8

Posts 227
LogosEmployee
Mike | Forum Activity | Replied: Tue, Jan 29 2013 4:38 PM

Hello John,

I am able to reproduce this behavior on Windows 7 64bit with Word 2010. The Footnotes show in the text as super-script, but are not linked to any data. I'll run this by Development and see if I can get some clarification about why it appears this way.

Mike

Faithlife Tech Support
Win Logs|Mac Logs|Training

Posts 501
John Duffy | Forum Activity | Replied: Wed, Jan 30 2013 12:48 AM

Mike (Tech Support):
I am able to reproduce this behavior on Windows 7 64bit with Word 2010. The Footnotes show in the text as super-script, but are not linked to any data. I'll run this by Development and see if I can get some clarification about why it appears this way.

Thanks Mike

Posts 3161
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Jan 30 2013 3:36 PM

To follow up on Mike's post, it looks like Dev is aware of the problem, and are working on a solution. 

 

Posts 777
Brisa Davis | Forum Activity | Replied: Tue, May 28 2013 5:42 PM

This will be fixed in 5.1 Beta 9 for beta testers, and in general when 5.1 ships to the stable channel.

Posts 18860
Rosie Perera | Forum Activity | Replied: Tue, May 28 2013 6:33 PM

Brisa Davis:

This will be fixed in 5.1 Beta 9 for beta testers, and in general when 5.1 ships to the stable channel.

Yay! This one's been around for a long time; so glad to see it finally being fixed!!

Posts 501
John Duffy | Forum Activity | Replied: Wed, May 29 2013 12:35 AM

Brisa Davis:

This will be fixed in 5.1 Beta 9 for beta testers, and in general when 5.1 ships to the stable channel.

That's great.  Smile

Posts 8893
fgh | Forum Activity | Replied: Wed, Jun 5 2013 1:02 PM

Brisa Davis:
This will be fixed in 5.1 Beta 9 for beta testers

Could someone on Mac beta do me a favour and check whether this is fixed for LibreOffice as well?

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 10550
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Jun 5 2013 4:30 PM

fgh:

Brisa Davis:
This will be fixed in 5.1 Beta 9 for beta testers

Could someone on Mac beta do me a favour and check whether this is fixed for LibreOffice as well?

This seems only partly fixed on Windows: Word 2007 gets endnotes instead of footnotes. 

Sending this to Word brings 6082.Test.docx

Luckily, in this section the new 100-pages bug does not strike.

Running Logos 8 latest beta version on Win 10

Posts 777
Brisa Davis | Forum Activity | Replied: Wed, Jun 12 2013 10:23 AM

NB.Mick:
This seems only partly fixed on Windows: Word 2007 gets endnotes instead of footnotes. 

This will be fixed in 5.1 Release Candidate 1.

Posts 8893
fgh | Forum Activity | Replied: Fri, Jun 14 2013 8:11 AM

fgh:
Could someone on Mac beta do me a favour and check whether this is fixed for LibreOffice as well?

It seems that it is.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Page 1 of 1 (18 items) | RSS