More Sync Problems

Page 1 of 1 (11 items)
This post has 10 Replies | 2 Followers

Posts 16557
Forum MVP
Dave Hooton | Forum Activity | Posted: Tue, Feb 26 2013 1:43 PM

The latest ones occur on upload

Error    DatabaseSyncClientRepository    Item of type PassageListStatusSyncItem failed to submit;

Community notes, etc

1462.LogosSync.zip

Dave
===

Windows PC, Android phone

Posts 80
LogosEmployee
Seth Copeland | Forum Activity | Replied: Wed, Feb 27 2013 2:16 PM

Dave Hooton:

The latest ones occur on upload

Error    DatabaseSyncClientRepository    Item of type PassageListStatusSyncItem failed to submit;

Community notes, etc

1462.LogosSync.zip

Could you upload the LogosError.log as well so I could investigate a little more. It might not have anything useful though, in which case maybe I could get a copy of your PassageList.db?

Regards,

Seth Copeland

Logos SW Development

Posts 16557
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Feb 27 2013 3:20 PM

Here they are Seth

4667.LogosError.zip

1411.PassageList.zip

Dave
===

Windows PC, Android phone

Posts 80
LogosEmployee
Seth Copeland | Forum Activity | Replied: Thu, Feb 28 2013 7:24 AM

Dave Hooton:


Weird, the errors reported in the first log you posted weren't in the second log, and the id's marked with an error, weren't found in your database. The signature of the error definitely didn't look like a transient type error though. There is more info associated with an sync error, and I don't know why it isn't being logged.

Did the yellow triangle immediately go away after trying again?

Posts 16557
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, Feb 28 2013 5:41 PM

Seth Copeland:
Weird, the errors reported in the first log you posted weren't in the second log,

I checked and the error entries matched in both logs!

Seth Copeland:
the id's marked with an error, weren't found in your database.

I found both PL Id's 480798ed264a477cb8e39c097747e1b3 and 83116d310d334629851e02513da2f981 under SyncItemsToPatch (and in the current database).

Seth Copeland:
Did the yellow triangle immediately go away after trying again?

No. It took some time & a few attempts.

Dave
===

Windows PC, Android phone

Posts 80
LogosEmployee
Seth Copeland | Forum Activity | Replied: Fri, Mar 1 2013 9:16 AM

Dave Hooton:

I found both PL Id's 480798ed264a477cb8e39c097747e1b3 and 83116d310d334629851e02513da2f981 under SyncItemsToPatch (and in the current database).



Wow, of course. I didn't even think it could be in the patch table, without being in the main item tables. I suspected it might be  a patch problem, and is why I thought it might go away after retrying. Thanks for the info, I should be able to forward this on to someone who can figure out what might be going on.

Regards,

Seth Copeland 

Posts 9
John Hopcraft | Forum Activity | Replied: Sat, Mar 2 2013 1:13 PM

I'm seeing sync problem also L5 on 64 bit win 7. There are no entries in the log files. When I re-try to sync the yellow triangle pops up in about a second. I tried re-booting.

all else seems to work ok.

Here's todays log:

Program Version: 5.0b SR-1 (5.0.2.0727)
Time: 2013-02-22 20:28:49 -06:00 (2013-02-23T02:28:49Z)
Exception while syncing client: Repository = (Libronix.DigitalLibrary.HistoryManager+OurSyncClientRepository), Service = (Logos.Sync.WebService.JsonSyncService`1[Logos.Documents.Contracts.History.HistorySyncItem])
Logos.Sync.Client.SyncClientException: Web service error: Status code not handled. Request: POST https://historyapi.logos.com/v1/history/sync/up (status InternalServerError, content type 'application/json; charset=utf-8', content length 133) ---> Libronix.Utility.Net.WebServiceException: Status code not handled. Request: POST https://historyapi.logos.com/v1/history/sync/up (status InternalServerError, content type 'application/json; charset=utf-8', content length 133)
   at Libronix.Utility.Json.Web.AutoWebServiceRequest`1.HandleResponseCore(WebServiceResponseHandlerInfo`1 info)
   at Libronix.Utility.Net.WebServiceRequestBase`1.GetResponse(IWorkState state)
   at Logos.Sync.WebService.JsonSyncClient.SubmitItems(SyncSubmitItemsRequest request)
   at Logos.Sync.WebService.JsonSyncService`1.SubmitItems(IEnumerable`1 items, SyncSubmitItemsSettings settings, IWorkState state)
   --- End of inner exception stack trace ---
   at Logos.Sync.WebService.JsonSyncService`1.SubmitItems(IEnumerable`1 items, SyncSubmitItemsSettings settings, IWorkState state)
   at Logos.Sync.Client.SyncClient.Sync(SyncPurpose purpose, IWorkState state)
   at Logos.Sync.Client.SyncManager.SyncManagerThread()

Posts 16557
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Mar 3 2013 12:52 AM

John

Please start a new thread if you have sync errors as your issue may be quite different.

The log you posted is too old (22 Feb) to be useful and i would need you to upload the LogosError.log + logos.log. See http://wiki.logos.com/Diagnostic_Logging for more information.

Dave
===

Windows PC, Android phone

Posts 4
Joselito Villoria | Forum Activity | Replied: Mon, Mar 4 2013 6:26 PM

Need help. The logos4 on my laptop is giving me a message, error synchronization has occurred. I have been trying to contact logos since last week but i got no substantial reply yet. Any advice how you resolved the issue would be very much appreciated.

Posts 9
John Hopcraft | Forum Activity | Replied: Mon, Mar 4 2013 6:39 PM

I had similar sounding issue and the solution for now is to "clear" the "history". go to "tools", select "history". On the top right corner of that window you will see "clear". 

That wipes out the history.  Then the sync worked for me.

Posts 1028
LogosEmployee
David Mitchell | Forum Activity | Replied: Tue, Mar 5 2013 9:14 AM

Joselito Villoria:

Need help. The logos4 on my laptop is giving me a message, error synchronization has occurred. I have been trying to contact logos since last week but i got no substantial reply yet. Any advice how you resolved the issue would be very much appreciated.

We deployed a fix to history sync last night that may address your issue. If you're still having problems, please start a new thread, and we'll start working on diagnosing and fixing your issue.

David Mitchell
Development Lead
Logos Bible Software

Page 1 of 1 (11 items) | RSS