Am I the only one??

Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 6
Joseph Domine | Forum Activity | Posted: Wed, May 15 2013 12:24 PM

Am I the only one who misses Logos 2.1??  The latest renditions of Logos software are too difficult for me to master; I REALLY miss 2.0/2.1.  I wish I knew how to set them up as parallel packages even though 2.0/2.1 would have access to a much more limited set of resources; they are enough for my needs and if not, I simply go search the internet for what I can't find in 2/2.1.

Bring back 2.0/2.1!!!

Posts 8602
TCBlack | Forum Activity | Replied: Wed, May 15 2013 1:05 PM

Joseph,

While there is a learning curve, it may not be as steep if you take a look at some of the videos provided by folks like Mark Barnes. 

http://www.logos4training.com/videos/

Many of the videos transfer seamlessly to using L5 as well.

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 89
LogosEmployee
Sherri Huleatt | Forum Activity | Replied: Wed, May 15 2013 4:34 PM

Joseph Domine:

Am I the only one who misses Logos 2.1??  The latest renditions of Logos software are too difficult for me to master; I REALLY miss 2.0/2.1.  I wish I knew how to set them up as parallel packages even though 2.0/2.1 would have access to a much more limited set of resources; they are enough for my needs and if not, I simply go search the internet for what I can't find in 2/2.1.

Bring back 2.0/2.1!!!

Hi Joseph,

I'm sorry you're struggling! Logos can be difficult to master, but we have a lot of great tutorials on our You Tube channel that you may want to check out: http://www.youtube.com/user/LogosBibleSoftware/videos?tag_id=UCZFF0RGvkG-G5_SACnkN_5w.3.how-to&view=46&sort=dd 

Hopefully these help get you started!

 

Page 1 of 1 (3 items) | RSS