Crash on startup

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 38
Tim Bader | Forum Activity | Posted: Tue, May 28 2013 12:03 PM

Hi,

I've just tried transferring to a new PC from my old Logos 4 to Logos 5 installation.

i followed the wiki procedures to avoid downloading/indexing but get an error when i start Logos.

Attached is my log file.

Any ideas?

Thanks

0181.LogosLog.zip

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, May 28 2013 12:13 PM

To clarify: You moved from L4 on computer A, to L5 on computer B. Is that right? 

I noticed something about the wrong NIV file being detected. Can you load to a blank layout? If so, can you run the command "update resources"?

OSX & iOS | Logs |  Install

Posts 13411
Mark Barnes | Forum Activity | Replied: Tue, May 28 2013 12:19 PM

Tim Bader:

I've just tried transferring to a new PC from my old Logos 4 to Logos 5 installation.

i followed the wiki procedures to avoid downloading/indexing but get an error when i start Logos.

I'm not sure you can follow those procedures at the same time as moving from L4 to L5. Personally, I think I would uninstall L5, and reinstall using Method 3.

Posts 26012
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, May 28 2013 5:48 PM

Tim Bader:

i followed the wiki procedures to avoid downloading/indexing but get an error when i start Logos.

Attached is my log file.

You may not have copied folders correctly, therefore backup the resources folder (as per wiki for Method 3), uninstall Logos, delete the C:\Users\Tim\AppData\Local\Logos5 folder and then install using Method 3.

Dave
===

Windows 10 & Android 8

Posts 38
Tim Bader | Forum Activity | Replied: Wed, May 29 2013 5:17 AM

alabama24:

To clarify: You moved from L4 on computer A, to L5 on computer B. Is that right? 

I noticed something about the wrong NIV file being detected. Can you load to a blank layout? If so, can you run the command "update resources"?

Yes, that's right.

I don't get as far as the program itself opening; just the "logos is preparing your library" dialog.

This sits there for a few minutes and then the errors start occurring.

However, I think the other posters may be right about the files not being restored properly.

I will try again this evening, restore the files "fresh" and let you know how it went.

Thanks all for the quick replies!

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, May 29 2013 6:46 AM

Tim Bader:
I will try again this evening, restore the files "fresh" and let you know how it went.

But you are not going to try and go from L4 to L5 directly, are you? Some of the files do actually change and the software might get confused. 

OSX & iOS | Logs |  Install

Posts 38
Tim Bader | Forum Activity | Replied: Wed, May 29 2013 7:12 AM

Well, I was advised on a different thread that I could go straight from one to the other as part of the process.

The wiki page seems to indicate that this is ok too.

But perhaps it would be safer to re-install L4 first and then upgrade to L5 once I know it's ok? 

What is the consensus on this?

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, May 29 2013 7:23 AM

Tim Bader:

Well, I was advised on a different thread that I could go straight from one to the other as part of the process.

The wiki page seems to indicate that this is ok too.

Do you have links? Mark & Dave are the tech gurus I turn to, but I didn't read that in their comments above.

Tim Bader:
But perhaps it would be safer to re-install L4 first and then upgrade to L5 once I know it's ok? 

If you don't hear back from Mark or Dave, I would say yes.

OSX & iOS | Logs |  Install

Posts 13411
Mark Barnes | Forum Activity | Replied: Wed, May 29 2013 7:25 AM

Tim Bader:
What is the consensus on this?

If you're using the Wiki method, you should ensure that you're using the same version of Logos of both computers. We should probably add that proviso onto the Wiki. Once it's installed, run it (to make sure it works), then upgrade to L5.

Posts 38
Tim Bader | Forum Activity | Replied: Wed, May 29 2013 7:39 AM

Thanks very much Mark and alabama24!

I will do so. Smile

Blessings!

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, May 29 2013 8:30 AM

Let us know how it turns out! Good luck. Smile

OSX & iOS | Logs |  Install

Posts 26012
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, May 29 2013 5:46 PM

Tim Bader:
Well, I was advised on a different thread that I could go straight from one to the other as part of the process.

The quick Methods work as long as the version you install is not older than your working version i.e. install L5 with working data from L4.

Dave
===

Windows 10 & Android 8

Posts 38
Tim Bader | Forum Activity | Replied: Thu, May 30 2013 1:33 AM

Well, would you believe it, I was amazed last night:

I restored my files from backup to a separate folder, so they would all be ready to copy across to the correct folders.

I went to uninstall Logos, first checking the Start > Programs menu to see if it had it's own uninstall option.

In the process I accidentally clicked on Logos 5 itself ... And it sprang into life miraculously - no errors, nothing!

I was a little bit worried that something might be missing, but on testing it out, everything was there and I was able to re-compile my personal books too.

So I have a working Logos 5 installation after all, but am none the wiser as to what happened with all the error messages.

One possible thought I had was that my program settings are setup to go into the most recent layout on startup, rather than the home page and I wondered if perhaps it was having trouble opening the resources/layout before it had 'found' them again?

The moral of the story? - You can go straight from Logos 4 to 5 as part of a PC migration, but I wouldn't recommend it for your heart/sanity! Wink

So thank you all for your time on this and God bless!

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, May 30 2013 4:05 AM

Tim Bader:
The moral of the story? - You can go straight from Logos 4 to 5 as part of a PC migration, but I wouldn't recommend it for your heart/sanity!

Smile

Glad to hear you have everything up and running. Yes

OSX & iOS | Logs |  Install

Posts 26012
Forum MVP
Dave Hooton | Forum Activity | Replied: Thu, May 30 2013 4:53 AM

Tim Bader:
So I have a working Logos 5 installation after all, but am none the wiser as to what happened with all the error messages.

It looks like resource discovery (with the Indexer) was underway when you got those errors and that the Indexer successfully completed later. There was no reason for it not to succeed as Logos 5 installs over Logos4 when upgrading "normally". If you try a "quick" install of Logos 4 with working data from Logos 5 you will get a crash, guaranteed, hence the advice not to install an older version.

Dave
===

Windows 10 & Android 8

Posts 28691
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, May 30 2013 5:08 AM

Thanks for the clarification Dave. Smile

OSX & iOS | Logs |  Install

Posts 38
Tim Bader | Forum Activity | Replied: Thu, May 30 2013 5:52 AM

Thanks for the explanation: makes sense now.Smile

Page 1 of 1 (17 items) | RSS