Bug: Copying and Pasting Hebrew Text into Logos Notes

Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 2
Bryan Chung-Hee Kim | Forum Activity | Posted: Wed, Aug 14 2013 12:30 AM

Dear Logos

Copying and pasting Hebrew text into a Logos notes document does not seem to working as it did before.

When I type in English next to the Hebrew text it seems 

1. rearrange the Hebrew text from left-to-right (instead of right-to-left)

2. change the font of the Hebrew text

To reproduce the problem:

1. Right click on a Hebrew word in the BHS text, select the lemma, then select copy.

<e.g. copy lemma נחם for the word נַחֲמ֥וּ in Isaiah 40:1>

2. Paste the word into a Logos note file.

<e.g. this will produce "נחם + new line" >

3. Type in English after the Hebrew

<e.g. the Hebrew text will change from right-to-left to left-to-right>

Kind regards,

Bryan

Posts 25653
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Aug 14 2013 1:44 AM

This behaviour was different in the 5.1 RC version just before it was released.

I cannot understand how it reverted in 5.1 SR-3!

Dave
===

Windows 10 & Android 8

Posts 3169
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, Aug 16 2013 11:44 AM

Bryan Chung-Hee Kim:

1. Right click on a Hebrew word in the BHS text, select the lemma, then select copy.

<e.g. copy lemma נחם for the word נַחֲמ֥וּ in Isaiah 40:1>

2. Paste the word into a Logos note file.

<e.g. this will produce "נחם + new line" >

3. Type in English after the Hebrew

<e.g. the Hebrew text will change from right-to-left to left-to-right>

I'm unable to replicate the behavior. After I paste the cursor ends up below the Hebrew text so maybe that is the problem? After you paste the text does the cursor remain on the line that some of the Hebrew text was on?

 

Posts 2
Bryan Chung-Hee Kim | Forum Activity | Replied: Sun, Sep 8 2013 5:10 AM

Hi Tommy 

Sorry for the late reply I didn't notice that there was a reply to the thread. 

Aftter you paste, the cursor ends up below the Hebrew text... correct.

If you press backspace, or move the cursor to a position just after the hebrew text, and then type characters in English, that's when funny things happen to the Hebrew text.

Kind regards,

Bryan

Posts 3169
LogosEmployee
Thomas Ball | Forum Activity | Replied: Tue, Sep 10 2013 12:06 PM

Bryan Chung-Hee Kim:

Hi Tommy 

Sorry for the late reply I didn't notice that there was a reply to the thread. 

Aftter you paste, the cursor ends up below the Hebrew text... correct.

If you press backspace, or move the cursor to a position just after the hebrew text, and then type characters in English, that's when funny things happen to the Hebrew text.

Kind regards,

Bryan

It looks like typing on the same line as the Hebrew line in a left-to-right oriented language forces all formatting--including writing direction--to its way. I'll submit a report to dev about this.  

Edit: The behavior is different on the Mac version. The Hebrew doesn't move, but the text jumps to the left of the Hebrew word and starts pushing the Hebrew pasted text right.

 

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Mon, Oct 7 2013 12:26 PM

This should be fixed in 5.2 Beta 1 and later on the Stable channel.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Page 1 of 1 (6 items) | RSS