Logos 5 Indexer stops working

Page 1 of 1 (15 items)
This post has 14 Replies | 1 Follower

Posts 36
Rhonda Dodson | Forum Activity | Posted: Wed, Sep 11 2013 6:23 AM

I got a huge update yesterday (>1,000 items) & now I keep getting an error message Logos 5 Indexer has stopped working every time Logos tries to index. Help?

Posts 8602
TCBlack | Forum Activity | Replied: Wed, Sep 11 2013 6:25 AM

Please enable Logging ( wiki.logos.com/Diagnostic_Logging ) and upload your logs ( wiki.logos.com/Uploading_Logs ) so we can take a look.

Thanks. 

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 36
Rhonda Dodson | Forum Activity | Replied: Wed, Sep 11 2013 4:23 PM

The indexing just got done (approx. 3.5 hours). Do you still want the logs just in case others have this issue? Will the logs still be there now that the indexing is completed?

Posts 9127
Forum MVP
Mark Smith | Forum Activity | Replied: Wed, Sep 11 2013 4:31 PM

Rhonda, every time the indexer restarts it starts a new indexer log, getting rid of the old one. So the ones generated with errors will be gone. The LogosIndexerError.log and the LogosError.log files are cumulative, however, so those would be good to see.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 251
Rod | Forum Activity | Replied: Thu, Sep 12 2013 1:26 PM

I am having the same problem.  Log files attached

8883.Logos Log Files.zip

Posts 9127
Forum MVP
Mark Smith | Forum Activity | Replied: Thu, Sep 12 2013 1:33 PM

Taxee:
I am having the same problem.  Log files attached

Neither of those shows an error. Is there a LogosCrash, LogosError, Indexer4Error, or IndexerCrash log you can send?

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 3160
LogosEmployee
Thomas Ball | Forum Activity | Replied: Thu, Sep 12 2013 4:52 PM

Taxee:

I am having the same problem.  Log files attached

8883.Logos Log Files.zip

Hi Taxee, 

Your logs don't record a crash. Be sure to collect the logs immediately after it crashes; otherwise, the crash may be coming from elsewhere, at which point we'd need to do more serious troubleshooting over the phone.  

 

Posts 251
Rod | Forum Activity | Replied: Fri, Sep 13 2013 7:53 AM

I shut Logos 5 down and started it up again.  These are the only log files that the system produces.

The indexer crashes almost immediately.  Logos 5 itself is still running but the index program crashes.

0312.Logos Log Files.zip

Posts 251
Rod | Forum Activity | Replied: Fri, Sep 13 2013 7:59 AM

When the indexer crashes, Windows 7 produces the following message under problem details:

Problem signature:
Problem Event Name: APPCRASH
Application Name: LogosIndexer.exe
Application Version: 5.1.1.600
Application Timestamp: 522789f1
Fault Module Name: Libronix.DigitalLibrary.Logos.dll
Fault Module Version: 5.1.1.600
Fault Module Timestamp: 522789e3
Exception Code: c0000005
Exception Offset: 00038ed8
OS Version: 6.1.7601.2.1.0.256.48
Locale ID: 4105
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Posts 8602
TCBlack | Forum Activity | Replied: Fri, Sep 13 2013 8:04 AM

There is no crash in your indexer log.  You need to capture and upload that log before the indexer is allowed to restart.  Do you have a logoserror.log or a logoscrash.txt or even better a logosindexererror.log?

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 251
Rod | Forum Activity | Replied: Fri, Sep 13 2013 9:15 AM

I don't think anyone is understanding what I am saying.

These log files are all that is created.  I did not restart Logos.  The indexer crashes and these are the only log files created. There is no logoserror.log or logoscrash.txt or logosindexererror.log

I actually started Logos 5 with explorer open so that I could check that no other log files were created.

There are none.

I appreciate that this is probably not supposed to happen but, unfortunately for me, it is,

So where do I go for help???

Posts 9127
Forum MVP
Mark Smith | Forum Activity | Replied: Fri, Sep 13 2013 10:44 AM

Taxee:
So where do I go for help???

Since we would just be guessing and all we could suggest at this point is deleting some files or reinstalling, I think you ought to contact Logos Tech Support for direct assistance.

If you do discover what is happening, it would be good to post that here.

Pastor, North Park Baptist Church

Bridgeport, CT USA

Posts 196
Dan Pogue | Forum Activity | Replied: Fri, Sep 13 2013 3:55 PM

I have to agree about calling Logos for support, they are fantastic.  I am curious also looking at the appcrash, when is the last time you have done a checkdisk on your hard drive?  Hope you are able to get it figured out soon!

Blessings,

Danp

Posts 8148
LogosEmployee

Taxee:

There is no logoserror.log or logoscrash.txt or logosindexererror.log

This usually indicates a "native crash" (which does not result in a log file). These are relatively rare, and harder to diagnose via the forums; I second the recommendation to call tech support.

Posts 251
Rod | Forum Activity | Replied: Wed, Sep 18 2013 4:38 PM

Solved my problem and hope it doesn't happen again anytime soon.  Tech support's first suggestion was to rebuild my index.  They estimated it would take an hour but i have a large library (6500 volumes) which took overnight to rebuild.

Things appear to be back to normal.

Page 1 of 1 (15 items) | RSS