ads? really? Come on Logos!

Page 1 of 1 (5 items)
This post has 4 Replies | 2 Followers

Posts 150
rog | Forum Activity | Posted: Mon, Sep 23 2013 7:02 AM

For what I pay for Logos, I shouldn't have to look at ads. Really. So I open up logos today and since they aren't getting through to me with enough emails (sarcasm), there on my screen is a pop-up ad telling me that time is running out to upgrade to logos 5. Um...I'm running logos 5....

Still, I put up with ads on the computer and my phone because I'm getting content free. But not in Logos. I have paid a lot of money for the packages I'm running, I shouldn't have to see any ads and I shouldn't have to click it to turn it off so I can get into my Bible study time. 

I'm sure there is a way to turn these off, but still I think it's a bit intrusive. The default should be off.

enough ranting for today....

Posts 28357
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Sep 23 2013 8:13 AM

rog:
there on my screen is a pop-up ad telling me that time is running out to upgrade to logos 5. Um...I'm running logos 5....

Two thoughts:

  1. These pop ups existed in L4, and are used occasionally (maybe 3-4 a year).
  2. The ad wasn't for updating the software engine to L5, but to update your base package. Unless you purchased L5 Portfolio, you are still eligible for upgrade discounts.

OSX & iOS | Logs |  Install

Posts 627
Ryan | Forum Activity | Replied: Mon, Sep 23 2013 10:02 AM

I could be wrong but doesn't un-checking the box "My Logos Messages" (click on the settings wheel on the bottom left corner of the home page next to your user name) prevent these messages from popping up?

Or is that something else?

Posts 8893
fgh | Forum Activity | Replied: Mon, Sep 23 2013 10:31 AM

Ryan B:
I could be wrong but doesn't un-checking the box "My Logos Messages" (click on the settings wheel on the bottom left corner of the home page next to your user name) prevent these messages from popping up?

The settings there only control what's directly on the home page. If this truly was a popup, the setting to turn off should be Program Settings > Show Alerts.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Pro OS 10.9.

Posts 627
Ryan | Forum Activity | Replied: Mon, Sep 23 2013 11:02 AM

Ahhh okay <lightbulb goes off> Idea. Got it. Wasn't 100% sure when I posted. Thanks for the clarification.

Page 1 of 1 (5 items) | RSS