Page 1 of 2 (27 items) 1 2 Next >
This post has 26 Replies | 2 Followers

Posts 8133
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Posted: Mon, Dec 21 2009 3:07 PM | Locked

4.0a RC 2 (v4.01.3.4533) is now available for installation.

To install, download and run this link: http://downloads.logos.com/LBS4/InstallerBeta/Logos4Setup.exe

Bug Fixes

  • Fixed crash moving/opening media resources
  • The Message has a title when copying from CBV
  • Fixed crash in Word by Word section if surface text resource is unavailable/hidden
  • Fixed crash creating a new reading plan when Home Page tools disabled

The release notes for 4.0a RC 1 are available at: http://community.logos.com/forums/t/7480.aspx

Posts 97
Jeff Loven | Forum Activity | Replied: Mon, Dec 21 2009 3:30 PM | Locked

Will I have to go through the many-hour re-indexing process with this RC?

 

Thanks, 

Jeff

Posts 8133
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Mon, Dec 21 2009 3:34 PM | Locked

Jeff Loven:

Will I have to go through the many-hour re-indexing process with this RC?

Only if you have a corrupted index. (If you merged with any of the betas, and haven't reindexed with RC 1, your index may be corrupted.)

Posts 5337
Kevin Becker | Forum Activity | Replied: Mon, Dec 21 2009 3:34 PM | Locked

Jeff Loven:

Will I have to go through the many-hour re-indexing process with this RC?

 

Thanks, 

Jeff

You shouldn't have to. I never had a full -reindex in the entire beta cycle after the initial index. I didn't have to do a full index with RC 1. Granted, I haven't had the chance to update to RC 2 but I don't imagine it would need to index again based on my experience.

Posts 13379
Forum MVP
Mark Barnes | Forum Activity | Replied: Mon, Dec 21 2009 3:43 PM | Locked

There was a bug in 4.0a RC-1 which it's too late to fix now!

It looks for updates from the stable.xml RSS feed not the beta.xml feed, so Update Now doesn't work. So we have to download the installer again, as Bradley says.

Posts 97
Jeff Loven | Forum Activity | Replied: Mon, Dec 21 2009 3:46 PM | Locked

When I run the "Update Resources" function manually it only takes about 3 seconds before it informs me that no updates are available. My library contains 1776 resources; shouldn't it be taking longer than this?

 

Thanks again, great update Logos crew!

Posts 8133
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Mon, Dec 21 2009 4:08 PM | Locked

Mark Barnes:

There was a bug in 4.0a RC-1 which it's too late to fix now!

It looks for updates from the stable.xml RSS feed not the beta.xml feed, so Update Now doesn't work. So we have to download the installer again, as Bradley says.

That was by design; we didn't want to have to re-release it just to change the channel from "beta" to "stable" (if no other bugs were found). RC2 also checks the stable channel.

Posts 77
Adrian Frost | Forum Activity | Replied: Mon, Dec 21 2009 4:11 PM | Locked

Thanks Mark, that would explain why "Update Now" hasn"t worked for me. Problem is that the installer doesn't work correctly for me. It says: "Please wait while Setup downloads files" and underneath the non-moving progress bar: "Downloading Logos 4 Web Script... Progress..." Then nothing happens at all.

If I press "Cancel" then the installer quits saying it was unable to download a required file.

I'm using Windows Vista SP2 with all the UAC stuff enabled and running in a limited account.

(And on non-preview I see that Bradley has explained the stable/beta thing...)

Eglise Protestante Evangélique de Libramont, Belgique - www.epelibramont.com

Posts 13379
Forum MVP
Mark Barnes | Forum Activity | Replied: Mon, Dec 21 2009 4:16 PM | Locked

Bradley Grainger:

That was by design; we didn't want to have to re-release it just to change the channel from "beta" to "stable" (if no other bugs were found). RC2 also checks the stable channel.

You're obviously an optimist! Perhaps that suggests a new command would be useful "set update to beta" whereby we could ask Logos to permanently monitor the beta RSS rather than the stable RSS.

Posts 8133
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Mon, Dec 21 2009 5:28 PM | Locked

Mark Barnes:

Bradley Grainger:

That was by design; we didn't want to have to re-release it just to change the channel from "beta" to "stable" (if no other bugs were found). RC2 also checks the stable channel.

You're obviously an optimist! Perhaps that suggests a new command would be useful "set update to beta" whereby we could ask Logos to permanently monitor the beta RSS rather than the stable RSS.

You mean the "set update channel to beta" command? Wink Use "set update channel to default" to turn it off.

We haven't publicised it much because (a) it overrides the default setting (of beta vs stable) so you're not testing that feature exactly as it will be in the release version, and (b) it seems quite possible that someone would forget that he had turned it on, and automatically get upgraded to 4.0b Beta 1 only to find out that it crashes his system, but not before upgrading all his local files so that he can't downgrade to 4.0a. If you have a dedicated testing machine/account, though, it probably won't hurt anything to change that setting, and you'll get all the latest betas as soon as they're available.

However, it's definitely a "use at your own risk" command.

Posts 13379
Forum MVP
Mark Barnes | Forum Activity | Replied: Mon, Dec 21 2009 5:32 PM | Locked

Bradley, I think this could be your most productive day in the office yet!!

Posts 97
Jeff Loven | Forum Activity | Replied: Mon, Dec 21 2009 5:48 PM | Locked

Hey ya'll, 

I'm running RC-2 and everything was fine, until I purchased several resources. Logos now appears to be re-indexing my entire library....at this point my status indicator reads "12 Hours Remaining." Any ideas on why this has happened?

Thanks!

Posts 352
Mike & Rachel Aubrey | Forum Activity | Replied: Mon, Dec 21 2009 6:34 PM | Locked

Thanks Bradley!

Posts 111
Keith Gant | Forum Activity | Replied: Mon, Dec 21 2009 8:05 PM | Locked

I'm new to this, having recently upgraded to L4. For someone who is not involved in beta testing, is it advisable to install beta's like this, or to wait until they release something which the automatic upgrader installs for you?

Posts 13379
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Dec 22 2009 1:31 AM | Locked

See Bradley's comments here: http://community.logos.com/forums/p/7700/60853.aspx#60853

Posts 1931
Donovan R. Palmer | Forum Activity | Replied: Tue, Dec 22 2009 1:52 AM | Locked

Keith Gant:
I'm new to this, having recently upgraded to L4. For someone who is not involved in beta testing, is it advisable to install beta's like this, or to wait until they release something which the automatic upgrader installs for you?

This is actually "Release Candidate" which is considered very stable. I have been using L4 Windows since the beta stage as my primary Bible programme and I don't have any regrets.  This RC version will even be better than what we have been using, so I would say go for it if you are so inclined, but recognise there may be the occasional issue still being worked out.

Posts 77
Adrian Frost | Forum Activity | Replied: Tue, Dec 22 2009 2:16 AM | Locked

Update problem resolved. I set the channel to beta, rebooted and the upgrade went fine. Then set it back to default as suggested. thanks Bradley for the tip.

Eglise Protestante Evangélique de Libramont, Belgique - www.epelibramont.com

Posts 286
Dr. Charles A. Wootten | Forum Activity | Replied: Tue, Dec 22 2009 6:43 AM | Locked


Bradley Grainger:

4.0a RC 2 (v4.01.3.4533) is now available for installation.

To install, download and run this link: http://downloads.logos.com/LBS4/InstallerBeta/Logos4Setup.exe

The download option was given in two different postings. I downloaded one, tried it. Didn't work. Downloaded the other, tried it. Didn't work. I've no clue what the "unusual way" means....Tongue Tied

Here are screen shots that might give you an idea as to why nothing happened. I'm using Windows 7, 8gigs RAM, 850gigs HD free space, all programs closed except the Thunderbird e-mail program.

Any ideas?

thanX!!

God bless

{charley}

running Logos Bible Software 6.0a: Collector's Edition on HP e9220y (AMD Phenom II X4 2.60GHz 8.00GB 64-bit Win 7 Pro SP1) & iPad (mini) apps.

Posts 13379
Forum MVP
Mark Barnes | Forum Activity | Replied: Tue, Dec 22 2009 6:48 AM | Locked

I've had this message after rebooting after installing Logos. It doesn't seem to affect the installation in any way. To see whether the update has been installed, load Logos, click on the Help icon, and choose About Logos Bible Software. The version number listed should be 4.01.3.4533 is you're using RC2.

Posts 2246
Forum MVP
John Fidel | Forum Activity | Replied: Tue, Dec 22 2009 7:33 AM | Locked

I am getting this error this morning on my SR7 installation. It does not allow the update to occur.

Page 1 of 2 (27 items) 1 2 Next > | RSS