Crash - Logos 5 on Mac

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 10
Steve Law | Forum Activity | Posted: Fri, Nov 8 2013 6:42 AM

6378.LogosLogs.madox15.20131108-075656.zip

Running Logos 5 on Mac OS X Mavericks.  I tried starting Logos 5, but after the "signing in" popped up, Logos stopped.  I noticed it was indexing at the time so I thought that might cause the problem.  So I let it run its course last night.

This morning I assumed Logos is done indexing since I left the computer on all night and the indexing is gone this morning.  So I tried starting up Logos again.  But same thing happened.

Please take a look at the log file.  Any help is greatly appreciated.  I have a paper due this Wednesday!!

Thanks,

-Steve

Posts 8014
LogosEmployee

One of your local database files has become corrupted. Please delete the following file and restart Logos:

/Users/madox15/Library/Application Support/Logos4/Data/h70lcrvv.1ov/HistoryManager/history.db

Posts 10
Steve Law | Forum Activity | Replied: Fri, Nov 8 2013 6:58 AM

oh Nice!!! it's working! I'm so relieved that I do not need to uninstall and reinstall again (yeah, did that earlier this week)!! Thanks Bradley!!

Posts 10
Steve Law | Forum Activity | Replied: Tue, Nov 12 2013 10:38 AM

5611.LogosLogs.madox15.20131112-133655.zip

Seems like every time Mavericks crashes... my logos 5 breaks as well.

Please help!

-Steve

Posts 24928
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Nov 12 2013 11:54 AM

Steve Law:
Seems like every time Mavericks crashes... my logos 5 breaks as well.

Did you delete the history.db file as Bradley advised because you have the same error? If you did delete it then you may have some disk corruption.

Dave
===

Windows & Android

Posts 10
Steve Law | Forum Activity | Replied: Tue, Nov 12 2013 2:22 PM

After you said that... i did the same step Bradley advised and it worked.  But what seems to be the problem? I understand that Mavericks can be problematic at times... but how did it affect Logos?

Posts 24928
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Nov 13 2013 12:21 PM

Steve Law:
I understand that Mavericks can be problematic at times... but how did it affect Logos?

I think it is an issue with the SQlite databases (like history.db) that Logos uses to store data and your documents. They are not as robust as expected and contents become corrupted.

Dave
===

Windows & Android

Posts 1
Christopher Hall | Forum Activity | Replied: Thu, Nov 14 2013 6:49 AM

help me out please. i'm new to mac. i used to be able to enter that into the windows and hit "go" but i don't know how to do that on my mac.

Posts 21920
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Nov 14 2013 6:57 AM

Hi Christopher - and welcome to the forums

Christopher Hall:

help me out please. i'm new to mac. i used to be able to enter that into the windows and hit "go" but i don't know how to do that on my mac.

the same thing should work on Mac.

please start a new thread and explain exactly what problems you are seeing.

Graham

Posts 10550
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Nov 14 2013 9:02 AM

Christopher Hall:

help me out please. i'm new to mac. i used to be able to enter that into the windows and hit "go" but i don't know how to do that on my mac.

In recent versions of OS X, the User Library folder is hidden by default. In the Finder, hold down the Option key and click on the Go Menu. The Library folder will now appear, and you can follow the rest of the path Bradley listed to delete the history.db

Application Support/Logos4/Data/h70lcrvv.1ov/HistoryManager/history.db.

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Nov 14 2013 9:50 AM

The path Jack gave is for another user. The strangely named folder will be something different, randomly generated. 

OSX & iOS | Logs |  Install

Posts 10550
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Nov 14 2013 12:03 PM

alabama24:
The path Jack gave is for another user.

Oops. Did not notice that a new person had entered the conversation Embarrassed

Posts 3
J. Spurling | Forum Activity | Replied: Tue, Nov 19 2013 11:20 AM

I did this, but this did not help me at all... still experiencing crashes on start up with Mac running Logos 5

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Nov 19 2013 11:49 AM

J. Spurling:

I did this, but this did not help me at all... still experiencing crashes on start up with Mac running Logos 5

Don't take someone else's medicine. Please create a new thread, explaining the issue, and posting logs.

OSX & iOS | Logs |  Install

Posts 10
Steve Law | Forum Activity | Replied: Wed, Nov 20 2013 7:23 AM

Hello, 

I'm taking my room back! (I wish I didn't have to, though)

5280.LogosLogs.madox15.20131120-102156.zip

Logos crashed couple of times and was unable to open - so i used the deleting history.db method to fix the problem.

But this time - it doesn't work.

Any help is greatly appreciated!

Posts 120
David Manning | Forum Activity | Replied: Wed, Nov 20 2013 7:27 AM

Work around

C/P:

There is. Everyone on Mac having this problem, try the following:

  1. Start Logos with the Cmd key pressed down.
  2. When the dialogue box appears, choose Offline mode.
  3. When Logos is open, click on the little gear-wheel at the bottom left of the Home Page and uncheck Verse of the Day.
  4. Restart normally to get back to online mode.

MacBook Pro 15" Retina 1TB Flash 2.8 Quad i7 16 GB Ram OSX 10.13.4

iMac 27"3.2 GHz Intel Core i5 - 32 GB Ram 10.13.4

Posts 10
Steve Law | Forum Activity | Replied: Wed, Nov 20 2013 7:55 AM

wow, thanks! it worked!

are you saying "verse of the day" is the cause of the problem?

Posts 41
Ritchin Eapen Sen | Forum Activity | Replied: Wed, Nov 20 2013 8:02 AM

Thanks, David. Your method helped.

I deleted the history file as mentioned before but it didn't do anything for me.

Thank you all for all your help, especially the timely and quick responses. God Bless. Smile

Posts 1875
Paul-C | Forum Activity | Replied: Wed, Nov 20 2013 8:09 AM

Steve Law:

are you saying "verse of the day" is the cause of the problem?

Yep!  Happened to me too.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Nov 20 2013 8:36 AM

Paul-C:

Steve Law:

are you saying "verse of the day" is the cause of the problem?

Yep!  Happened to me too.

This should be fixed now.

Mobile Development Team Lead

Page 1 of 1 (20 items) | RSS