Crashing on Startup - Logos 5.2.0.52 on OSX Mavericks

Page 1 of 1 (16 items)
This post has 15 Replies | 2 Followers

Posts 6

Logos has been crashing on startup for me today. Yesterday Logos was updated, as were a bunch of resources, but I was using it as normal.

I'm running Logos 5.2.0.52 on OS X Mavericks.

Thanks.

Posts 1
Nancy Ho | Forum Activity | Replied: Tue, Nov 19 2013 4:07 PM

Me too... Frustrating.

Posts 15216
Forum MVP
alabama24 | Forum Activity | Replied: Tue, Nov 19 2013 4:20 PM

Nancy Ho:

Me too... Frustrating.

Welcome to the forums! Sorry you are having troubles. Tongue Tied

Please create a new thread and post logs. See my signature line for help with that.

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 15216
Forum MVP
alabama24 | Forum Activity | Replied: Tue, Nov 19 2013 4:23 PM

Daniel Saunders:
Logos has been crashing on startup for me today.

I believe that you have a corrupted database file. Please delete your ErrorReportManager.db file and restart Logos. The path to the file is:

Users/danielsaunders/Library/Application Support/Logos4/Data/jka7iybk.pdd/Errors/Application/ErrorReportManager.db 

NOTE: Your user library is hidden by default in OSX. Google "show user library in OSX" to learn different ways to reveal it.

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 6

Thanks Alabama24,

I deleted the ErrorReportManager.db (via terminal) and started Logos. The same crash occurred so I've attached new logs.

Posts 15216
Forum MVP
alabama24 | Forum Activity | Replied: Tue, Nov 19 2013 5:03 PM

This time around, I see something about a TIFF. I assume this is referring to an image, perhaps on the homepage. Is that what you load to? Have you tried starting to a blank layout? Press and hold the command key immediately upon startup. Check the appropriate box.

Here is what the log says: NSInvalidUnarchiveOperationException: Archived bitmap contains no TIFF data, which is a required element.  This archive is bad.

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 2317
LogosEmployee
Tommy Ball | Forum Activity | Replied: Tue, Nov 19 2013 5:05 PM

Hi Daniel,

This is a bit of a stab in the dark, but it looks like it is having issue with something related to the home page. Can you open Logos to a blank layout* re-size the window (perhaps hit the green re-size button on the main Logos window), and then click the house icon to navigate to the homepage? If it still crashes please give us a call at 800-875-6467. 

*You can open to a blank layout by opening Logos from the Applications folder with the Command key held down long enough for the sign in window to appear. You should see a "Blank layout" option there. 


Posts 6
Daniel Saunders | Forum Activity | Replied: Tue, Nov 19 2013 5:23 PM

Opening to a blank screen seems to have done part of the trick. 

I tried resizing the home screen. When it was smaller than usual everything seemed to behave properly. However, I went back to the book I'm reading and resized the window to my normal dimensions—then clicking the home button caused a crash.

I wonder if there's a corruption in the nice 'verse of the day' graphic today?

Posts 1
S.D.G Jo | Forum Activity | Replied: Tue, Nov 19 2013 5:52 PM

I have trouble same kind of bugs. 

Plz help.... I am 2011 mid macbook air

Posts 15216
Forum MVP
alabama24 | Forum Activity | Replied: Tue, Nov 19 2013 7:38 PM

S.D.G Jo:

I have trouble same kind of bugs. 

Plz help.... I am 2011 mid macbook air

welcome! Sorry you are having troubles. Tongue Tied

Try the advice Kevin gave above about opening to a blank layout. If that doesn't work, please enable and post logs in a NEW thread. See my signature line for instructions. 

OSX 10.9 | iOS 7 | L5 Gold | Mac Logs | Install

Posts 7666
fgh | Forum Activity | Replied: Wed, Nov 20 2013 4:00 AM

Daniel Saunders:
I wonder if there's a corruption in the nice 'verse of the day' graphic today?

There is. Everyone on Mac having this problem, try the following:

  1. Start Logos with the Cmd key pressed down.
  2. When the dialogue box appears, choose Offline mode.
  3. When Logos is open, click on the little gear-wheel at the bottom left of the Home Page and uncheck Verse of the Day.
  4. Restart normally to get back to online mode.

"The Christian way of life isn't so much an assignment to be performed, as a gift to be received."  Wilfrid Stinissen

Mac Mini late 2010 8GB RAM 10.6.8

Posts 1581
Paul-C | Forum Activity | Replied: Wed, Nov 20 2013 6:25 AM

I'm having the same issue with the Verse of the Day on the home page.  I always start Logos opening to a blank layout, then when I manually clicked on the home page, Logos 5 crashed.  I've done what fgh suggested above (disabling the Verse of the Day), and I can navigate to the home page without trouble now.

Posts 9
Ivan Rusyn | Forum Activity | Replied: Wed, Nov 20 2013 6:29 AM

Hi, 

I have the same problem today - Logos 5 crashes all day (maverick). I can't use it at all. What to do???

Ivan

Posts 1581
Paul-C | Forum Activity | Replied: Wed, Nov 20 2013 7:02 AM

Ivan, have you done this (per fgh above)?

There is. Everyone on Mac having this problem, try the following:

  1. Start Logos with the Cmd key pressed down.
  2. When the dialogue box appears, choose Offline mode.
  3. When Logos is open, click on the little gear-wheel at the bottom left of the Home Page and uncheck Verse of the Day.
  4. Restart normally to get back to online mode.
Posts 112
David Manning | Forum Activity | Replied: Wed, Nov 20 2013 7:20 AM

Had to to this to our Pastor's Computer this morning.

MacBook Pro 15" Retina 768GIG Flash Quad i7 16 GB Ram OSX 10.9

iMac 27" 2.7 GHz Quad Core i5  8 GB Ram 10.9

Posts 8114
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Nov 20 2013 1:51 PM

Tom Philpott (Logos) reported that this problem has now been fixed, and it is safe to enable Verse of the day.

Page 1 of 1 (16 items) | RSS