Faithlife Page Not Displaying Properly in Safari or Chrome and few Questions

Page 1 of 1 (13 items)
This post has 12 Replies | 0 Followers

Posts 56
Matthew Candler | Forum Activity | Posted: Wed, Nov 20 2013 5:53 AM

Attached below you will see that Faithlife page does not display properly in either Safari or Chrome. I am using the latest of both browsers and it just looks bad. Aesthetically it is not fun to work within. 

I am interested in using Faithlife for a university course class discussion, however, not if these things don't look prettier. 

Also:

(1) Is there an estimated time when we will be able to "edit" our own community posts. I found this very frustrating when I couldn't correct toys, and my only option was to delete and write comment again.

(2) My concern is that I would make an investment in Faithlife, and it get canned or significantly changed. I wish there was a more direct way to share with other users without such a learning curve of a separate web interface and system to learn. Would seem better to integrate sharing features in a more direct way via biblia or something. The more I hav dug into Faithlife, I actually DO see the potential - but it feels like a half built house with only a few utilities working - you can see and imagine it in its full glory, but can't actually "live in it." 

Make me love it! Help me!

Posts 99
LogosEmployee
Patrick Nausha | Forum Activity | Replied: Wed, Nov 20 2013 11:15 AM

Matthew,

Thanks for reporting this problem. That is certainly not how Faithlife is supposed to look. But I'm excited you see Faithlife's potential!

We actually can't reproduce this display problem on Mac or Windows in either browser. Some more info would help us debug this issue. Which platform are you on? Windows or Mac? Are you using any browser plugins/extensions? Does every page look like this, or just group pages? Can you try to clear your browser cache (or use an incognito window) and let us know if you see the same issue?

  1. We have not planned to implement editing of Community Notes. I will bring this up to our design team.
  2. We will not can Faithlife.com. It remains a crucial part of our ecosystem. Any change to Faithlife will have users' best interest in mind. There may be large changes down the road, but the same core features should persist. Which features would you like to see on Biblia? Have you tried posting community notes on Biblia or bible.faithlife.com?

Thank you,

Patrick

Software Developer
Faithlife

Posts 9813
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Nov 20 2013 11:38 AM

Matthew,

I'm not sure where your problem is, but on Windows, using Chrome, the page does look like this:

You'll see

  • no awkward blank space
  • the line is very well-placed to differentiate user-related stuff from group-related stuff
  • tweets do display nicely

Some ideas where you might check for the issue:

Do you use some very intrusive ad- and popup-blocker? Or run from behind a firewall with a "kindergarden" proxy, interfering in websites?

Did you disable javascript or anything like this that might be needed by the page to render correctly? 

Running Logos 8 latest beta version on Win 10

Posts 4625
RIP
Milford Charles Murray | Forum Activity | Replied: Wed, Nov 20 2013 6:10 PM

Peace!           *smile*                Using IE 11 I'm getting as good a site as Mick was able to get ...     seems to work well for me ....

Philippians 4:  4 Rejoice in the Lord always; again I will say, Rejoice. 5 Let your reasonableness be known to everyone. The Lord is at hand..........

Posts 5
Daniel R. Sick | Forum Activity | Replied: Fri, Jan 24 2014 8:14 AM

Hi Patrick, 

The same happens to me. I am using a MacBook Air (OS X 10.9.1 Maverick)  with the Safari browser. Only Plug-in or extension is "iTube Studio" I tested the different sites from Logos (Proclame, Logos, Forum, ...) and there it is normal. The only site that does the funny arrangement is Faithlife.com and this on all pages. Private browsing makes it even worse.    

I hope this information is of any help with the debugging. 

Greetings from Ecuador, 

Daniel 

Posts 2
Jacquelyn Lutz | Forum Activity | Replied: Sun, May 4 2014 5:43 PM

I'm having the same issue. I can't even post in my groups because the post buttons are covered by ads or "Fill Out Your Profile" boxes.

Any updates on this or how to fix it? I'm also using a Macbook Pro OSX 10.9.2. Chrome and Safari both are not loading the page properly. 

Is there a plugin I need? Or will I have to just download a whole new browser? :\

Posts 99
LogosEmployee
Patrick Nausha | Forum Activity | Replied: Mon, May 5 2014 10:24 AM

I just saw Matthew's issues in Chrome and Safari after installing iTube Studio for both. We will try to make Faithlife play nicer with this plugin. Daniel, uninstalling that plugin or using a browser that doesn't have the iTube plugin installed should fix your problems temporarily. Jacquelyn, are you using iTube or any other plugins?

-Patrick

Software Developer
Faithlife

Posts 56
Matthew Candler | Forum Activity | Replied: Mon, Jun 2 2014 5:31 AM

Patrick,

Two quick things:
(1) Does this mean that I have the iTube Studio plugin installed on my Mac? Big Smile Guess I didn't know, I didn't see it in my Apps List Indifferent, or is it a browser plugin?

(2) I didn't even know I had responses to this original post, how do I go about being informed when there is a response to a post? Sorry, I should probably know that :-)

Thanks so much everyone for your help!

Posts 99
LogosEmployee
Patrick Nausha | Forum Activity | Replied: Mon, Jun 2 2014 9:34 AM

Matthew,

  1. iTube studio is a browser extension. But your problem in Faithlife could very well be caused by some other extension. You can view your extensions by choosing Safari > Preferences > Extensions.
  2. You can receive email notifications for forum posts. When logged in you can choose Edit at the top right, click the Site options button, and scroll down to view email preferences.

-Patrick

Software Developer
Faithlife

Posts 56
Matthew Candler | Forum Activity | Replied: Mon, Jun 2 2014 3:34 PM

Beautiful! I removed the extension, works great now! Thanks a ton for everything!

Posts 2
Jacquelyn Lutz | Forum Activity | Replied: Wed, Jun 4 2014 6:22 AM

WOW! Thank you so much! I've just turned off all Safari extensions and the site is working perfectly now. Thank you so very much!! :) 

Posts 1
John | Forum Activity | Replied: Fri, Jun 6 2014 10:51 AM

Thanks for the fix.  Smile

John

Your Bible Quotes

Personalized Bible Quotes

Posts 16
Daniel Miller | Forum Activity | Replied: Fri, Feb 6 2015 7:11 AM

I'm having the same issue but in Firefox.  I do not know how to cancel extensions.  Any help here? 

thanks

Dan

Page 1 of 1 (13 items) | RSS