Bug: Random highlighting of all text on screen

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 80
Steve Brannon | Forum Activity | Posted: Tue, Jan 7 2014 6:25 PM

There are times when all the text on my screen (so far, only Bible text) suddenly becomes highlighted.  It was never intended to be highlighted, but highlighting appears suddenly.

If I close Logos and reopen the passage, the highlighting is gone (except, of course, any portion that was intentionally highlighted).  

I have attached a log to assist troubleshooting.

This is on a Mac, running the latest version of OS-X and the latest version of L5.

Steve

2577.LogosLogs.sgbrannon.20140107-211706.zip

Posts 28712
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Jan 7 2014 6:51 PM
Screen shots would help. Do you have any search windows open?

OSX & iOS | Logs |  Install

Posts 80
Steve Brannon | Forum Activity | Replied: Tue, Jan 7 2014 7:05 PM

No "Search" windows open.  The bug typically occurs if I switch to another application, then switch back to L5.  Screenshots follow...

"Normal" view

5314.Normal.tiff

"Highlight Bug" View

7115.BugHighlighting.tiff

Posts 23630
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Jan 7 2014 11:07 PM

From your log there is a lot of search activity going on.

Do you have any visual filters set up which could be causing this?

Posts 8867
LogosEmployee

It seems likely that a visual filter (perhaps for a morph term or "bible:*"?) is causing this display. I'd recommend looking through recently-modified visual filters to find one that has a broad query that has grey highlighting applied. When you find it, either modify it to match fewer words, or delete it. (This should also speed up Logos because it won't be executing an expensive query in the background.)

Posts 28712
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Jan 8 2014 10:30 AM

Steve Brannon:
Screenshots follow...

Thanks for posting those. In the future, you should use a .jpg screen shot. Did you change your default settings in OSX to take screen shots using .tiff (very large and unwieldy)? 

Here is your screen shot in case anyone else wants to see:

OSX & iOS | Logs |  Install

Posts 80
Steve Brannon | Forum Activity | Replied: Wed, Jan 8 2014 10:52 AM

I do not have any visual filters enabled unless L5 comes with some.  I don't even know what a visual filter is.

Posts 80
Steve Brannon | Forum Activity | Replied: Wed, Jan 8 2014 10:53 AM

I used "GRAB".  By default it captures tiff's.  Just didn't feel like looking up the Mac keystroke for screen capture again (I keep forgetting it).

Posts 80
Steve Brannon | Forum Activity | Replied: Wed, Jan 8 2014 10:54 AM

Yes, I was searching to prepare for a Bible Study.  But I don't see what this has to do with the bug unless you're suggesting that using L5 to search our resources is a bad thing?  <<confused>>

Posts 23630
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Jan 8 2014 11:16 AM

Steve Brannon:

Yes, I was searching to prepare for a Bible Study.  But I don't see what this has to do with the bug unless you're suggesting that using L5 to search our resources is a bad thing?  <<confused>>

When you execute a search, Logos highlights the search results in the texts.

a visual filter is a way of having a permanent search - with associated highlights - running in the background.

The screen shot indicates that you have some sort of wildcard search running which is highlighting every word.

Does this help at all?

Posts 28712
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Jan 8 2014 11:39 AM

Graham Criddle:
The screen shot indicates that you have some sort of wildcard search running which is highlighting every word.

Except he doesn't, does he? Can you see any search tabs?

OSX & iOS | Logs |  Install

Posts 28712
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Jan 8 2014 11:40 AM

Steve Brannon:
I used "GRAB".  By default it captures tiff's.  Just didn't feel like looking up the Mac keystroke for screen capture again (I keep forgetting it).

Well make sure you convert to .jpg so that the image can be shown. Your laziness required more work on my part. Stick out tongue

OSX & iOS | Logs |  Install

Posts 23630
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Jan 8 2014 12:06 PM

alabama24:

Graham Criddle:
The screen shot indicates that you have some sort of wildcard search running which is highlighting every word.

Except he doesn't, does he? Can you see any search tabs?

And that is a very fair point!

three options I can think of:

  1. There is a search panel open in a floating window
  2. there is a visual filter configured (but I note Steve says he hasn't created one)
  3. There is something happening here I don't understand!

Steve, if the first two aren't the case it may be worth contacting Logos support and asking them to log in remotely.

Posts 80
Steve Brannon | Forum Activity | Replied: Wed, Jan 8 2014 12:35 PM

;-P back at you.

Posts 80
Steve Brannon | Forum Activity | Replied: Wed, Jan 8 2014 12:36 PM

No floating search panel.

Perhaps I don't understand how these boards work.  I was told to post it here with the title "Bug:" so that Logos staff could see it.

<<heavy sigh>>

Posts 23630
Forum MVP
Graham Criddle | Forum Activity | Replied: Wed, Jan 8 2014 1:34 PM

Hi Steve

Steve Brannon:

No floating search panel.

Perhaps I don't understand how these boards work.  I was told to post it here with the title "Bug:" so that Logos staff could see it.

<<heavy sigh>>

Sorry this is difficult.

Logos staff do look at these forums. Bradley, who posted, above is one of their lead designers. But most of the contributors are regular users.

To get a formal case logged with Logos, who are the only people who can remotely access your machine with your permission, does require contacting them.

Contact details are at https://www.logos.com/contact although from what you said above it sounds as though you have already contacted them about this.

Graham

Posts 8867
LogosEmployee

Steve Brannon:
 I don't even know what a visual filter is.

Click the Documents menu. Near the top, there will probably be a document of type "Visual Filter". If you click it, it will open. I'm guessing it has a very broad query (like "*") and applies Grey Highlighting. This is causing the highlighting that you see.

To delete it, open the Documents menu, right-click that visual filter document, and choose Delete.

Posts 80
Steve Brannon | Forum Activity | Replied: Thu, Jan 9 2014 5:30 PM

Bradley,

Thanks for the pointer.

I did have a visual filter turned on, but I don't see why that filter would cause the problem I am seeing, namely: no visual highlighting visible; switch to another running program; switch back to L5; the entire screen suddenly has visual highlighting...  I still consider this a bug.

Respectfully,

Steve

Posts 8867
LogosEmployee

Steve Brannon:

the problem I am seeing, namely: no visual highlighting visible; switch to another running program; switch back to L5; the entire screen suddenly has visual highlighting...  I still consider this a bug.

A query for "*" takes a very, very long time to run. (We do not recommend running searches or creating visual filter that use "*".) Switching to another app gives Logos 5 enough time to finish running this query in the background and apply the visual filter.

If you don't want this grey highlighting to be applied to your resources, delete or disable this visual filter.

Posts 1
ManUp777 | Forum Activity | Replied: Mon, Jan 20 2014 4:59 AM

I had the same problem (Logos newbie) and these instructions helped me fix mine. I don't remember creating a visual filter, but it was there, and when deleted, immediately solved the problem. Thank you.

Page 1 of 1 (20 items) | RSS