Logos 5 for Windows - CPU usage is crazy high

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 13
Jesse Adams | Forum Activity | Posted: Tue, Feb 4 2014 12:34 PM

I'm updated and indexed, yet my CPU usage is at like 224mb while I'm not doing anything. I've run plenty of programs on this PC, but Logos 5 slows me completely down. Mouse is clunky as is everything else I try to run when it's open. Takes 2 seconds for the program to shift from tab to tab. How can I alleviate the memory used by this program so I can run both it and at least another program? 

I'm Windows 7 with 4GB of RAM.

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 4 2014 1:11 PM

Jesse Adams:
I'm updated and indexed, yet my CPU usage is at like 224mb while I'm not doing anything

CPU usage is a percentage and 100 is the maximum! What is 224?

Jesse Adams:
I'm Windows 7 with 4GB of RAM.

which is sufficient to run Logos with other programs, but what is your machine make/model, and what CPU?

Dave
===

Windows & Android

Posts 10102
Forum MVP
NB.Mick | Forum Activity | Replied: Tue, Feb 4 2014 1:38 PM

Dave Hooton:

Jesse Adams:
I'm updated and indexed, yet my CPU usage is at like 224mb while I'm not doing anything

CPU usage is a percentage and 100 is the maximum! What is 224?

I think he refers to RAM usage (in taskmgr the column to the right of CPU % usage).

Logos is notoriously high on this - currently showing near 300 MB for me by running idle with one main window and a floating window. It can easily go into the 400s I think (Chrome is hiding its RAM hunger in this display by running several processes at once). Nevertheless, RAM usage alone doesn't slow down the machine.  

Running Logos 8 latest beta version on Win 10

Posts 13
Jesse Adams | Forum Activity | Replied: Tue, Feb 4 2014 1:45 PM

CPU Usage gets up to 59% on idle with only LOGOS and my Task Manager open. 

I'm on a Toshiba Satellite A505 with Intel Core 2 Duo CPU T6600 @ 2.2GHz   -   64 Bit O.S.

Besides the delay in the mouse and jitters as move throughout the program, if I try to play any music it's rough with digital static (once the song finally opens, which takes a good 2 minutes). 

I've cleaned everything a few times with CCleaner and I've re-started. So I'm at a loss now.

Like I said, I run plenty on this machine. Logos is introducing me suddenly to these problems, however. I really want to use it!

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 4 2014 2:07 PM

Jesse Adams:
CPU Usage gets up to 59% on idle with only LOGOS and my Task Manager open. 

How much of that is actually due to Logos as background tasks can hog the CPU at times (contributing most of the 59% usage)?

Jesse Adams:
I've cleaned everything a few times with CCleaner and I've re-started. So I'm at a loss now.

Have you  emptied the Recycle Bin, got rid of old restore points (can be several GB) and defragged the drive? You can use Disk Cleanup (in Administrative Tools) for the first two. Defraggler is a good free tool as it is important to keep the Logos indexes defragged (you can choose files rather than defrag the whole drive).

Dave
===

Windows & Android

Posts 491
Mr. Simple | Forum Activity | Replied: Tue, Feb 4 2014 2:31 PM

My concern is that Logos is not aggressive enough on RAM for machines that have it available.

Posts 13
Jesse Adams | Forum Activity | Replied: Tue, Feb 4 2014 3:36 PM

I will attempt the Defraggler. CCleaner empties everything unnecessary automatically.

Posts 3938
abondservant | Forum Activity | Replied: Tue, Feb 4 2014 3:39 PM

Mr. Simple:

My concern is that Logos is not aggressive enough on RAM for machines that have it available.



+1 Would love to have a logos version that used more of my CPU and Memory... As I understand it, Logos is a single thread application, and I have an octocore chip... Further, with 32gb of ram available (for graphic/video editing) would love for it to use more especially for indexing. Maybe there could be a button (use more system resources, are you sure? Yes/no - something like that).

For reference, I'm using .8% of my available processing power, and 179mb of ram at idle. Doing something intense like searching my library for the word "the" spiked the cpu usage to 20%, and ram usage to 267mb. Took 2.87 seconds, and found 4m results in my pbs, and 12 seconds to find 54m results in my logos library proper. Really, that's nothing to complain about....


L2 lvl4, L3 Scholars, L4 Scholars, L5 Platinum,  L6 Collectors. L7 Baptist Portfolio. L8 Baptist Platinum.

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Tue, Feb 4 2014 4:00 PM

Jesse Adams:
CPU Usage gets up to 59% on idle with only LOGOS and my Task Manager open. 

As Dave said: There can be other background tasks running contributing to the CPU usage. Open Task Manager, select the Details tab, and sort by the CPU column. Watch it for a while, especially during slow downs and note the processes using the most CPU and how much they are using. It's probably not Logos unless it is indexing or in the middle of a search.

Logos and the indexer are only at the top because of indexing in this shot, otherwise Logos will normally be much further down the list:

abondservant:
As I understand it, Logos is a single thread application

Note the Threads column above. Big Smile

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 4 2014 8:04 PM

abondservant:

Mr. Simple:

My concern is that Logos is not aggressive enough on RAM for machines that have it available.



+1 Would love to have a logos version that used more of my CPU and Memory... As I understand it, Logos is a single thread application, and I have an octocore chip... Further, with 32gb of ram available (for graphic/video editing) would love for it to use more especially for indexing. Maybe there could be a button (use more system resources, are you sure? Yes/no - something like that).

For reference, I'm using .8% of my available processing power, and 179mb of ram at idle. Doing something intense like searching my library for the word "the" spiked the cpu usage to 20%, and ram usage to 267mb. Took 2.87 seconds, and found 4m results in my pbs, and 12 seconds to find 54m results in my logos library proper. Really, that's nothing to complain about....

This debate is done and dusted, and is totally inappropriate in a thread discussing someone's problem.

Dave
===

Windows & Android

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Feb 4 2014 8:11 PM

Jesse Adams:
CCleaner empties everything unnecessary automatically.

Not so! You can use its Tools section on "System Restore" to manually delete old restore points.

Dave
===

Windows & Android

Posts 13
Jesse Adams | Forum Activity | Replied: Wed, Feb 5 2014 6:26 AM

After Defraggling, things seems to be working much more smoothly. Thanks for the recommendation. CPU usage is at 13% on idle with Chrome open, and Logos is taking up only 129,000k of memory. As I looked at all the fragmented files in Defraggle, nearly 3/4 were from Logos 4, a program I had on my computer for less than a day before upgrading to Logos 5. Do you think that had something to do with it?

Thanks for all your help! Godspeed. Now I'm going to study :-)

Posts 25032
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Feb 5 2014 1:00 PM

Jesse Adams:
As I looked at all the fragmented files in Defraggle, nearly 3/4 were from Logos 4, a program I had on my computer for less than a day before upgrading to Logos 5

An upgrade to Logos 5 will replace Logos 4 files in the \Logos4 folder so those fragmented files are part of Logos 5! The index.* files can be quite large but de-fragmenting those will be beneficial.

Dave
===

Windows & Android

Page 1 of 1 (13 items) | RSS