BUG: 5.2a: Applying tags to group of selected resources after one is deselected

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 18867
Rosie Perera | Forum Activity | Posted: Tue, Apr 8 2014 2:34 PM

Open the Library in grid view.

Select three or more adjacent resource by clicking on the first and then shift-clicking on the last.

Now deselect the last one of the bunch by ctrl-clicking on it.

Click "Add tag" and type in any tag of your choosing.

Result: The new tag gets applied to all of the originally selected items, including the one you deselected.

Wrong. It should only get applied to the ones that were selected at the time, not the one that was deselected.

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Tue, Apr 8 2014 2:47 PM

Rosie Perera:
Wrong. It should only get applied to the ones that were selected at the time, not the one that was deselected.

More accurately, the issue is that Ctrl-clicking the last resource doesn't actually deselect it; if you check the "# resources selected" message you can see the number doesn't change. This seems to only apply to the last resource in the selected group.

I'll make a case.

Edit: This is not an issue on Mac, where Cmd-Click correctly deselects any of the selected resources.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 18867
Rosie Perera | Forum Activity | Replied: Tue, Apr 8 2014 3:22 PM

Dylan Rondeau:
More accurately, the issue is that Ctrl-clicking the last resource doesn't actually deselect it; if you check the "# resources selected" message you can see the number doesn't change. This seems to only apply to the last resource in the selected group.

I see. Well, it's weird because the highlight does get removed from the ctrl-clicked item, even when it's the last resource in the selected group. But you're right, it doesn't change the "# resources selected" message.

Posts 1471
Angela Murashov | Forum Activity | Replied: Wed, May 14 2014 3:11 PM

Dylan Rondeau:

Rosie Perera:
Wrong. It should only get applied to the ones that were selected at the time, not the one that was deselected.

More accurately, the issue is that Ctrl-clicking the last resource doesn't actually deselect it; if you check the "# resources selected" message you can see the number doesn't change. This seems to only apply to the last resource in the selected group.

I'll make a case.

Edit: This is not an issue on Mac, where Cmd-Click correctly deselects any of the selected resources.

This should be fixed in 5.2b Beta 1. 

Page 1 of 1 (4 items) | RSS