Crash on Mac opening resources

Page 1 of 1 (17 items)
This post has 16 Replies | 1 Follower

Posts 109
Darryl Burling | Forum Activity | Posted: Mon, Apr 14 2014 1:28 PM

Hi there, 

I'm having intermittent (i.e. frequent but not consistent) crashes opening resources in Logos v5 on a Mac. 

It is a fairly new install (new computer a couple of weeks ago). 

I've attached a log below. It looks like it is having problems with some API calls, but I'm not sure whether (or if) this would cause a problem opening resources.

4237.LogosLogs.darryl.20140414-132252.zip

Thanks for any help you can offer. 

Darryl

Posts 22108
Forum MVP
Graham Criddle | Forum Activity | Replied: Mon, Apr 14 2014 1:47 PM

Hi Darryl

It looked as though it crashed trying to open NIDOTTE.

Is that correct and - if so - does trying to open that resource (or a particular article in that resource) always cause a crash?

Graham

Posts 109
Darryl Burling | Forum Activity | Replied: Mon, Apr 14 2014 1:56 PM

It crashed this time trying to open NIDOTTE, however, it crashes opening any resource - though not consistently. I've opened NIDOTTE successfully on other occasions, but have had it crash on another resource. 

For example - I just tried to open BHS and that also caused a crash - and NIDOTTE was already open. 

Posts 109
Darryl Burling | Forum Activity | Replied: Mon, Apr 14 2014 2:10 PM

Here is another log - this time it crashed opening Volume 2 of the updated EBC series

6472.LogosLogs.darryl.20140414-140746.zip

Posts 109
Darryl Burling | Forum Activity | Replied: Wed, Apr 16 2014 8:01 AM

FWIW, it seems to be a problem only when opening from the library button at the top of the window when it is in Title View. I switched to detail view and it doesn't seem to crash. 

Posts 3156
LogosEmployee
Thomas Ball | Forum Activity | Replied: Wed, Apr 16 2014 5:07 PM

Hi Darryl,

Have you been able to open the EBC since this last crash?

 

Posts 10601
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Apr 17 2014 3:38 AM

Darryl Burling:
FWIW, it seems to be a problem only when opening from the library button at the top of the window when it is in Title View. I switched to detail view and it doesn't seem to crash.

You may have found another bug in Mono, but I cannot duplicate it. (Mono is the code underlying Logos for Mac.)

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

Posts 109
Darryl Burling | Forum Activity | Replied: Thu, Apr 17 2014 8:28 AM

I can open EBC vol 2 no problems. The problem is not the book per se, but the method of opening it seems. 

Jack Caviness:

You may have found another bug in Mono, but I cannot duplicate it. (Mono is the code underlying Logos for Mac.)

Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.

I saw that too. Are the logos developers contributing to Mono? Given their dependance on it, it might be prudent to...

Posts 109
Darryl Burling | Forum Activity | Replied: Thu, Apr 17 2014 11:45 AM

Just to narrow this down further, the crash doesn't seem to occur if I open a library pane (i.e. cmd+L), only if I click the library button and try and open a resource. 

Hope that helps. 

Posts 10601
Forum MVP
Jack Caviness | Forum Activity | Replied: Thu, Apr 17 2014 1:11 PM

Darryl Burling:
Are the logos developers contributing to Mono?

Believe Tom Philpot indicated that they do.

BTW: I cannot duplicate your crash.

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Apr 17 2014 6:23 PM

Darryl Burling:

Just to narrow this down further, the crash doesn't seem to occur if I open a library pane (i.e. cmd+L), only if I click the library button and try and open a resource. 

Hope that helps. 

Darryl,

That helps alot! Having a set of steps to reproduce this (even a partial set) is helpful. I saw the crash reports for this and created a case for our developers to look at two days ago. The information in the crash log was not super helpful, so knowing that it's something in the Library popup exclusively will help us narrow this down.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Apr 17 2014 6:27 PM

Darryl,

One other question: Are you clicking on the title to open the resource, or pressing Enter or dragging the resource out? Are you typing in the filter box to filter before you open the resource?

You seem to be able to reproduce this with some regularity, so I'm just curious if there might be more information that can help us.

Mobile Development Team Lead

Posts 109
Darryl Burling | Forum Activity | Replied: Thu, Apr 17 2014 7:40 PM

I normally filter by author or title and then click the title I want, the crash is fairly consistent when I do this. 

If I drag the book out or use the arrow keys to scroll down and click enter the crash doesn't occur. It only occurs in tile view and only if I click on the library icon in the toolbar. If I open the library in a new pane (cmd+L) it works fine. 

It could be something funny on my computer, but given it is a two week old computer with a fresh install of Logos, the only upgrades it has had have came down since around the 26th of March. 

Thanks for investigating!

Posts 303
LogosEmployee
Martin Potter | Forum Activity | Replied: Mon, Apr 21 2014 1:41 PM

Darryl,

We have been unable to reproduce the crash internally. Looking at the crash reports, it appears to be a result of some accessibility calls. Do you have any accessibility features, such as Voice Over, turned on?

Thank you,

Martin

Mac Developer
Faithlife

Posts 109
Darryl Burling | Forum Activity | Replied: Mon, Apr 21 2014 1:49 PM

Thanks for following up, the only feature I have on is font smoothing - and that might be on by default as I don't remember changing it (though I may have). 

Posts 109
Darryl Burling | Forum Activity | Replied: Mon, Apr 28 2014 4:59 PM

What about retina/display settings? I've got a 15" MacBook Pro Retina with two external screens, one running at 2560x1600 and one at 1200x1920 (turned sideways). Just a thought. My testing hasn't shown these to make any difference, but I'll look more tomorrow morning.

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Tue, Apr 29 2014 2:05 PM

This should be fixed in 5.2a SR-3. Please let us know if you continue to crash. Smile

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Page 1 of 1 (17 items) | RSS