downloading new material

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 1
Ryan Lee | Forum Activity | Posted: Fri, Jul 18 2014 11:32 AM

Hi, i recently got the New Interpreter's dictionary of the bible and i want to dl it to my computer but for some reason it is not. I have Logos 4, is there some reason for this or a solution?

Posts 26104
Forum MVP
MJ. Smith | Forum Activity | Replied: Fri, Jul 18 2014 6:07 PM

I don't have the product but it is likely that it has tagging requiring Logos 5. Is there a reason you have not upgraded to the free L5 engine?

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 7943
LogosEmployee

NIDB requires Logos 5.2a SR-7; it will not work on earlier versions of the software. To install it for free, visit https://www.logos.com/install

(For more information, see http://blog.logos.com/2014/01/changes-to-logos-product-support/ and https://www.logos.com/support/free-support).

Posts 8967
RIP
Matthew C Jones | Forum Activity | Replied: Fri, Jul 18 2014 7:52 PM

Bradley Grainger (Logos):
NIDB requires Logos 5.2a SR-7; it will not work on earlier versions of the software.

It would be nice if that were listed on the product page.  

Do all new releases require Logos 5.2a SR-7?

Logos 7 Collectors Edition

Posts 7943
LogosEmployee

Super.Tramp:

It would be nice if that were listed on the product page.

Do all new releases require Logos 5.2a SR-7?

You can assume that all products require a Supported or Maintenance version of the software. Unsupported versions are... well, unsupported. See https://www.logos.com/support/free-support 

99% of customers using Logos Bible Software are using an OS that can run Logos 5.2a SR-7; if you're not already running it, you can update for free here: https://www.logos.com/install 

Posts 8967
RIP
Matthew C Jones | Forum Activity | Replied: Fri, Jul 18 2014 8:11 PM

Bradley Grainger (Logos):
99% of customers using Logos Bible Software are using an OS that can run Logos 5.2a SR-7;

For the record, what are the oldest Microsoft and Apple operating systems that will run Logos 5? 

Logos 7 Collectors Edition

Posts 7943
LogosEmployee

Super.Tramp:
For the record, what are the oldest Microsoft and Apple operating systems that will run Logos 5? 

Logos 4.6c will run on Windows XP SP3 or Mac OS X 10.5 (or later).

Logos 5.2a will run on Windows Vista SP2 or Mac OS X 10.6 (or later).

Logos 5.3 (not released yet) will require Windows 7 SP1 or Mac OS X 10.9 (or later).

Page 1 of 1 (7 items) | RSS