New Checkout workflow coming to Logos.com

Page 1 of 1 (13 items)
This post has 12 Replies | 1 Follower

Posts 698
LogosEmployee
Cameron Watters (Faithlife) | Forum Activity | Posted: Wed, Oct 1 2014 11:47 AM

In the very near future (could be a few hours, could be a few days) a new checkout workflow will be coming to Logos.com.

This new workflow should simplify the checkout process for most regular customers, particularly those that keep payment information on file. We've also added the ability to save items for later and add items from your wish lists right in the cart. Also, we no longer require a credit card for orders with a $0 subtotal (e.g. Free Book of the Month).

If you'd like to start using it immediately, you can join this Faithlife.com group: https://faithlife.com/logos-com-checkout-beta

Feel free to post questions or feedback to the group or to this forum thread. I promise to read every piece of feedback.

Director of Engineering for Enterprise and Operations

Posts 8601
TCBlack | Forum Activity | Replied: Wed, Oct 1 2014 12:30 PM

Cameron Watters (Faithlife):
Also, we no longer require a credit card for orders with a $0 subtotal (e.g. Free Book of the Month).

THIS has just made a number of people very happy. Yes

Truth Is Still Truth Even if You Don't Believe It

Check the Wiki

Warning: Sarcasm is my love language. I may inadvertently express my love to you.

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 1:09 PM

I added the infamous NAS package to my cart and got this:

Empty cart, with a price tag. Clicked the remove button even though nothing was selected and then got:

I don't remember having that or anything in my cart to switching over to this beta, but at one time I know I did have that title from the Presching collection during that Pick and Mix sale. It could have still been in there so this might be an effect of having something in cart prior to switching to the beta???

However, selecting the box next to CM100 only, not NAS, And then selecting Remove, removes the item but takes me back to the empty cart with the corrected price. Refreshing shows the NAS.

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 1:22 PM

Clicking Add to Cart in the Recommendations section beside the cart also results in an empty cart--showing lines for two line items, but no items. Total price is shown. Just like the empty cart image above.

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 1:27 PM

Is there still not going to be a way to add a purchase to an existing payment plan?

EDIT:

After entering the phone number for creating a NEW payment plan, you have to click outside the phone number edit box for it to register. Would prefer it to recognize a valid phone number or pattern and automatically validate the form.

Once you go to ../cart/checkout, there is no way back to ../cart if I change my mind and want to add/remove an item from the cart.

Posts 4
Jason Offutt (Faithlife) | Forum Activity | Replied: Wed, Oct 1 2014 2:21 PM

Randy, thank you for your feedback. Just to make sure we're covering all of our bases, I figured I'd double check whether your have JavaScript enabled in your browser.

Thanks!

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 2:38 PM

Jason Offutt (Faithlife):

Randy, thank you for your feedback. Just to make sure we're covering all of our bases, I figured I'd double check whether your have JavaScript enabled in your browser.

Yes JavaScript is enabled. This is Chrome Version 37.0.2062.120 m (there IS a pending update I haven' t installed yet.) Have not tested on other browsers yet, but I can trigger the empty cart display doing just about anything. Chrome settings are almost stock; in fact, this is a fresh install of and on Windows 8.1, < 2 wks. A Refresh always brings shows the cart correctly.

Also, seen a number of times but can't reliably reproduce in the Save for Later section occasionally loses state. Sometimes I can check an item and the Add to Cart button does not work. Sometimes I can click the All button and the item(s) are not checked.

I'll experiment with different browsers and disabling extensions as soon as I get a chance, within the next hour or so.

EDIT:

Actually, I may have already found it. Need more testing to confirm, but the culprit might be this RefTagger Extension:

https://community.logos.com/forums/p/86912/634501.aspx 

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 2:52 PM

SUGGESTION:  If I add an item to the cart that is part of a collection, show it in the Recommendations section.

Posts 4
Jason Offutt (Faithlife) | Forum Activity | Replied: Wed, Oct 1 2014 3:27 PM

Randy W. Sims:

Actually, I may have already found it. Need more testing to confirm, but the culprit might be this RefTagger Extension:

https://community.logos.com/forums/p/86912/634501.aspx 

Please let me know if that lead anywhere. In the interim, we're looking into a possible fix from our end as well. Thanks again, Randy!

Posts 2062
Forum MVP
Randy W. Sims | Forum Activity | Replied: Wed, Oct 1 2014 3:55 PM

Jason Offutt (Faithlife):

Randy W. Sims:

Actually, I may have already found it. Need more testing to confirm, but the culprit might be this RefTagger Extension:

https://community.logos.com/forums/p/86912/634501.aspx 

Please let me know if that lead anywhere. In the interim, we're looking into a possible fix from our end as well. Thanks again, Randy!

I'm pretty confident now that that extension is causing it. I've added/removed the extension several times and on several system and the problem disappears when it's uninstalled and comes back after installing it. Don't know if it's behaving badly or some namespace collision issue. I do think this was causing the invisible items in the cart (they were there and clickable, but not visible), the state issues in the Save for Later section and a similar issue deleting codes with the Coupon section (the list under the Coupon code edit box) that I just noticed. All of these problems disappear after removing the extension. 

Posts 13343
Forum MVP
Mark Barnes | Forum Activity | Replied: Wed, Oct 1 2014 4:35 PM

Apply Logos Credit ought to be automatically checked, IMO. It's much less obvious than before, and it would be easy to miss. Also the total amount held in credit shouldn't be in parentheses (which indicates a negative number). The amount being applied should be in parentheses (and is).

Posts 4
Jason Offutt (Faithlife) | Forum Activity | Replied: Wed, Oct 1 2014 4:37 PM

Randy W. Sims:

I'm pretty confident now that that extension is causing it. I've added/removed the extension several times and on several system and the problem disappears when it's uninstalled and comes back after installing it. Don't know if it's behaving badly or some namespace collision issue. I do think this was causing the invisible items in the cart (they were there and clickable, but not visible), the state issues in the Save for Later section and a similar issue deleting codes with the Coupon section (the list under the Coupon code edit box) that I just noticed. All of these problems disappear after removing the extension. 

Great to hear. Thank you for the update!

Posts 13343
Forum MVP
Mark Barnes | Forum Activity | Replied: Sat, Oct 4 2014 4:17 AM

When I click on my "Jesus of Nazareth" CP order on mobile, it opens the wrong product page. It works fine on the desktop site.

Page 1 of 1 (13 items) | RSS