Page 1 of 1 (6 items)
This post has 5 Replies | 1 Follower

Posts 1367
JimTowler | Forum Activity | Posted: Wed, Oct 29 2014 8:53 PM

My Desktop shows 86 for AYBC, but only 21 on Logos Bible app.

Just opened Vyrso and it wanted to update the library. Its reporting 33 resources. (Typing AYBC into Library tab)

How can I get them updated/synced please, to get the full set?

EDIT: Updated title to report this as a BUG

Posts 27688
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Oct 29 2014 9:04 PM

JimTowler:
Just opened Vyrso and it wanted to update the library. Its reporting 33 resources. (Typing AYBC into Library tab)

Did you try AYB instead? 

OSX & iOS | Logs |  Install

Posts 1367
JimTowler | Forum Activity | Replied: Wed, Oct 29 2014 9:32 PM

Hi Alabama. Same result.

On my iPad, I can't see the AYBC resource for "Exodus" in the Library if I search by "AYBC", or "AYB" or "EXODUS" or "Propp" (the author).

However, I've added a link into a document, and I can open it on my iPad from the link in the document which has synced to the ipad. Same thing on the iPad DOES NOT open it - but goes into edit mode.

Maybe I've got too many resources and have blown the buffered for the Library index.

I've nuked Vyrso off my iPad and reinstalled it. Something I HATE doing and only defective software gets fixed doing things like that. Anyway, its finally updated the index progress bar in the library tab and is now showing 86.

Is there a way to force the Logos Bible app to refresh the index WITHOUT a reinstall?

(Like others, I sometimes have many hundreds of resources downloaded, as 3G/4G cell traffic is very limited and expensive here in New Zealand. Reinstalls is NOT the answer to application bugs)

Both my iPad and iPhone report the same numeric totals for all resources (but Vyrso and Bible are a little different due to various reasons).

However clearly the index has not rebuilt correctly as the search fails to find the resources.

So currently:

iPhone Bible: AYBC = 21

iPhone Vyrso: AYBC = 86

iPad Bible: AYBC = 2

iPad Vyrso: AYBC = 4

This has got to be a BUG!!!

Posts 1367
JimTowler | Forum Activity | Replied: Wed, Oct 29 2014 10:46 PM

Seems running "Rebuild Index" on the home tab has worked this time. It DID NOT earlier, so I doubted that was the fix. So iPhone has 86 in both apps. Maybe the Logos server was maxed out and was adding to why the index would not update.

iPad is updating its index now. It flashed up some error that was too hard to catch about an hour ago. This time looking good ...

OK all 4 apps now report 86 AYBC resources after reinstall or "Rebuild Index".

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Wed, Oct 29 2014 11:33 PM

Jim,

Everything you've mentioned in this thread is a result of very high load on our servers and/or the minimal downtime caused by hardware upgrades to help resolve the load issue.  In case you didn't know, we just released Logos 6 and our servers have been overwhelmed.

I'm glad things are working for you now - sorry for the trouble.

Posts 1367
JimTowler | Forum Activity | Replied: Thu, Oct 30 2014 12:39 AM

Kevin,

Thanks for your feedback and help.

Yes - I was thinking it was about something that must have been failing during the index rebuild, as it was not about the resource counts (they matched).

If the web services are returning errors, the client apps really should somehow offer to report an error and that the index is incomplete/invalid, rather than what happened where its just plain wrong!

I'm asking Faithlife to please review the failure modes, as its clear it can't be assumed the servers will also be there, or complete any lookup or request.

Regards,

Jim

Page 1 of 1 (6 items) | RSS