Logos 6 is Slow

Page 1 of 6 (107 items) 1 2 3 4 5 Next > ... Last »
This post has 106 Replies | 11 Followers

Posts 389
James C. | Forum Activity | Posted: Tue, Dec 16 2014 3:26 AM

I have noticed that Logos 6 has been running very slow lately and clunky. Scrolling is not smooth and opening up books is slow. Right or left arrowing to the next book is slow.

This is something that didn't happen when L6 first came out. I was very happy with the speed but now it's just slow.

I'm running:

Logos Bible Software 6.0a SR-36.0.1.1339

on Windows 8.1 16.0 GB. 64bit

Intel 17-3770 cpu @ 3.40ghz

Posts 1700
JoshInRI | Forum Activity | Replied: Tue, Dec 16 2014 9:04 AM

As I read this I am pondering going back to 5.0 myself.  Adopting a wait-and-see for now.

Posts 322
Bob Soule | Forum Activity | Replied: Tue, Dec 16 2014 11:25 AM

James C.:

I have noticed that Logos 6 has been running very slow lately and clunky. Scrolling is not smooth and opening up books is slow. Right or left arrowing to the next book is slow.

This is something that didn't happen when L6 first came out. I was very happy with the speed but now it's just slow.

I'm running:

Logos Bible Software 6.0a SR-36.0.1.1339

on Windows 8.1 16.0 GB. 64bit

Intel 17-3770 cpu @ 3.40ghz

I am on 6.0a SR3 as well, and have had the same sluggish performance since 6.0a beta 1. They said there was an active case in development but no new news about this yet.

I wonder if this is a widespread windows issue?

Posts 25378
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, Dec 16 2014 11:40 AM

James C.:
I have noticed that Logos 6 has been running very slow lately and clunky. Scrolling is not smooth and opening up books is slow. Right or left arrowing to the next book is slow.

More specifically, I find Library scrolling is noticeably slower. Resource scrolling is OK, except that Reverse Interlinears are somewhat "clunky".

Windows 7 with SSD and Intel i5.

Dave
===

Windows 10 & Android 8

Posts 5270
Dan Francis | Forum Activity | Replied: Tue, Dec 16 2014 3:10 PM

Dave Hooton:

James C.:
I have noticed that Logos 6 has been running very slow lately and clunky. Scrolling is not smooth and opening up books is slow. Right or left arrowing to the next book is slow.

More specifically, I find Library scrolling is noticeably slower. Resource scrolling is OK, except that Reverse Interlinears are somewhat "clunky".

Windows 7 with SSD and Intel i5.

I am using Verbum 6.0a SR-3 6.0.1.1339 Mac while running Mac OS X 10.10.1... Something seems very wrong because on the mac scrolling is smooth as glass, and I am scrolling faster than anyone could read. The RI (I tired NRSV) in both the greek and hebrew also scrolls fast as I can do it. My Library is also scrolling great. As well this release for me seemed to fix the slow population of right clicked words. I hope Logos fixes the issues you are experiencing, I find it quite odd that a Release would have made it out with such defects.

-Dan

Posts 18856
Rosie Perera | Forum Activity | Replied: Tue, Dec 16 2014 4:15 PM

Yup, it's been quite slow for me lately too. It's getting frustrating.

Some of the things that are slow:

Updating Library catalog while tagging or assigning ratings

Populating dropdowns (e.g., the Open menu in Collections, but pretty much any dynamic dropdown is slower now).

Search is noticeably slower than it used to be

Opening Layouts

Sometimes the program seems to hang for 5-10 seconds or so before user input (e.g., clicking to bring the focus somewhere) takes effect.

Posts 1578
John Kight | Forum Activity | Replied: Tue, Dec 16 2014 5:04 PM

A lot of the same for me as well. Sleep

For book reviews and more visit sojotheo.com 

Posts 1874
Alan Macgregor | Forum Activity | Replied: Tue, Dec 16 2014 9:54 PM

Scrolling on my Mac is slow. Yesterday I had two crashes while scrolling through a commentary quickly. The crash logs were submitted on restart automatically.

Logos is the slowest program on my system, but then it always has been! However, it is the most memory-greedy also.

I hope things will change, but I doubt it.

Every blessing

Alan

iMac Retina 5K, 27": 4GHz; 16GB RAM;MacOS 10.12.2; 1TB FD; Logos 7

MacBook Air 13.3": 1.8GHz; 4GB RAM; MacOS 10.12.2; 256GB SSD; Logos 7

iPad Pro 32GB WiFi iOS 10.2

iPhone 5s 32GB iOS 10.2

Posts 18856
Rosie Perera | Forum Activity | Replied: Tue, Dec 16 2014 10:26 PM

Logos.com searches are really slow lately too, but I know this is unrelated. I find that they take at least 20 seconds now. Ugh!

Posts 732
Bootjack | Forum Activity | Replied: Wed, Dec 17 2014 3:47 AM

It's got to be them there SSD Drives everyone is ranting about!  :-)

Posts 1505
Forum MVP
Veli Voipio | Forum Activity | Replied: Wed, Dec 17 2014 4:07 AM

I have a SSD drive and a fast computer and only the library is clunky.

English is not my mother tongue but I assume "clunky" is the right word.

I feel the clunkiness may have something to do with that if they have reorganized the library database with views.

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 8.1

Posts 1505
Forum MVP
Veli Voipio | Forum Activity | Replied: Wed, Dec 17 2014 10:43 AM

This morning I've updated to L6 SR-4 and I think it caused some additional sluggishness to L6.

Intermittently I see the rotating ring which may be a new form of the hourglass, and I can take a cup of coffee or so but the program does not stop, and after coffee it works fine for an hour or so.

Gold package, and original language material and ancient text material, SIL and UBS books, discourse Hebrew OT and Greek NT. PC with Windows 8.1

Posts 322
Bob Soule | Forum Activity | Replied: Fri, Dec 19 2014 7:19 AM

I updated to L6 SR-4 this morning as well. 

Still have lags with library filter, ESV bible scrolling and ESV read aloud to name a few. However, for me it does not seem any slower than it has been for 6.0a.

 

Posts 16
Ken J | Forum Activity | Replied: Fri, Dec 19 2014 12:53 PM

I think startup is slow as well - the splash screen is up for 15-20 seconds each time I start up. I have a pretty high powered desktop system - Win 64, I3770K cpu, 16GB Ram, SSD C drive, etc.

Posts 194
KPK | Forum Activity | Replied: Fri, Dec 19 2014 6:56 PM

I purchased a brand new Mac with a large memory! I don't have anything on my desktop except for Microsoft Word, Logos, Pages Evernote, little things like that. And it's still super slow. Driving me insane. It's not even usable (to me) because if I have multiple windows open it crashes on me. I have stayed away from Logos for a couple of weeks now. I'm a little upset but what else can I do. I love this software and want to use it on my new computer.  

Posts 322
Bob Soule | Forum Activity | Replied: Sat, Dec 20 2014 8:34 AM

KPK:

I purchased a brand new Mac with a large memory! I don't have anything on my desktop except for Microsoft Word, Logos, Pages Evernote, little things like that. And it's still super slow. Driving me insane. It's not even usable (to me) because if I have multiple windows open it crashes on me. I have stayed away from Logos for a couple of weeks now. I'm a little upset but what else can I do. I love this software and want to use it on my new computer.  

It would be better to start a new thread for your issue, along with your hardware specs and any specifics of what you are doing in Logos 6. Also, be sure any downloads and/or indexing had been completed as this can slow things down quite a bit.

Posts 322
Bob Soule | Forum Activity | Replied: Sat, Dec 20 2014 1:36 PM

Bob Soule:

I updated to L6 SR-4 this morning as well. 

Still have lags with library filter, ESV bible scrolling and ESV read aloud to name a few. However, for me it does not seem any slower than it has been for 6.0a.

Startup to a layout with just the ESV bible open took over 1 minute as well when I issued the search below  the time for the suggestion pull down to appear was over 30 seconds (this was much faster as I remember, almost immediate). This was done on an 2.4Ghz i7 and windows 7. 

Posts 5270
Dan Francis | Forum Activity | Replied: Sat, Dec 20 2014 2:15 PM

Bob Soule:
I updated to L6 SR-4 this morning as well. 

Verbum 6.0a SR-5 was released a few days ago is that what you meant? I only ask because it seems odd Logos would not be updating to the latest version.

  -Dan

Posts 322
Bob Soule | Forum Activity | Replied: Sat, Dec 20 2014 3:29 PM

Dan Francis:

Bob Soule:
I updated to L6 SR-4 this morning as well. 

Verbum 6.0a SR-5 was released a few days ago is that what you meant? I only ask because it seems odd Logos would not be updating to the latest version.

  -Dan

Yes it was SR-5 not SR-4, my mistake. At any rate the latest still has many performance issues.

Posts 5270
Dan Francis | Forum Activity | Replied: Sat, Dec 20 2014 5:13 PM

I have no idea what is going on with 6. As I said above I was having no issues or speed issues on my macBook Pro... It is fully true it takes about 90 seconds to load completely for me but after that I have smooth sailing. I was a bit puzzled to see the complaint by the mac user and hope that tech support can help him ASAP. 

-Dan

Page 1 of 6 (107 items) 1 2 3 4 5 Next > ... Last » | RSS