L6 Notes Bugs (Minor) & Questions

Page 1 of 1 (20 items)
This post has 19 Replies | 1 Follower

Posts 215
Tim | Forum Activity | Posted: Wed, Dec 31 2014 8:55 AM

I was able to recently update to L6 on Mac and have noticed a couple things that seem quite minor but perhaps worth bringing up.

1. Three cursors: This is probably a feature and not a bug, but I have noticed three different cursors when using notes. One is offset slightly below the line of typing, is thin and the top of the cursor is an ascending line that resets with each blink. The second is what I would consider a standard cursor, and the third is the standard cursor but in a bold heavy line.  Can anybody tell me what the significance is for the three so I can understand what information they are relaying?

2. Bug: on a note that has enough data to require scroll bar inside the note, often when typing the text of the last word gets hidden behind that scroll bar. If the word becomes long enough to wrap then there is no problem, but I have had a few words get partially stuck behind the scroll bar. I could not exactly replicate that for this post, but here is a screen shot with the cursor behind the bar. I reduced the image down so you all do not have to put up with my insignificant comments on the holy scripture. you should be able to see the cursor behind the scroll bar after the word "with."

3. Bug: I would consider this one the most significant and cannot reproduce it on demand. Sometimes, after using [fn] + [delete] to delete highlighted text, when I start typing the replacement text, the new text will be inserted somewhere else within the same paragraph, but NOT where the cursor is blinking! Once this gets started I have had to remove a large block of text and start from a previous line to get rid of whatever formatting bug is happening otherwise it persists. 

Has anybody else seen these behaviors? 

Posts 215
Tim | Forum Activity | Replied: Wed, Dec 31 2014 8:57 AM

I forgot to include my specs sorry:

2011 27in  iMac

OS X 10.9.5

Logos 6.0a SR-5 (6.0.1.1352)

Posts 215
Tim | Forum Activity | Replied: Wed, Dec 31 2014 12:25 PM

I managed to get a screen shot of the scroll bar cutting off part of a word and thought I would add improved evidence to what I posted previously:

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Wed, Dec 31 2014 3:24 PM

Tim, I'm unable to reproduce these issues. Sad Do you find you experience this specifically with one font, or text size? Or perhaps on sections of text that have been pasted in, or created automatically from resources vs. completely hand-typed?

Just trying to hone in on some variables that will help to reproduce the problem.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 81
Doug Hanna | Forum Activity | Replied: Thu, Jan 1 2015 8:30 PM

Tim:

I was able to recently update to L6 on Mac and have noticed a couple things that seem quite minor but perhaps worth bringing up.

2. Bug: on a note that has enough data to require scroll bar inside the note, often when typing the text of the last word gets hidden behind that scroll bar. If the word becomes long enough to wrap then there is no problem, but I have had a few words get partially stuck behind the scroll bar. I could not exactly replicate that for this post, but here is a screen shot with the cursor behind the bar. I reduced the image down so you all do not have to put up with my insignificant comments on the holy scripture. you should be able to see the cursor behind the scroll bar after the word "with."

3. Bug: I would consider this one the most significant and cannot reproduce it on demand. Sometimes, after using [fn] + [delete] to delete highlighted text, when I start typing the replacement text, the new text will be inserted somewhere else within the same paragraph, but NOT where the cursor is blinking! Once this gets started I have had to remove a large block of text and start from a previous line to get rid of whatever formatting bug is happening otherwise it persists. 

Has anybody else seen these behaviors? 

I use notes extensively, I've seen #2 and 3 often since upgrading to Logos 6.

I have a bigger concern though. When working with a longer note, I've noticed a very serious typing lag. (i.e. when I type a letter it takes several seconds for it to appear in the note.)

MacBook Pro Mid-2012

OSX 10.10.1

8 GB RAM

Logos Bible Software 6.0a SR-5

6.0.1.1352

Posts 215
Tim | Forum Activity | Replied: Wed, Jan 7 2015 10:53 AM

@Dylan - I use Gentium 12 for my font. I do paste in a section as I start the note, the same section into every note (just a basic "to do" list as I work through my own process of hermeneutics), but even that is something that I have typed up and tried retyping, with no noticeable difference. I also paste in the text from the USB4 & NASB95 into the note. That ends up being reformatted because for some reason the copy <verse reference> always pastes in Hevetica 9 and as I noted previously, I prefer Gentium 12. Most of what I do is simply typed by me.

@Doug - I am glad to hear that it isn't just me having these issues. I don't experience typing lag per se, but have noticed that my typing is significantly worse in Logos than Word, or other word processing apps. Notes simply drops letters. I am not the greatest typist of all time, but my ratio of corrections has gone way up since I upgraded. Rightly or wrongly I have attributed this to the much higher processor usage in L6, which I haven't found a satisfactory answer for yet. L5 usually used 20%-30% of my processor where now L6 is very consistently running 68%-80%. I need to try rebuilding my layout. Maybe that will help.  

Posts 81
Doug Hanna | Forum Activity | Replied: Wed, Jan 7 2015 6:17 PM

Dylan Rondeau:

Tim, I'm unable to reproduce these issues. Sad Do you find you experience this specifically with one font, or text size? Or perhaps on sections of text that have been pasted in, or created automatically from resources vs. completely hand-typed?

Just trying to hone in on some variables that will help to reproduce the problem.

Keep in mind - in order to reproduce the type covered by the scroll bar, you have to be using bullet points.

Posts 215
Tim | Forum Activity | Replied: Wed, Jan 14 2015 12:27 PM

Actually I have it happen even when not using bullets. here is a clip that was taken from a non-bulleted section.

Posts 215
Tim | Forum Activity | Replied: Thu, Jan 22 2015 12:44 PM

i'm pretty sure this has gotten lost and is already forgotten, but I have more details on what seems to be happening particularly on the curser/typing location mismatch. 

This always seems to happen at the beginning of a line after a hard return or highlighting text and typing over. The typing starts to insert either at the end of the line, or at the beginning of a paste/hyperlink section, despite the cursor blinking where it is inserted. 

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Thu, Jan 22 2015 1:44 PM

Tim:

i'm pretty sure this has gotten lost and is already forgotten, but I have more details on what seems to be happening particularly on the curser/typing location mismatch. 

This always seems to happen at the beginning of a line after a hard return or highlighting text and typing over. The typing starts to insert either at the end of the line, or at the beginning of a paste/hyperlink section, despite the cursor blinking where it is inserted. 

Sorry Tim for the delay on this. We have a list of cases we're getting to and I just got back to this one. A couple things:

1. Are you still experiencing all this behavior in 6.0b SR-1? Just curious if that fixed any problems for you.

2. I'm still unable to reproduce the text being overlapped by the scrollbar. Sad If you have a reproducible scenario, I'd appreciate specific steps and/or a screencast of the behavior (http://www.techsmith.com/download/jing/ is a good, free screencast app)

3. For the typing starting in a different location than the cursor, does that sound like https://community.logos.com/forums/t/99003.aspx ? If so, that issue has been addressed in the most recent Beta build, and will be fixed once the build is considered stable enough for general users.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 215
Tim | Forum Activity | Replied: Thu, Jan 22 2015 2:41 PM

Dylan, thank you for the quick response! I know you all have a lot on your plate (and I added more elsewhere!). I have upgraded to 6.0b SR-1. 

1. I have not noticed the three cursor issue recently, or at least not paid attention. I will keep watch for it.

2. I have the text overlap happen a lot, perhaps even more now, although that may simply be a perception thing. unfortunately I cannot account for exactly how it happens. Here is what I do consistently though:

  • I highlight text (verse or multiple verses) in the NASB95 &/or UBS4 bibles using r-click --> copy <ref>  and paste that into a note.
  • I select all ( [cmd]+ A) and reformat the font from Helvetica 9 (can anybody tell me where to change that default?) to Gentium 12. (I have set the Default notes font to Gentium, but this method never pastes in as Gentium) 
  • I italicize the biblical text to make it easily recognizable from my own mental meanderings. 
  • I then use hard line breaks [enter] to create space between verses or logical stopping points.
  • I leave one hard line break after the verse and then undo the italics and start typing. This is where I start seeing this issue of the scrollbar overlap problem. the screenshot I pasted before was done with the standard mac function and then edited in preview so you only see the relevant section. 

3. that problem does look like the issue I am dealing with, although I do have it happen also with hard line breaks as well. Hopefully the fix will take care of all instances whether number/bullet or otherwise. 

Thanks again for the response!

Posts 215
Tim | Forum Activity | Replied: Thu, Jan 22 2015 2:55 PM

I forgot to mention, and this is definitely relevant: I use three monitors, with a single monitor dedicated to typing in notes. Each time I open my notes or my layout which includes my notes, I have to move the vertical divider between the left column of note references/titles and the text box on the right. When I open it does not remember where I placed it previously and ends up bisecting my screen into two exact halves, wasting a lot of space on the left. 

Posts 215
Tim | Forum Activity | Replied: Thu, Jan 22 2015 4:01 PM

I thought I would post another screen shot because you can clearly see the cursor behind the scroll bar. It seems almost as if the right limit of the text box is set before the scroll bar appears and when the note becomes long enough that scrolling starts that right limit is never updated to the new dimensions once the scroll bar is in place.  

Just a guess from a non-developer. :-)

Posts 1258
LogosEmployee
Dylan Rondeau | Forum Activity | Replied: Thu, Jan 22 2015 4:12 PM

Tim:
2. I have the text overlap happen a lot, perhaps even more now, although that may simply be a perception thing. unfortunately I cannot account for exactly how it happens. Here is what I do consistently though:

Thanks for the extra info! I can reproduce it, though I wasn't able to before - I forgot to ask, but you left out one crucial bit of information! You view your notes in Split view. I didn't realize it until you mentioned the divider between the notes and the text entry. This is why full, non-or-minimally-cropped screenshots are helpful. Smile Sorry, just had to make that point!

I've created a case for our devs to investigate, thanks for your patience and assistance.

Dylan Rondeau, Software Tester

Enable Logging: Mac | Windows (Right-click "Save As...")

Posts 215
Tim | Forum Activity | Replied: Fri, Jan 23 2015 9:14 AM

Hooray for success in reproducing this bug! Thank you for taking the time to respond and follow this through. I look forward to seeing the update in the fullness of developmental time. :-D 

Posts 215
Tim | Forum Activity | Replied: Fri, Jan 23 2015 1:41 PM

Dylan, I don't suppose while you were reproducing my issue you happened to notice a problem with text input into notes being slow. Mine is always so slow that I can type a sentence and then sit back and watch it complete the final several words. I assure you I don't type all that fast either!

I imagine this is the typing lag that Doug mentioned in his post previously. 

Posts 3148
LogosEmployee
Thomas Ball | Forum Activity | Replied: Fri, Jan 23 2015 2:14 PM

Tim:

Dylan, I don't suppose while you were reproducing my issue you happened to notice a problem with text input into notes being slow. Mine is always so slow that I can type a sentence and then sit back and watch it complete the final several words. I assure you I don't type all that fast either!

I imagine this is the typing lag that Doug mentioned in his post previously. 

I would verify that you have the newest version of your graphics driver by going to DxDiag (http://windows.microsoft.com/en-us/windows-vista/run-directx-diagnostic-tool). Check the date on the Display tab for when the driver was updated, and search the internet for graphics card name and driver. You should be able to find a page that either has what the latest driver is, or a method of checking. 

You may also want to troubleshoot font cache: https://www.logos.com/support/logos5/windows/font-cache

 

Posts 215
Tim | Forum Activity | Replied: Fri, Jan 23 2015 2:18 PM

Tommy, you may have missed my machine stats above. I am running Mac OS 10.9. In fact you helped me over the phone and team viewer this week on a different but perhaps related issue regarding processor usage and notes. :-) 

I don't know if there is a comparable font cache problem with Mac but will try to research it more. Thanks!

Posts 215
Tim | Forum Activity | Replied: Fri, Jan 23 2015 2:40 PM

I did a quick check, and it looks like this may be a matter of me using notes to an extent it has not been designed for. the note that I am working on is the equivalent of 29 pages in a word doc, complete with LOTS of bulleted notes. I created a quick new note and started typing in with no lag whatsoever. I grabbed some random text from another note and pasted it in enough times to have somewhat comparable length and sure enough I started getting lag. 

I am not sure what causes the lag, but I will keep in mind that I need to keep the notes a bit shorter per note/more notes in the note file. 

Posts 215
Tim | Forum Activity | Replied: Wed, Feb 4 2015 2:07 PM

Dylan, I emailed a short recording of the behavior of problem #3 to Tommy Ball (because I have his email address and I don't have yours) that shows the problem happening. Once it occurs it is repeatable until I go back and delete the characters around the insertion point. Although the recording has this happen on a bulleted point, the problem also occurs on non-bulleted text. Sometimes the typing point (circled in the video, as opposed to where the cursor is) will be at the  beginning of a hyperlink, at other times it is simply a random insertion, including the first space of the next line down. Please let me know if there is anything else I can do to help troubleshoot or demonstrate the problem. 

Page 1 of 1 (20 items) | RSS