[resolved] BUG in RC1: Yellow triangle never goes away

Page 1 of 1 (12 items)
This post has 11 Replies | 1 Follower

Posts 2829
Don Awalt | Forum Activity | Posted: Tue, May 12 2015 8:19 AM

I don't know if my comment got lost in the "RC 1 available" thread, so I am posting here. Is this normal behavior?

I just did the update from 6.2 SR-1 to 6.3 RC-1 (Windows 7 x64 Verbum). Some weird things happened:

1. I did not get any type of notification that the software had been updated to 6.3

2. I saw a yellow triangle at the top right corner, but hovering over it did not produce any tool tip until about 3-4 minutes later. It did update one resource, Grammar Cross References Database, might it have been a lower priority to display the tool tip behind indexing?

3. Once that all settled down, it said "Resources are ready to be added to your library". I should not have any, as I checked this morning before I updated, but assuming it was some update that came with the 6.3 . When I click on the yellow triangle, it says that plus "Updates will be added when the application is restarted". Does this mean a software update, or is it a generic message meaning updates and/or resources? That's unclear if it is. Anyway - so I restarted. Nothing came in, and the triangle again says "Resources are ready to be added to your library". My install comes up default to the Home Page if that matters.

4. So I restarted again (third time now), and it still says the same when I click - "Resources are ready to be added to your library" and "Updates will be added when the application is restarted". So the yellow triangle appears to be stuck on. Indexing is not running, system appears quiet.

5. Note this last time, there was no indexing initiated when it started running, I counted (on a fast laptop) and it was 10 seconds before either hovering over the triangle, or clicking on it, would show any message. As this looks like a warning and is a current state, shouldn't this have a higher priority to ensure it displays as soon as a user sees it?

Note - I saw this in the beta forum, but just to report it - I too had to close Chrome in order to do the update.

==============

To add a second use case that I don't think worked as planned:

I changed by Master Theological Journal Bundle to be ship as available, so  had ultimately 40 journals that downloaded and indexed. The yellow triangle went thru

Resources are ready to be added to your library

Preparing Libary

then to 

Resources are ready to be added to your library

Your Library is indexing (0%)  - which then progressed

then it went to 

Resources are ready to be added to your library

Updates will be added when the application is restarted

so I restarted and now have a yellow triangle with

Resources are ready to be added to your library

I am thinking the yellow triangle will never go away, and it will always say Resources are ready to be added to your library?

Posts 2359
LogosEmployee

Don, can you post your log files?

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, May 12 2015 8:57 AM

Here ya go - I exited Verbum, cleared log file so it was clean, started Verbum, determined the yellow triangle was still up, and then closed Verbum. I think I have the old log files if you want them (they are big) or if you want me to try some other test...

3731.Verbum.log

Posts 2359
LogosEmployee

Can you exit the application, then create a backup copy of C:\Users\AWALT\AppData\Local\Verbum\Data\aqcxsize.v43\UpdateManager\Updates.db Then delete that file and restart the application. Post the resulting log file.

Depending on what happens with that, I may want to see a copy of the old and new Updates.db file.

It looks like the problem is with two of the Tabletalk magazine resources. The application is trying to update to a newer version but with an old file format. I'm not sure yet if this is a problem on our servers or residual effects from some past problem. Thanks for the help in tracking this down.

Posts 2359
LogosEmployee

Ignore my previous instructions. I've been able to recreate the problem here. Deleting the Updates.db file will not clear up the problem. We're working on getting a fix for this. For now you'll need to just ignore the restart notification.

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, May 12 2015 10:50 AM

Sorry just got back to my computer, glad you made some progress identifying it. Let me know if you need anything!

Posts 2359
LogosEmployee

This is a potential problem for four of the resources in our system. You happened to hit it with two of those four resources. A fix for this problem should go out in our next round of resource updates, which should be next week.

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, May 12 2015 3:27 PM

Thanks Andrew! If it goes away I'll let you know, or if you post here that the updates have gone out then I'll verify it for you on my end.

Posts 26020
Forum MVP
Dave Hooton | Forum Activity | Replied: Tue, May 12 2015 4:30 PM

Don Awalt:
I don't know if my comment got lost in the "RC 1 available" thread, so I am posting here. Is this normal behavior?

It's always better to raise issues in a thread of your own, and a bad idea to raise issues in an FL "Release" threadSmile!

I appreciate you starting this thread.

Dave
===

Windows 10 & Android 8

Posts 26020
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, May 24 2015 6:46 AM

Andrew Batishko (Faithlife):

This is a potential problem for four of the resources in our system. You happened to hit it with two of those four resources. A fix for this problem should go out in our next round of resource updates, which should be next week.

Have the resoures been released, fixing the problem?

Dave
===

Windows 10 & Android 8

Posts 2359
LogosEmployee

Dave Hooton:

Have the resoures been released, fixing the problem?

It looks like something went wrong with the publishing of these resources last week, but we just got the correct versions published. I was able to verify with my recreation that the problem has been cleared up.

Posts 2829
Don Awalt | Forum Activity | Replied: Tue, May 26 2015 11:31 AM

The resources to be added message went away for me! Thanks Andrew!

Page 1 of 1 (12 items) | RSS