logos 4 not starting

Page 1 of 2 (27 items) 1 2 Next >
This post has 26 Replies | 3 Followers

Posts 10
Paul Williamson | Forum Activity | Posted: Fri, Feb 5 2010 5:23 PM

for the last two days logos 4 has crashed whiled booting up  i followed directions and sent text file yesterday--haven't heard anything yet. program has run perfectly since i received and installed some tme ago-- i have tried loading on line and off line   any suggestions

Posts 5337
Kevin Becker | Forum Activity | Replied: Fri, Feb 5 2010 6:16 PM

hold ctrl as you are starting up, keep holding it, when the login screen shows check "Load Blank page at startup" and then click login. Often if Logos wont start it's because of a corrupt layout or homepage. Opening to a blank layout sidesteps these problems. If this doesn't work go ahead and upload the logs to the forum, someone might be able to help before tech support gets back to you.

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 6:37 PM

thank kevin-- i did as you suggested and as soon as i got the blank page up crashed-- here is the log

 

Paul

Posts 5337
Kevin Becker | Forum Activity | Replied: Fri, Feb 5 2010 6:41 PM

Well, I've never seen this one before

2010-02-05 20:12:29.4040    10    Error    OurApp    Unhandled exception: System.ExecutionEngineException: Unable to retrieve security descriptor for this frame.
   at System.Security.CodeAccessSecurityEngine.Assert(CodeAccessPermission cap, StackCrawlMark& stackMark)
   at System.Security.CodeAccessPermission.Assert()
   at System.Reflection.Assembly.EnumerateCache(AssemblyName partialName)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()

The weird thing is that this error is 5 seconds before the log cuts off

Anybody else seen this one before?

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 6:57 PM

That's one for the developer's!  I haven't seen that error before.

The only thing I can suggest is to rename layouts.db in C:\Users\paulwilliamson\AppData\Local\Logos4\Documents\nu0okx3t.wft\LayoutManager & start L4.

 

EDIT:  LOL  I just saw your comment Kevin!!

Dave
===

Windows 10 & Android 8

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 7:06 PM

Kevin Becker:
The weird thing is that this error is 5 seconds before the log cuts off

It carried on with the normal initialisation of bible data types before screeching to a halt.

Dave
===

Windows 10 & Android 8

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 7:06 PM

 

 

 

 

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 7:07 PM

I may not have follew your instructinss correctly but here is what i got

 

2010-02-05 22:02:39.0530 7 Error ResourceRichTextUtility Couldn't load color_green.jpg from LLS:RCL: No imaging component suitable to complete this operation was found.
2010-02-05 22:02:39.1350 7 Error OurApp Unhandled exception: System.IndexOutOfRangeException: Index was outside the bounds of the array.
   at LDLS4.HomePage.LectionaryToolViewModel.<UpdateToolWork>d__0.MoveNext()
   at Libronix.Utility.Threading.AsyncWorkerTask`1.EnumMoveNext()
   at Libronix.Utility.Threading.AsyncWorkerTask`1.ContinueExecution()
   at Libronix.Utility.Threading.AsyncAction.Continue()
   at Libronix.Utility.Threading.ThreadPoolAsyncAction.<Start>b__0(Object )
   at Libronix.Utility.Threading.GroupedThreadPool.ExecuteNextCallback(Object state)
   at System.Threading._ThreadPoolWaitCallback.WaitCallback_Context(Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallbackInternal(_ThreadPoolWaitCallback tpWaitCallBack)
   at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback(Object state)
2010-02-05 22:02:39.3000 9 Error ResourceRichTextUtility Couldn't load color_green.jpg from LLS:RCL: No imaging component suitable to complete this operation was found.
2010-02-05 22:02:39.6130 1 Info IsWorkingControl Hiding IsWorkingControl (name PreferredBibleToolWorking id 63183526)
2010-02-05 22:02:39.6360 9 Info HomePage.HomePageViewModel Committing content preferences.
2010-02-05 22:02:39.7980 9 Info HomePage.HomePageViewModel Creating home page cache C:\Users\paulwilliamson\AppData\Local\Logos4\Data\nu0okx3t.wft\HomePage\2010-02-05
2010-02-05 22:02:39.8070 9 Info HomePage.HomePageViewModel (Timed) Getting today's references
2010-02-05 22:02:40.4410 9 Info DataTypeManager Creating data type bible+elber (Libronix.DataTypes.Bible.BibleDataType).
2010-02-05 22:02:40.4410 9 Info StandardDataType (Timed) Initializing data type bible+elber.

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 7:14 PM

Paul  Exactly what did you do?

PS. delete your first response  as I'm replying to your second one. On the RHS press the More button, then Delete.

Dave
===

Windows 10 & Android 8

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 7:19 PM

i followed the path you suggested and renamed the file to layouts1  I have since gone back and renamed it layouts

 

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 7:24 PM

OK, let's try deleting the Home Pages.

Delete everything in the folder C:\Users\paulwilliamson\AppData\Local\Logos4\Data\nu0okx3t.wft\HomePage.

Also rename the layouts.db to something more agrressive like  xxxxlayouts.db

Dave
===

Windows 10 & Android 8

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 7:38 PM

here it is

-02-05 22:33:40.0910 5 Info StandardDataType (0ms) Initializing data type twot.
2010-02-05 22:33:40.0910 5 Info DataTypeManager Creating data type vp (Libronix.DataTypes.Specific.VolumePageDataType).
2010-02-05 22:33:40.1060 5 Info StandardDataType (Timed) Initializing data type vp.
2010-02-05 22:33:40.1060 5 Info StandardDataType (0ms) Initializing data type vp.
2010-02-05 22:33:40.1060 5 Info DataTypeManager Creating data type wn (Libronix.DataTypes.StringDataType).
2010-02-05 22:33:40.1060 5 Info StandardDataType (Timed) Initializing data type wn.
2010-02-05 22:33:40.1060 5 Info StandardDataType (0ms) Initializing data type wn.
2010-02-05 22:33:40.1060 5 Info DataTypeManager Creating data type ymd (Libronix.DataTypes.Specific.YearMonthDayDataType).
2010-02-05 22:33:40.1060 10 Error OurApp Unhandled exception: System.ExecutionEngineException: Unable to retrieve security descriptor for this frame.
   at System.Security.CodeAccessSecurityEngine.Assert(CodeAccessPermission cap, StackCrawlMark& stackMark)
   at System.Security.CodeAccessPermission.Assert()
   at System.Reflection.Assembly.EnumerateCache(AssemblyName partialName)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
2010-02-05 22:33:40.1060 5 Info StandardDataType (Timed) Initializing data type ymd.

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 7:48 PM

Paul

I'd like to see the log file (pls delete the extraneous length of your previous message) and explain what you did to get the error eg. did you delete HomePage contents and rename layouts.db? If you started normally then try with the Ctrl key and a Blank Layout.

 

Dave
===

Windows 10 & Android 8

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 7:53 PM

Yes i renamed the layouts to xxxlayouts and deleted the HomePage contents  this is with Ctrl key and Blank Layout--- sorry for the excess --didn't know if it helped   

Thanks

 

 

2010-02-05 22:50:53.6150 10 Error OurApp Unhandled exception: System.ExecutionEngineException: Unable to retrieve security descriptor for this frame.
   at System.Security.CodeAccessSecurityEngine.Assert(CodeAccessPermission cap, StackCrawlMark& stackMark)
   at System.Security.CodeAccessPermission.Assert()
   at System.Reflection.Assembly.EnumerateCache(AssemblyName partialName)
   at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
   at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
   at System.Threading.ThreadHelper.ThreadStart()
2010-02-05 22:50:53.7840 11 Info StandardDataType (935ms) Initializing data type bible.
2010-02-05 22:50:53.7840 11 Info DataTypeManager Creating data type bible+dr (Libronix.DataTypes.Bible.BibleDataType).
2010-02-05 22:50:53.7840 11 Info StandardDataType (Timed) Initializing data type bible+dr.

Posts 25825
Forum MVP
Dave Hooton | Forum Activity | Replied: Fri, Feb 5 2010 8:25 PM

I'm stumped! When asked, though, please upload the log file. I can only suggest that you re-install:-

First, save your Resources folder so that we can scan its contents later and save all the downloading.

Uninstall L4 from the Control Panel and delete the Logos4 folder.

Install with Method 3 at http://wiki.logos.com/Quick_Installation_onto_multiple_computers

Dave
===

Windows 10 & Android 8

Posts 10
Paul Williamson | Forum Activity | Replied: Fri, Feb 5 2010 8:40 PM

Dave

thank you for your time. I will remember your suggestion about uploading the log file.

I have rebooted and carefully redone your suggestions and currently logos 4 is up and working from blank page. I have not recoverd my layouts but I appreciate your patience and help

 

thanks again

 

paul

Posts 15805
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Fri, Feb 5 2010 11:31 PM

Looking at uploaded log file - noted early in log file LogInPrompt and PasswordBox - missing status IsLoggedIn - wonder about logos.com login id and password ?

Also noticed lack of messages to sync stuff - upload and download.

Keep Smiling Smile

Posts 17
Mark E Schaaf | Forum Activity | Replied: Fri, Jun 17 2011 12:45 PM

Kevin:

I have the same problem - Logos4 crashes on startup.  I did the crtl key step you mentioned and that did allow Logos4 to start to a blank page.  I successfully loaded the layout I wanted to use - but then clicked on the Home icon and it crashed.  So - I know how to start up, but how do I uncorrupt the Home page?

 

Thanks

Posts 1
Jerry Barron | Forum Activity | Replied: Fri, Jun 17 2011 1:16 PM

I attempted the ctrl key step just as Mark did with the same results - crash/close when I click on the Home icon.   Any solution to this problem yet?

 

Thanks,

Jerry

Posts 10769
Forum MVP
NB.Mick | Forum Activity | Replied: Fri, Jun 17 2011 1:23 PM

Welcome to the forum, Jerry

Jerry Barron:

crash/close when I click on the Home icon.   Any solution to this problem yet?

You'll help those trying to help you, if you post the crash-log file that Logos produces automatically in this situation. See http://wiki.logos.com/Diagnostic_Logging for further instructions. The more info you give, the better and faster you may receive a solution in the forum. Or call tech support, they will log on to your system and try to solve this interactively.

Hope this helps,

Mick

 

Running Logos 8 latest beta version on Win 10

Page 1 of 2 (27 items) 1 2 Next > | RSS