Program Opening Time

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 2
David Blystone | Forum Activity | Posted: Thu, Feb 18 2016 9:52 AM

I am wondering what a 'normal' amount of time is for Logos 6 to open in either Windows 7 or Windows 10. I am using both, and the time between when I click on the icon and when the program actually opens and is usable is never less than a minute. Is this normal? I use a lot of other programs and everything else opens in less than 2 seconds. Is there some setting I should check?

Posts 25342
Forum MVP
Graham Criddle | Forum Activity | Replied: Thu, Feb 18 2016 9:58 AM

Hi David - and welcome to the forums

David Blystone:
I am wondering what a 'normal' amount of time is for Logos 6 to open in either Windows 7 or Windows 10. I am using both, and the time between when I click on the icon and when the program actually opens and is usable is never less than a minute. Is this normal?

Time taken does vary

I've just tried it and it took around 12 seconds.

What is the specification of your system? In particular how much memory do you have and what type of hard disk (rotation time)?

Graham

Posts 239
Mikko Paavola | Forum Activity | Replied: Thu, Feb 18 2016 10:04 AM

It depends on your computer specs, especially the hard drive and RAM.

If you have a slow computer you can make the startup a bit faster by changing these settings (Tools -> Program Settings):
- At startup open to : Blank layout
- Automatically download updates: No

Faithlife Connect + several Base Packages + Luther's Works, etc.
Lenovo ThinkPad Yoga 260, Win 10 Pro, Intel Core i7-6500U, 16GB RAM, 256GB SSD, Intel HD Graphics 520.
iPhone 7 Plus.

Posts 2
David Blystone | Forum Activity | Replied: Thu, Feb 18 2016 12:12 PM

The two systems I use are different, but the results are about the same. One has 4 gig of RAM while the other has 12 gig. The hard drives are both 7200 rpm SATA-III with more than 50% of the storage space available.

The first starting of Logos after a reboot is the long one. Subsequent starts are between 12-15 seconds. Changing the layout at startup seems to have no impact. Automatically downloading updates has always been turned off for me.

It may just be what I need to live with, but it is very aggravating. Far too often, I forget what I was going to look for by the time the Logos opens. :) 

Page 1 of 1 (4 items) | RSS