Page 1 of 2 (29 items) 1 2 Next >
This post has 28 Replies | 0 Followers

Posts 43
Steve Owings | Forum Activity | Posted: Sat, Apr 23 2016 9:49 PM

i have the 9.7 iPad Pro and after the last update I can no longer view my books off line. Yes they are downloaded an show as such but when I turn off the internet I can not change the page on any downloaded book. Like i said above this issue began with the last update Version 5.2.2 April 21st 2016

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Sat, Apr 23 2016 11:16 PM

Did you perform an iTunes backup/restore from a previous iOS device to your new iPad Pro?

Posts 43
Steve Owings | Forum Activity | Replied: Sun, Apr 24 2016 3:54 AM

Yes but it worked after that it stopped after the last update

Posts 43
Steve Owings | Forum Activity | Replied: Sun, Apr 24 2016 6:42 AM

I did delete and reload all three Vyroso, Logos, and Faithlife all three quit working off line with the new update then they worked but that is a pain

Posts 638
Into Grace | Forum Activity | Replied: Sun, Apr 24 2016 11:44 AM

Hi Steve.

So is your issue resolved? I also have the IPad pro. I had problems but a clean install resolved everything. The latest update has been stable.

Posts 43
Steve Owings | Forum Activity | Replied: Sun, Apr 24 2016 10:24 PM

Yes the clean my not all solved the issue it was just a pain as when I needed it it stopped working!

Posts 69
JeremyS | Forum Activity | Replied: Mon, Apr 25 2016 1:45 AM

i've got the same issue. was overseas over the weekend and suddenly my FSB app would not load any passage from my downloaded bibles on my iphone 6s+. my ipad FSB was fine however.. totally annoying when you need it to work.

are you saying the official solution is to wipe everything off my device and set it up from scratch as a new device instead of restoring an itunes backup?

Posts 43
Steve Owings | Forum Activity | Replied: Mon, Apr 25 2016 4:49 AM

I am saying that I had to do that to make it work again. Though I am not official but a realist.

Posts 27275
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 25 2016 5:01 AM

JeremyS:
are you saying the official solution is to wipe everything off my device and set it up from scratch as a new device instead of restoring an itunes backup?

Only  a FL employee can proclaim an "official" solution, but Kevin did not do that.

For clarification: Are you suggesting that you wipe your device? Before I would do that, I would simply delete the app and reinstall. Seems a simpler solution to try at first. Wink

OSX & iOS | Logs |  Install

Posts 43
Steve Owings | Forum Activity | Replied: Mon, Apr 25 2016 7:02 AM

That is what I'd did delete and reinstall all FL apps and then download resources again. 

Pas I stated above not official but it was the only solution that worked.

Posts 27275
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 25 2016 8:05 AM

Steve - 

I wasn't responding to you, just clarifying for another forum member. 

OSX & iOS | Logs |  Install

Posts 69
JeremyS | Forum Activity | Replied: Mon, Apr 25 2016 8:39 AM

as stated above, deleting/reinstalling the app didn't work.. i'll try that first but since the only official response is "did you restore from an itunes backup" it sounds like maybe FL already knows this is a problem?

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Mon, Apr 25 2016 10:27 AM

Previously downloaded Faithlife resources are not restored from iTunes after updating to a new device; they need to be downloaded again.

Posts 43
Steve Owings | Forum Activity | Replied: Mon, Apr 25 2016 11:23 AM

No problem

Posts 69
JeremyS | Forum Activity | Replied: Mon, Apr 25 2016 7:56 PM

thanks kevin. the app seems to think that they are still downloaded though. there's no "download" button when you click on the resource. is there a way to fix that in a future build?

Posts 27275
Forum MVP
JT (alabama24) | Forum Activity | Replied: Mon, Apr 25 2016 8:13 PM

JeremyS:
there's no "download" button when you click on the resource.

There should be a "remove" button in the "info" panel. Clicking on that should bring back the download button.

OSX & iOS | Logs |  Install

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Mon, Apr 25 2016 9:12 PM

JeremyS:

i've got the same issue. was overseas over the weekend and suddenly my FSB app would not load any passage from my downloaded bibles on my iphone 6s+. my ipad FSB was fine however.. totally annoying when you need it to work.

are you saying the official solution is to wipe everything off my device and set it up from scratch as a new device instead of restoring an itunes backup?

Did you backup/restore our app(s) to you iPhone 6S+ but not to your iPad?  I need more information before I can offer a possible answer.  In any case, a complete device wipe should not be required unless you've been playing around with iOS beta versions (which we don't support).

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Mon, Apr 25 2016 9:14 PM

JeremyS:

thanks kevin. the app seems to think that they are still downloaded though. there's no "download" button when you click on the resource. is there a way to fix that in a future build?

In the Library, are the circular resource "i" icons "empty" with a white background or filled with a solid color (blue for the Bible app, green for the FSB app, etc.)?

Posts 1881
Donnie Hale | Forum Activity | Replied: Tue, Apr 26 2016 5:29 AM

Kevin,

I can add that I have seen similar behavior. I upgraded to the iPad Pro 9.7 right when it came out. I did a backup and restore from my iPad Air 2. The Bible! app installed no problem, and I noticed that the network spinner (upper left) ran for a very long time when I was in the app. I don't know how long it ran in total, but in the neighborhood of at least an hour. I assume it was downloading the books I had downloaded on my previous iPad.

At one point, I was completely off-network and could not access my downloaded books. Basically wouldn't navigate at all. I have also noticed that these supposedly downloaded books don't behave right in other situations. Yesterday, off network, the app could not bring up the ToC for a downloaded book. The "info" icon made it clear it was downloaded. Touching a footnote has caused the app to spin for several seconds, apparently retrieving the footnote data over the network even though it's a downloaded book.

In every case, what has fixed the problem for the book I'm having an issue with at the moment is to "remove" the book, kill the app, and re-download the book after starting the app. At that point, footnotes work instantly, the ToC shows up as expected, etc.

So there's definitely something going on. But I can't tell whether it's more related to the latest version of the app, my migration to a new device, perhaps the new version of iOS, or the specific confluence of all of those.

Donnie

Posts 4264
LogosEmployee
Kevin Byford (Faithlife) | Forum Activity | Replied: Tue, Apr 26 2016 3:27 PM

Donnie Hale:
I can add that I have seen similar behavior. I upgraded to the iPad Pro 9.7 right when it came out. I did a backup and restore from my iPad Air 2. The Bible! app installed no problem, and I noticed that the network spinner (upper left) ran for a very long time when I was in the app. I don't know how long it ran in total, but in the neighborhood of at least an hour. I assume it was downloading the books I had downloaded on my previous iPad.

Yes, this is what should happen, but if you have many hundreds of books (or more) downloaded locally it might take hours or even days for them to complete downloading depending on network throughput.

Donnie Hale:
At one point, I was completely off-network and could not access my downloaded books. Basically wouldn't navigate at all. I have also noticed that these supposedly downloaded books don't behave right in other situations. Yesterday, off network, the app could not bring up the ToC for a downloaded book. The "info" icon made it clear it was downloaded. Touching a footnote has caused the app to spin for several seconds, apparently retrieving the footnote data over the network even though it's a downloaded book.

I haven't been able to reproduce this issue but I trust that it's there - I'll write up a case.  On the other hand, I'm curious whether or not this would have happened if all of the previously downloaded books had completed downloading since I'm not convinced that process succeeded.  The app should really be more indicative of background processes (there are already cases for this) instead of just using the spinning indicator.  I would ask for your device logs but we've already had that conversation; if we had them it might help us narrow things down.

Page 1 of 2 (29 items) 1 2 Next > | RSS