Compatibility Proclaim 2 with Proclaim 1.x

Page 1 of 1 (4 items)
This post has 3 Replies | 1 Follower

Posts 14
Bill Waller | Forum Activity | Posted: Fri, Dec 2 2016 7:28 AM

I am setting up service presentations remotely, and I have not upgraded to Proclaim 2 because I feared that my work might not be compatible with Proclaim 1 on the Sanctuary PC on Sunday morning.   (I am 1,000 miles away and cannot access Sanctuary PC to upgrade.)    If I upgrade, would my presentations be backward compatible with PC's running Proclaim 1.0?    What about presentations developed in Proclaim 1.0.x are they compatible with Proclaim 2.0?    Any things to be aware of when using different versions?

I bypassed the upgrade, but when I launched Proclaim today, it appears to be using the new user interface screen.    Menus and display changed?   Is this expected behavior?

Saw some posts regarding reliability problems...   Should we wait to upgrade until these are resolved?   I would not want someone to upgrade Sanctuary PC to 2.0 on Sunday morning and have Proclaim become unreliable.

   Thanks, Bill

Posts 3501
LogosEmployee
Scott Alexander | Forum Activity | Replied: Fri, Dec 2 2016 8:53 AM

Bill Waller:
I am setting up service presentations remotely, and I have not upgraded to Proclaim 2 because I feared that my work might not be compatible with Proclaim 1 on the Sanctuary PC on Sunday morning.   (I am 1,000 miles away and cannot access Sanctuary PC to upgrade.)

Presentations are compatible with all versions of Proclaim released after October 7. Only a handful of users were running older versions and we sent out emails notifying them that they would be required to update.

Bill Waller:
I bypassed the upgrade, but when I launched Proclaim today, it appears to be using the new user interface screen.    Menus and display changed?   Is this expected behavior?

Sounds like you're on version 2, but perhaps not the very latest update. You can see what's new in version 2 here. Our release notes are here and you can see what version you're currently running here.

Bill Waller:
Saw some posts regarding reliability problems...   Should we wait to upgrade until these are resolved?   I would not want someone to upgrade Sanctuary PC to 2.0 on Sunday morning and have Proclaim become unreliable.

There have been a few minor hiccups earlier this week but we feel confident that we have sorted them out (see release notes). I recommend updating to the most recent version.

Posts 14
Bill Waller | Forum Activity | Replied: Fri, Dec 2 2016 9:55 AM

Hmmm...   OK...   I did an about and it says that I am running 2.0.0.0017 which is up to date.    I thought that I had to explicitly update, and clicking skip would postpone the update.    Apparently, the update got pushed automatically when I was setting up services yesterday?

I did skip yesterday, and the setup of services was done with the Proclaim 1.0 interface.    When I launched today to do some updates, the splash screen for startup was a different format, and the screen format was different.   I checked my Install directory and there was a 106MB msi file dated yesterday.  

I don't recall seeing an "updating" message.  

I like the new interface, and hopefully all will be well back at the church.

Thanks for your  prompt response.

When does Proclaim update automatically versus requiring the end user to accept the update?

  Bill

Posts 3501
LogosEmployee
Scott Alexander | Forum Activity | Replied: Fri, Dec 2 2016 11:24 AM

Proclaim on Windows will update in the background and you won't notice until the next time you start the application. We still prompt at startup if an update is available in order to provide the opportunity to force the update immediately. 

Page 1 of 1 (4 items) | RSS