Please Help: Logos 7 SO SLOW!

Page 1 of 3 (51 items) 1 2 3 Next >
This post has 50 Replies | 4 Followers

Posts 809
Cynthia in Florida | Forum Activity | Posted: Sun, Jan 22 2017 7:06 AM

I'm not too sure if it's on my end, but my Logos 7 software seems to be getting slower and slower.  Opening up takes forever, switching from home screen to work screen takes forever, (often times it's just a white screen on the home screen until I shut out and go back in), opening up course takes FOREVER...

Are there some things I should look for that might be slowing it down?

1)  My internet is wicked fast

2) I'm on a Mac book Pro MacOS Sierra 10.12.2

3)  I have Logos Bible Software 7.3 SR-2 7.3.0.0047, and Logos Now

4)  I've tried closing all other programs

Not sure what other info you need, but this is really getting worse and has become quite frustrating. 

Cynthia

Romans 8:28-38

Posts 10178
Denise | Forum Activity | Replied: Sun, Jan 22 2017 7:45 AM

I kept my trap shut on this issue, for fear folks might guess I'm not real thrilled with the Bellingham team at the moment.

I usually read on Libby, and switch to Logos for questions. But the Logos7 Bibles are so slow, I've been using Laridian for Bibles. That's pretty bad, no offense to Laridian.

I'm on W7, offline, latest update and the usual SSD drive etc. It's worse than L4 (historically called 'the Molassas edition').


Posts 144
LogosEmployee
Christian Villapando | Forum Activity | Replied: Sun, Jan 22 2017 7:51 AM

Hello Cynthia!

I apologize for the trouble experienced with Logos 7 lately. Would it be possible for you to post diagnostic logs? I can check the logs to see if there's something on the back-end causing trouble. 

For information on how to obtain logs, please check out this article: https://www.logos.com/support/mac/report-problem 

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 11:31 AM

Christian Villapando:

Hello Cynthia!

I apologize for the trouble experienced with Logos 7 lately. Would it be possible for you to post diagnostic logs? I can check the logs to see if there's something on the back-end causing trouble. 

For information on how to obtain logs, please check out this article: https://www.logos.com/support/mac/report-problem 

Hello Christian:  Give me a bit and let me see if I can get around to it today.

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 12:14 PM

I couldn't get my courses to open at all this time.

I have only posted logs a few times.  I'm not sure which one it is as it asked me twice to save the logs.  Does this work? 4314.LogosLogs.CynthiaFeenstra.20170122-144948.zip

1665.LogosLogs.CynthiaFeenstra.20170122-145011.zip

Cynthia

Romans 8:28-38

Posts 27681
Forum MVP
JT (alabama24) | Forum Activity | Replied: Sun, Jan 22 2017 1:17 PM

Cynthia - Someone much smarter than me is going to have to appropriately diagnose your logs... but some questions:

  • Have you tried restarting your computer?
  • Have you tried loading to a blank layout and building a new, simple one? If so, did you notice improvement?
  • Do you have a lot of searches going on? Are you doing technical, original language work? 
  • Are you doing something with photos/media?

I did notice that you have a LONG list of hidden resources, most of which appear to be perseus related. It would have been best to have FL lock those licenses on your account instead of hiding them. 

OSX & iOS | Logs |  Install

Posts 435
Adam Olean | Forum Activity | Replied: Sun, Jan 22 2017 2:24 PM

Hi Cynthia,

You can check out this thread along with my post for some ideas. Unfortunately, Logos 7 seems to waste a lot of unnecessary resources, but there are at least some things that can be done to help optimize performance. This has been discussed at various places on the forums.

Posts 435
Adam Olean | Forum Activity | Replied: Sun, Jan 22 2017 2:40 PM

Adam Olean:

Hi Cynthia,

You can check out this thread along with my post for some ideas. Unfortunately, Logos 7 seems to waste a lot of unnecessary resources, but there are at least some things that can be done to help optimize performance. This has been discussed at various places on the forums.

In addition to the ideas in that thread, you can also try toggling off any unnecessary Sidebars and Content in the homescreen to see if that improves things. You could even try initially toggling everything off and then adding things back as desired, balancing performance and functionality.

Posts 986
John Goodman | Forum Activity | Replied: Sun, Jan 22 2017 2:54 PM

I'm curious as to the difference between hiding resources and asking for the licenses to be revoked? Does hiding really affect performance? I have quite a lot of hidden resources but not all of perseus...

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 24930
Forum MVP
Dave Hooton | Forum Activity | Replied: Sun, Jan 22 2017 3:38 PM

John Goodman:
I'm curious as to the difference between hiding resources and asking for the licenses to be revoked? Does hiding really affect performance?

In both cases, the resource is removed from Library, collections, etc. and deleted from the resource folder. And if you reindex library it removes the resource's index entries. But you keep the license when you Hide resources.

Performance of drop downs, Context menu will improve if a large number of resources are removed, and reindexing will be faster e.g. for Perseus collection, multi-volume original bible texts.

Dave
===

Windows & Android

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 5:19 PM

alabama24:

Cynthia - Someone much smarter than me is going to have to appropriately diagnose your logs... but some questions:

  • Have you tried restarting your computer?
  • Have you tried loading to a blank layout and building a new, simple one? If so, did you notice improvement?
  • Do you have a lot of searches going on? Are you doing technical, original language work? 
  • Are you doing something with photos/media?

I did notice that you have a LONG list of hidden resources, most of which appear to be perseus related. It would have been best to have FL lock those licenses on your account instead of hiding them. 

Thanks.

1)  I did restart my computer

2)  I did try loading a blank layout and building a new one.  No improvement.  In the log it should show that I tried that as well.  I actually shut everything closed and still had problems

3)  No searches, and no original language work

4) Nothing with photos/media

I do have a long list of hidden resources.  Didn't know I should have them lock them for me, but that's been like that for a LONG time prior to this.

Thanks for your help!

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 5:24 PM

Adam Olean:

Adam Olean:

Hi Cynthia,

You can check out this thread along with my post for some ideas. Unfortunately, Logos 7 seems to waste a lot of unnecessary resources, but there are at least some things that can be done to help optimize performance. This has been discussed at various places on the forums.

In addition to the ideas in that thread, you can also try toggling off any unnecessary Sidebars and Content in the homescreen to see if that improves things. You could even try initially toggling everything off and then adding things back as desired, balancing performance and functionality.

Hello Adam:  Thanks for your help.  I did check out your post for ideas.  From what I can tell, that mostly doesn't apply to me.  I don't have tons of complex collections, etc., etc.

I did toggle off everything, and still, when I went back to my work screen (which was blank) I could not open "courses."  Three times I tried, and I was stripped down to the bare bones.

When I went back to the home screen..I still was mostly blank and only was able to see items in the far bottom left corner. 

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 7:10 PM

FYI:  No matter what I do, I can't get my courses to open.  Plain white screen opens, and at the bottom left all I see is this:

Save

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 7:24 PM

I think my problem is getting worse...quickly.

Items continue to fail to open.  This is what I see when i click on Bible Browser.

Edited to add: Quite some time later, bible browser said this:

Save

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 7:28 PM

My Concordance tool has been working for almost 5 minutes and the blue bar is only half the way through!

Edited to add:  Concordance JUST generated...it took 9 minutes for 1 Cor-Rev.

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 7:30 PM

Atlas, Collections, timeline, text comparisons, personal books, passage analysis, wikipedia, Bible sense lexicon, and factbook work like normal.

Media is slow but it works.

Concordance is STILL chewing!

Hey, I just had a thought...are my problems Logos Now Tools? 

Cynthia

Romans 8:28-38

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 7:46 PM

So, it's late and I'm talking to myself so that's all the info I can give for now.  I have an appointment tomorrow morning so I'll check back afterward.

EDITED TO ADD: Okay, I just noticed something.

If I try to open the courses tab or concordance tab, or any tab that isn't working, leave it alone, , click the + button, click on any of the tools that DO work, and go back to, the tool that wasn't working, opens up.  It's not super fast, but it opens up before my eyes.

So, if I open courses, it won't open.  Then, I click the + sign, open a tool that is working, click back over to the courses tool, and it opens.

Now I would have two tabs open, right?

Okay, then I go and open the concordance tab, and it stays frozen, I click the + tab, open a tool that is working, click back over to the concordance tab and it opens up in front of my eyes. So then I have four tabs open, right?

Well, that's how it works.   In order to open a tool that ISN'T working, I have to open a tool that DOES work.  For ever tool that doesn't work, I go and open one that does and it works like normal.

So, I hope that helps to narrow things down.

Cynthia

Romans 8:28-38

Posts 744
Armin | Forum Activity | Replied: Sun, Jan 22 2017 8:29 PM

I believe quite a few of us are experiencing issues on the Mac at the moment. I cannot get through a 45min devotional time without having to force quit Logos several times on my Mac. 

Does your sync wheel keep spinning? When you click on the Library button, does it state that the library might be incomplete? Then it is very similar to what I am experiencing. Have a look at:

https://community.logos.com/forums/p/134208/876996.aspx 

Posts 809
Cynthia in Florida | Forum Activity | Replied: Sun, Jan 22 2017 8:49 PM

Hello Armin:  I have none of those symptoms.  Perhaps I have the flu and you have a cold? Smile

Cynthia

Romans 8:28-38

Posts 13360
Forum MVP
Mark Barnes | Forum Activity | Replied: Mon, Jan 23 2017 1:30 AM

Usually slowdowns come from:

  1. Too many, or overly-complex layouts.
  2. Too many, or too broad visual filters.
  3. Too many, or overly-complex collections.

Don't worry about hidden resources. They're very rarely an issue, and according to your log, they're only adding 0.5s to your startup time.

In your case:

  • Your layout seems OK, and you're running 7.3 which solved a big part of the layout slowdown.
  • You don't have many collections, though some of them are quite broad. Collections have to be recalculated every time your library changes. In at least one set of logs, you received silent metadata updates during startup, so collections ended up being calculated three times, at an average of about 3.2s each time. Your library catalog was also updated at the same time, which took an extra 8s. There's not much you can do about this unless you definitely don't need some of the collections (but that's not going to make a huge different).
  • But visual filters is more of a problem. You said you don't do any original language work, but you seem to have have dozens of morphological filters (possibly in the NASB?), which are certainly slowing things down. If you don't need these, you should delete them. If you don't want to delete them, but rarely use them, you could temporarily move the visual filter to a resource you don't access, and then move it back when you need it.
Page 1 of 3 (51 items) 1 2 3 Next > | RSS