Why is Logos 7 SOOOO SLOOOOOWWW?

Page 2 of 2 (32 items) < Previous 1 2
This post has 31 Replies | 6 Followers

Posts 306
LogosEmployee
Philip Peng | Forum Activity | Replied: Thu, Mar 16 2017 9:56 AM

PL:

Through regular use of various Bible versions this morning, I have determined that the CUV is exceptionally slow compared to other versions (ESV, NIV, NIV84, RCUV).

Even after all Bible panels have been loaded and opened at least once, CUV is still taking longer to move to other Bible references:

  • CUV moving to another Bible reference: 6 seconds, and mouse scrolling is extremely unresponsive and lagging, even with the bottom RVI pane closed.
  • Other translations (ESV, NIV, NIV84, RCUV) moving to another Bible reference: 1-2 seconds, and mouse scrolling is extremely responsive and not lagging, even with the bottom RVI pane opened.

This may have started becoming a problem after the CUV was turned into RVI around Christmas time last year.

Can others confirm this performance hit with the CUV?

Faithlife, can you please look into this performance problem?

Thanks,

Peter

Hi, Peter,

I have tried it on my mac (running 7.5.0.0028 updates) and found that 中文聖經新標點和合本(上帝版)CUV is moving slowly (with lagging) from one RVI Bible reference to another RVI reference when I clicked on the verses itself.    I tested it with only this Bible opened and with the RVI turned on. We will look into this issue and fix it as soon as we can.  Sorry for the inconvenience.

Best regards,

Philip 

Posts 1373
PL | Forum Activity | Replied: Thu, Mar 16 2017 1:23 PM

Philip, the CUV is lagging even with the bottom RVI pane turned off. There is clearly a problem with this one resource.

Alabama, how do I rebuild index for one specific resource?

Adam, thanks for your general tuning tips. Since the one CUV Bible is clearly slower than the other Bible resources, I will wait to apply your other tuning tips.

Bradley, can you please confirm that we should remove unused Collections for faster performance even within the same resource (like the CUV Chinese Bible)?

Peter

Posts 8241
LogosEmployee

alabama24:

PL:
Can others confirm this performance hit with the CUV?

Have you tried rebuilding the index for this specific resource? 

The index is only used for searching; rebuilding it has nothing to do with performance.

Posts 8241
LogosEmployee

PL:
Alabama, how do I rebuild index for one specific resource?

Don't do this.

Posts 8241
LogosEmployee

PL:
Bradley, can you please confirm that we should remove unused Collections for faster performance even within the same resource (like the CUV Chinese Bible)?

Does this post answer your question? https://community.logos.com/forums/p/131109/853792.aspx#853792 

Posts 1373
PL | Forum Activity | Replied: Thu, Mar 16 2017 2:14 PM

Hi Bradley,

I read that thread as saying Collections add a general background drag to Logos in general. It doesn't sound like having about 10 Collections defined can explain a specific, measurable drag on one specific resource (CUV), am I correct?

If I don't have to, I'd rather not touch these collections that I've set up and used on various occasions over the years. I don't have time to evaluate them right now.

While I have you, can you shed some light for me? Of the various things I've done so far (set custom chrome to no, turn off scroll bar tickmarks, turn off bottom RVI pane, change and turn off visual filters), am I correct to say that none of these steps would explain specific slowness with one particular Bible resource?

Also, BTW, how do you link to a particular section / reply on a forum thread?

Thanks,

Peter

Posts 28357
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Mar 16 2017 3:05 PM

PL:

how do you link to a particular section / reply on a forum thread?

Click on the paper icon to the left of the user's name from the post in question. The page will reload with a URL pointed to the specific post. 

See how this is built: https://community.logos.com/forums/p/139432/890739.aspx#890739

OSX & iOS | Logs |  Install

Posts 1373
PL | Forum Activity | Replied: Thu, Mar 16 2017 3:13 PM

Thanks Alabama!

Posts 8241
LogosEmployee

PL:
I read that thread as saying Collections add a general background drag to Logos in general. It doesn't sound like having about 10 Collections defined can explain a specific, measurable drag on one specific resource (CUV), am I correct?

Correct. I don't know of any reason why having collections defined should slow down a resource (especially after they've been loaded in the background once at startup).

PL:
While I have you, can you shed some light for me? Of the various things I've done so far (set custom chrome to no, turn off scroll bar tickmarks, turn off bottom RVI pane, change and turn off visual filters), am I correct to say that none of these steps would explain specific slowness with one particular Bible resource?

Turning off the reverse interlinear pane is likely to speed up the use of your Bible because the application doesn't have to load the reverse interlinear data.

One other thing that just came to mind: are you using the application-default resource font or a custom one (installed on your system)? Does changing it make any difference?

Posts 1373
PL | Forum Activity | Replied: Thu, Mar 16 2017 4:10 PM

All the fonts are Default or factory settings.

Peter

Posts 8241
LogosEmployee
Bradley Grainger (Faithlife) | Forum Activity | Replied: Fri, Mar 17 2017 12:48 PM

PL:
First time loading CUV seems to be the culprit: average 11-12 seconds first time load, single view or multi-view with another version. Any ideas why?

We've reproduced this problem in-house and are investigating solutions.

Posts 1373
PL | Forum Activity | Replied: Fri, Mar 17 2017 1:11 PM

Thanks Bradley. For now I will use other Bible versions unless I really need to use the RVI with the CUV.

Peter

Page 2 of 2 (32 items) < Previous 1 2 | RSS