Unable to sign in to www.logos.com

Page 1 of 1 (3 items)
This post has 2 Replies | 1 Follower

Posts 468
Charlene | Forum Activity | Posted: Thu, Apr 1 2010 2:23 AM

Actually it is my friend who is having trouble. A week or so ago, she was online and trying to purchase a book. She could click on the book, but when she clicked on proceed, instead of going to the billing window, it would just open the same window where she had placed an order. She never could "proceed" out of that window, to actually buy the book.

So, I told her to "Sign out" of her Logos account and then sign back in, which she attempted to do. BUT since then she is unable to sign back in. I thought that perhaps she was entering in her password inaccurately or perhaps using caps instead of using lower case, but she insists that she is entering it in correctly. And Logos resent her email address and password to her, so she knows that what she is entering in is correct.

I just now tried to enter into her account from my home and could do it successfully.

So I then had her turn her virus protection off of her computer and disable her firewall and try again. No success.

I don't know what is blocking it.

Do any of you have any ideas to suggest? She wanted to order some of the March Madness books, but can't even log in to do that!

Any and all help appreciated!

Charlene

Posts 18888
Rosie Perera | Forum Activity | Replied: Thu, Apr 1 2010 3:05 AM

I'm assuming this is on Windows? Try having her delete all her Internet cookies, or try to log in from a different browser (Firefox if she's using Internet Explorer, or vice versa). To delete cookies from IE8, Tools > Internet Options, ...

Or if she's using Firefox, that lets you delete just the Logos cookies if you want to preserve other ones: Tools > Options > Privacy > remove individual cookies, and then ...

Also, make sure she has turned her virus protection and firewall back on again since that little failed experiment.

Posts 468
Charlene | Forum Activity | Replied: Thu, Apr 1 2010 4:35 AM

Rosie Perera:
I'm assuming this is on Windows? Try having her delete all her Internet cookies, or try to log in from a different browser (Firefox if she's using Internet Explorer, or vice versa)

Thanks, Rosie! Deleting the cookies didn't help, but she did download Firefox and was then able to log in, so Internet Explorer is the problem.

And yes, we did remember to turn everything back on!

Appreciate the help!

Charlene

Page 1 of 1 (3 items) | RSS