Bug: Bible not tracking in custom Passage layout with linked Bible

Page 1 of 1 (9 items)
This post has 8 Replies | 1 Follower

Posts 962
John Goodman | Forum Activity | Posted: Tue, Oct 30 2018 1:38 AM

Under layouts, homepage layouts, passage, I have saved a custom layout which was based on the original but uses 4 columns rather than having the commentary load under the bibles.

Also it only opens my preferred bible; the left and right arrows serve me well for switching. NA28 is linked to BHS and BDAG is linked to HALOT such that clicking a word in the bible takes me instantly to the lexicon ref and entering an OT passage in NA28 takes me straight there with BHS popping up instead. 

The problem is that although the guides populate with the verse I have entered into the command bar, the bible and commentaries are stuck on the passage I was looking at when I first saved the layout. I have tried rebuilding this layout for the minimum changes from the original but I'm a bit stuck. I think it is because the code which loads the verse into the layout hasn't taken account of the newer linking feature. It tracks to NT passages but not to OT passages. If I save the layout with the NIV instead of my linked bible the tracking works.

Screen shot attached.

One nice trick is that my fav bible (the linked na28 + bhs with net) is actually my 2nd highest prioritised bible so that the NIV is the left arrow and the ESV is the right arrow. Both are only one key away. The linking is done by setting BHS and NA28 as same series.

The customisability including the linking together with the prioritisation and shortcut keys have made a beautifully uncluttered view possible... one reason why I really enjoy Logos!

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 21873
Forum MVP
Graham Criddle | Forum Activity | Replied: Tue, Oct 30 2018 2:33 AM

John Goodman:
The problem is that although the guides populate with the verse I have entered into the command bar, the bible and commentaries are stuck on the passage I was looking at when I first saved the layout.

It doesn't look as though the PG is included in the linkeset. What happens if you add it in?

Posts 1164
LimJK | Forum Activity | Replied: Tue, Oct 30 2018 2:52 AM

John,

Not sure how you did your customisation ... so just a wild guess. I think for your layout to work I supposed you have created you own customised "Series" to match your choice of OT and NT Original Language text. So that your 2nd panel will automatically switch between OT and NT text.

See screen shot

JK

MacBookPro Retina 15" Mid 2014 2.5GHz RAM:16GB SSD:512GB macOS Mojave 10.14.1 | iPhone X iOS 12.1

Posts 24852
Forum MVP
Dave Hooton | Forum Activity | Replied: Wed, Oct 31 2018 4:15 AM

Where NA28 is linked to BHS and BDAG is linked to HALOT, it is done via Multiview resources.

Dave
===

Windows & Android

Posts 1164
LimJK | Forum Activity | Replied: Sun, Nov 4 2018 5:58 PM

Dave Hooton:

Where NA28 is linked to BHS and BDAG is linked to HALOT, it is done via Multiview resources.

 Dave,

Thanks for the education Smile I have not used Multiview feature before Embarrassed Thanks!

JK

MacBookPro Retina 15" Mid 2014 2.5GHz RAM:16GB SSD:512GB macOS Mojave 10.14.1 | iPhone X iOS 12.1

Posts 62
Mark Kulikovsky | Forum Activity | Replied: Sun, Nov 4 2018 9:59 PM

I'm not sure if my problem is related to this one but I have had a few crashes (logs for one attached) which seem to be related to a linking and series issue. I have BHS SESB 2.0 and UBS5 in a series and then linkset them to the NIV. What should happen (and it works most of the time) is that when I move from verse to verse in the NIV, the linkset tracks with the NIV. If I change from OT to NT or vice-versa, then the linked resource will switch to the relevant resource for the testament I am in. Not always, but a couple of times when I have switched from one testament to the other in the NIV (expecting the linked resource to switch from BHS to UBS or vice versa), Logos doesn't do so and then if I go into the tabbed pane, Logos crashes with the attached error: 

Error detail: ArgumentException: Resource instances for LLS:UBS5 (2017-03-29T17:53:46Z) and LLS:1.0.204 (2017-10-26T20:42:40Z) do not match. Parameter name: range.

Logos is NOT always crashing but it has done so at least three times with this same error.

4336.LogosCrash0511.zip

Posts 24852
Forum MVP
Dave Hooton | Forum Activity | Replied: Mon, Nov 5 2018 2:58 PM

It is a different issue, Mark, so you should create a new thread to get the proper attention (I can't reproduce as I don't have UBS5/SESB).

Dave
===

Windows & Android

Posts 962
John Goodman | Forum Activity | Replied: Thu, Nov 8 2018 3:30 PM

Graham Criddle:
It doesn't look as though the PG is included in the linkeset. What happens if you add it in?

What happens is it reloads every time you scroll a bible... its a bit brutal!

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Posts 962
John Goodman | Forum Activity | Replied: Thu, Nov 8 2018 3:31 PM

LimJK:

Not sure how you did your customisation ... so just a wild guess. I think for your layout to work I supposed you have created you own customised "Series" to match your choice of OT and NT Original Language text. So that your 2nd panel will automatically switch between OT and NT text.

Yes exactly... it is in a series and will do that but not first load - thats the bug/missing feature. 

גַּם־חֹשֶׁךְ֮ לֹֽא־יַחְשִׁ֪יךְ מִ֫מֶּ֥ךָ וְ֭לַיְלָה כַּיּ֣וֹם יָאִ֑יר כַּ֝חֲשֵׁיכָ֗ה כָּאוֹרָֽה

Page 1 of 1 (9 items) | RSS