BUG: Sorting wrong titles as absent.

Page 1 of 1 (7 items)
This post has 6 Replies | 0 Followers

Posts 3024
SineNomine | Forum Activity | Posted: Thu, Feb 28 2019 2:32 PM

I've removed X books from my Verbum installation. The first X books, alphabetically, that are still in my installation show up as absent when I sort for the books that are absent.

Posts 2069
LogosEmployee

I don't quite follow. Can you attach a screenshot of your entire Library panel showing your situation?

Posts 3024
SineNomine | Forum Activity | Replied: Thu, Feb 28 2019 5:55 PM

No, especially since it fixed itself eventually, probably once all of the syncing/indexing finished. But it's still a BUG.

I can explain myself better, though.

I'll use a made-up number not terribly far from the truth.

I removed, let's say, exactly 250 books from my Verbum desktop installation.

Then, in my open Library pane, I sorted to see exclusively books NOT on my Device.

My library then displayed exactly 250 books. However, those 250 books were all books that are still in my installation. As it happens, they were the first 250 books I would see if I sorted my entire collection of books that ARE still on my system in alphabetical order.

Posts 2069
LogosEmployee

Do you mean Filter (like from selecting a facet in the sidebar or typing in the "Find resources" box) instead of Sort? Was the yellow bar visible indicating that the library catalog was updating?

Posts 3024
SineNomine | Forum Activity | Replied: Thu, Feb 28 2019 6:20 PM

Andrew Batishko (Faithlife):

Do you mean Filter (like from selecting a facet in the sidebar or typing in the "Find resources" box) instead of Sort? Was the yellow bar visible indicating that the library catalog was updating?

Selecting a facet in the sidebar. I've had a lot of problems with those facets lately. At least some of the time I think the bar was not present, but I couldn't say for sure now.

Posts 2069
LogosEmployee

If the yellow notification was visible, then this is not a bug. As the notification would indicate, the library needs time to finish updating to show the correct information. Please keep your eye open to see if this happens again, and if it happens when the yellow bar is not visible, then please post a screenshot and log file.

Posts 3024
SineNomine | Forum Activity | Replied: Fri, Mar 1 2019 4:51 PM

Andrew Batishko (Faithlife):
If the yellow notification was visible, then this is not a bug.

It sure looks like a bug. I get that while indexing my library may show me out of date information or may omit correct information. What I see as a bug is my Library showing me information that was never, ever accurate whatsoever.

Page 1 of 1 (7 items) | RSS