8.8 beta 2 bug: Keyboard picker getting in the way of morph terms

Page 1 of 1 (5 items)
This post has 4 Replies | 2 Followers

Posts 13343
Forum MVP
Mark Barnes | Forum Activity | Posted: Wed, Sep 4 2019 1:12 PM

When doing a morph search, pressing @ is cycling between the Hebrew and Greek keyboard, rather than allowing me to enter morph terms.

Posts 2567
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Sep 4 2019 1:45 PM

Mark Barnes:

When doing a morph search, pressing @ is cycling between the Hebrew and Greek keyboard, rather than allowing me to enter morph terms.

I'm not able to reproduce this, when I click on a Morph Search and have the keyboard set to default and enter the @ it allows me to enter the morph term. Are you already in Greek or Hebrew?

Posts 1004
Harry Hahne | Forum Activity | Replied: Wed, Sep 4 2019 2:22 PM

The @ symbol works to bring up the morph picker if you are typing in the default keyboard. But if you change the keyboard to Greek or Hebrew, @ is used for a diacritical mark, so you cannot bring up the morph picker.

There should be a way to bring up the morph picker if you are using the Greek or Hebrew keyboard to type in the Greek or Hebrew word directly, rather than by transliteration. It is a pain to switch back to English keyboard so you can press the @ sign and select the morphology. People comfortable enough to type Greek or Hebrew directly also probably also know the languages well enough to do morph searches.

Posts 13343
Forum MVP
Mark Barnes | Forum Activity | Replied: Wed, Sep 4 2019 3:07 PM

Philana R. Crouch:
I'm not able to reproduce this, when I click on a Morph Search and have the keyboard set to default and enter the @ it allows me to enter the morph term. Are you already in Greek or Hebrew?

It doesn't matter. As I press @, it cycles between the keyboard icon, the Greek icon, and the Hebrew icon, then back to the keyboard.

I double-checked, and the bug only occurs when I have the UK keyboard selected in my Windows settings. (The @ sign and the double quote are transposed on US/UK keyboard layouts.)

Posts 2567
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Tue, Sep 10 2019 8:45 AM

Mark Barnes:

When doing a morph search, pressing @ is cycling between the Hebrew and Greek keyboard, rather than allowing me to enter morph terms.

This has been fixed in 8.8 Beta 3.

Page 1 of 1 (5 items) | RSS