Israeli Hebrew Keyboard

Page 1 of 1 (7 items)
This post has 6 Replies | 1 Follower

Posts 3
Mike Tisdell | Forum Activity | Posted: Fri, Oct 4 2019 3:16 PM

Can Logos be configured to use an Israeli Hebrew keyboard layout. So far I can only find out to add the Logos layout to windows.

Posts 3219
Forum MVP
PetahChristian | Forum Activity | Replied: Fri, Oct 4 2019 3:29 PM

Hi Mike,

Welcome to the forums.

Have you tried using the Hebrew language/input method provided by the OS?

Just go to Settings -> Language and add Hebrew, which should correspond with the standard layout used for an Israeli Hebrew keyboard.

You can toggle between English and Hebrew keyboards by pressing Windows Key + Space.

Posts 3
Mike Tisdell | Forum Activity | Replied: Fri, Oct 4 2019 3:32 PM

Yes, I have that setting in windows already and it works with all of my other programs. I use it frequently when in MS-Word.

When I type in Logos, I get a Logos special keyboard with all of the keys in the wrong place.

Posts 3219
Forum MVP
PetahChristian | Forum Activity | Replied: Fri, Oct 4 2019 3:40 PM

Had you also installed the Logos Original Languages keyboard that Faithlife provides? That uses a different mapping from what you expect, and you may need to uninstall that.

Logos also has an in-app keyboard selector, which I've also never used. According to the Hebrew and Greek Input Options support page, it can be deactivated from Logos' Program Settings.

Posts 3
Mike Tisdell | Forum Activity | Replied: Fri, Oct 4 2019 4:24 PM

I downloaded but did not install the Original languages keyboard because I realized it was a Logos layout for windows which is not what I wanted.

I was selecting the input language on the search bar and that was the problem. If I switch it from the system tray it works correctly. In other software packages, the language selection uses the Windows selection and I had expected that Logos would do the same.

Posts 3219
Forum MVP
PetahChristian | Forum Activity | Replied: Fri, Oct 4 2019 8:25 PM

Mike Tisdell:
I was selecting the input language on the search bar and that was the problem. If I switch it from the system tray it works correctly.

Glad you got it figured out, Mike.

The keyboard selector on the search bar activates Logos' built-in keyboard. (It can be disabled from Program Settings if you don't plan to use it.)

I imagine it's an alternative for customers who never installed a Windows keyboard.

Posts 1998
Forum MVP
Reuben Helmuth | Forum Activity | Replied: Sat, Oct 5 2019 12:34 AM

PetahChristian:
I imagine it's an alternative for customers who never installed a Windows keyboard.

I think this is correct. Specifically, it eliminates the need to use transliteration. I have my own system keyboards installed that I can switch via Cmd+K, so I disabled the Logos keyboard switcher in settings.

Page 1 of 1 (7 items) | RSS