Page 1 of 1 (15 items)
This post has 14 Replies | 0 Followers

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Posted: Mon, Oct 21 2019 3:28 AM

Logos 8.9 Beta 2 Mac OS 10.15

Always start Logos to a blank layout. Experienced an immediate spinning beachball. Waited 4 minutes and took a sample with the LogosLoggingUtility.

2018.Sample.10.21.LogosLogs.jackcav.20191021-061622.zip

Took a sample with the Mac Activity Monitor

8838.AM Sample 10-21-19@0618.rtf

Forced quit from Activity Monitor—more than 5 minutes after startup.

Apple Crash Report

8623.Apple Crash 0620-10-21.rtf

Logos Logs

6557.LogosLogs.jackcav.20191021-062132.zip

RESTART WAS WITHOUT INCIDENT

Posts 1378
Ben | Forum Activity | Replied: Mon, Oct 21 2019 6:56 AM

This happens to me all the time. I would say >50% of the time I open Logos in the last 6 months, I have to force-kill it and restart. But I tend to just leave it open. 

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 2684
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Mon, Oct 21 2019 10:50 AM

Jack Caviness:

Logos 8.9 Beta 2 Mac OS 10.15

Always start Logos to a blank layout. Experienced an immediate spinning beachball. Waited 4 minutes and took a sample with the LogosLoggingUtility.

2018.Sample.10.21.LogosLogs.jackcav.20191021-061622.zip

Took a sample with the Mac Activity Monitor

8838.AM Sample 10-21-19@0618.rtf

Forced quit from Activity Monitor—more than 5 minutes after startup.

Apple Crash Report

8623.Apple Crash 0620-10-21.rtf

Logos Logs

6557.LogosLogs.jackcav.20191021-062132.zip

RESTART WAS WITHOUT INCIDENT

Jack,

Thank you for the report, we'll look into it

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Oct 22 2019 7:06 AM

Philana R. Crouch:
Thank you for the report, we'll look into it

Thanks Philana. Like Ben, I have had this happen previously. Not as often as Ben indicated, but still periodic freezes.

Posts 1378
Ben | Forum Activity | Replied: Fri, Oct 25 2019 9:46 AM

Startup-freeze three times in a row this morning. 
Logs- 6403.LogosLogs.benspackman.20191025-094512.zip

The logger may not have been enabled...

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Oct 25 2019 10:43 AM

Ben:
The logger may not have been enabled...

It was, but my log reading would be more harmful than helpful. Any special reason you have not upgraded to 10.15?

Note Quickbooks 2016 has some serious issues with Catalina, a fact neither Apple nor Intuit mention until after 10.15 is installed.

Posts 1378
Ben | Forum Activity | Replied: Mon, Oct 28 2019 8:40 AM

I tend to be a beta tester and early adopter, but all the forums say this Catalina release is quite buggy AND apparently it breaks the Bibleworks install under Mac.

"The whole modern world has divided itself into Conservatives and Progressives. The business of Progressives is to go on making mistakes. The business of Conservatives is to prevent mistakes from being corrected."- G.K. Chesterton

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Tue, Oct 29 2019 5:33 AM

Ben:
all the forums say this Catalina release is quite buggy

Believe those refer to the beta versions of the OS. I have not had any new problems with Logos since upgrading last week.

Ben:
apparently it breaks the Bibleworks install under Mac.

Sorry, can't comment there as I never used BibleWorks

Posts 27780
Forum MVP
JT (alabama24) | Forum Activity | Replied: Tue, Oct 29 2019 6:59 AM

Jack Caviness:
Believe those refer to the beta versions of the OS. I have not had any new problems with Logos since upgrading last week.

Nor have I. I can't speak to the beta issues though. 

OSX & iOS | Logs |  Install

Posts 10587
Forum MVP
Posts 52
LogosEmployee
Matt Preucil | Forum Activity | Replied: Wed, Oct 30 2019 2:34 PM

Jack,

The hang that you keep running into is a very unfortunate problem. Logos has been shipping with code that attempts to mitigate this same problem for years. Most users might experience this hang on occasion, but it does seem to be extremely consistent for you (each update, which you get weekly from the beta channel?). I've been looking for a solution, but haven't had any luck.

I'm sorry to say that at this point, if you've received an application update and the app beach balls on startup, your quickest resolution is just to force quit and relaunch. The samples indicate the issue and provide an interesting pattern, but we've got all we can from them. Specifically, you can determine if a hang is this issue by looking for one thread's callstack that includes sgen_stop_world and then dyldGlobalLockAcquire.

I hope to be able to deliver better news in regards to this issue in the future.

- Matt

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Wed, Oct 30 2019 3:06 PM

Matt Preucil:
it does seem to be extremely consistent for you (each update, which you get weekly from the beta channel?). I've been looking for a solution, but haven't had any luck.

Haven't paid enough attention to the frequency to verify this.

Matt Preucil:
The samples indicate the issue and provide an interesting pattern, but we've got all we can from them.

OK, I'll stop posting them.

Posts 52
LogosEmployee
Matt Preucil | Forum Activity | Replied: Thu, Nov 7 2019 1:21 PM

Jack,

We were able to make a change that might resolve this hang. The change shipped with RC 1, so let us know if you continue to experience this issue. Thanks!

- Matt

Posts 10587
Forum MVP
Jack Caviness | Forum Activity | Replied: Fri, Nov 8 2019 6:54 AM

Matt Preucil:
We were able to make a change that might resolve this hang. The change shipped with RC 1, so let us know if you continue to experience this issue.

It did not happen with 8.9 RC-1. Will be sure to let you know if it happens with 8.10 betas

Page 1 of 1 (15 items) | RSS