Logos 8.9 Beta 4 (8.9.0.0015)

Page 1 of 1 (19 items)
This post has 18 Replies | 1 Follower

Posts 2684
LogosEmployee
Philana R. Crouch | Forum Activity | Posted: Tue, Oct 29 2019 1:40 PM

To immediately update to the current beta enter the Update Now command. Otherwise, the app will automatically update the next time it's scheduled to check for updates.

Release Notes     

Mac

Windows

Posts 508
Bob Deacon | Forum Activity | Replied: Wed, Oct 30 2019 5:28 AM

My windows 10 surface pro 6 is NOT updating to beta 4.

Bob

Bob Deacon

Dell Inspiron, Windows 10 Latest Update

Surface Pro 6

MacBook Air (2017) Catalina

Ipad Air 2 (ios 8.2.1)

Motorola G6 Play (android 8.3.1)

Posts 2684
LogosEmployee
Philana R. Crouch | Forum Activity | Replied: Wed, Oct 30 2019 8:14 AM

Bob Deacon:

My windows 10 surface pro 6 is NOT updating to beta 4.

Bob

Bob,

Can we get logs? I'm not sure why it's not updating for you.

Posts 508
Bob Deacon | Forum Activity | Replied: Wed, Oct 30 2019 6:03 PM

I tried numerous times to "update now" only to be told "no updates available". I looked at your last post and followed the instructions to enable logging. I restarted L8 and viola! beta 4! Not sure what when or how but I do now have beta 4.

Bob

Bob Deacon

Dell Inspiron, Windows 10 Latest Update

Surface Pro 6

MacBook Air (2017) Catalina

Ipad Air 2 (ios 8.2.1)

Motorola G6 Play (android 8.3.1)

Posts 27780
Forum MVP
JT (alabama24) | Forum Activity | Replied: Wed, Oct 30 2019 6:23 PM

Had you restarted Logos before? Your computer?

OSX & iOS | Logs |  Install

Posts 508
Bob Deacon | Forum Activity | Replied: Thu, Oct 31 2019 3:53 AM

JT, all is good! Not sure why or how. I have never had a problem updating before but I am good now! Thank you!

Bob

Bob Deacon

Dell Inspiron, Windows 10 Latest Update

Surface Pro 6

MacBook Air (2017) Catalina

Ipad Air 2 (ios 8.2.1)

Motorola G6 Play (android 8.3.1)

Posts 27780
Forum MVP
JT (alabama24) | Forum Activity | Replied: Thu, Oct 31 2019 4:22 AM

Bob Deacon:
JT, all is good!

Yes, I understood that... and glad Smile

Bob Deacon:
Not sure why or how.

That was what I was trying to get at. "Enabling Logging" would not have fixed the issue... but restarting the app (and/or computer) might. If you are in a similar pickle in the future, make sure to try both.

OSX & iOS | Logs |  Install

Posts 508
Bob Deacon | Forum Activity | Replied: Thu, Oct 31 2019 12:38 PM

Will do, thanks again.

Bob

Bob Deacon

Dell Inspiron, Windows 10 Latest Update

Surface Pro 6

MacBook Air (2017) Catalina

Ipad Air 2 (ios 8.2.1)

Motorola G6 Play (android 8.3.1)

Posts 809
Richard Lyall | Forum Activity | Replied: Fri, Nov 1 2019 11:02 AM

Really unstable for me. Just updated to the above, and whenever I switch to Romans 13 in NIV84, Logos goes into a spinny cursor for a few seconds then crashes. 100% reproducible. Will try restarting.

Win 7x64 Pro.

Posts 2022
Forum MVP
Reuben Helmuth | Forum Activity | Replied: Sun, Nov 3 2019 12:23 AM

Richard Lyall:
Really unstable for me. Just updated to the above, and whenever I switch to Romans 13 in NIV84, Logos goes into a spinny cursor for a few seconds then crashes. 100% reproducible.

Sounds like the bug affecting link sets. In my experience, having resources linked and choosing to navigate outside the current book results in a short hang and then crash (I'm on macOS). Try unlinking your resources to avoid the crash. IMO, this is a really serious bug that needs to have top priority.

According to the normal release schedule, 8.9 ships to stable on the 11th, but this bug HAS to be addressed before going golden!

Posts 26858
Forum MVP
MJ. Smith | Forum Activity | Replied: Sun, Nov 3 2019 1:57 AM

Reuben Helmuth:
Sounds like the bug affecting link sets.

Yes, I'd tried to report it ... but gotten little reaction.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 809
Richard Lyall | Forum Activity | Replied: Sun, Nov 3 2019 5:59 PM

Reuben Helmuth:

Richard Lyall:
Really unstable for me. Just updated to the above, and whenever I switch to Romans 13 in NIV84, Logos goes into a spinny cursor for a few seconds then crashes. 100% reproducible.

Sounds like the bug affecting link sets. In my experience, having resources linked and choosing to navigate outside the current book results in a short hang and then crash (I'm on macOS). Try unlinking your resources to avoid the crash. IMO, this is a really serious bug that needs to have top priority.

According to the normal release schedule, 8.9 ships to stable on the 11th, but this bug HAS to be addressed before going golden!

Removing all link sets seems to have circumvented the issue, allowing me to restore functionality.

One of my linked resources was a serial association between Lexham Hebrew Interlinear and NA27, so maybe the navigating to a different resource during a link update was indeed the issue. I'm pretty sure the NIV84 was located somewhere in the OT when I attempted to navigate to Romans, and the NIV84 is in a linked set with the LHI\NA27.

However, this issue, in its current form, has mostly likely arisen with 8.9b4 as I was using the same Layout for quite a while without any crashes, and had regularly been navigating between OT & NT with that same Link Set in place, so maybe it's a separate, but clearly related issue?

Posts 3
LogosEmployee
Owen Shelton | Forum Activity | Replied: Mon, Nov 4 2019 11:21 AM

We are aware of the issue and investigating it.

As Ruben says, unlinking your resources will avoid the issue.

Posts 809
Richard Lyall | Forum Activity | Replied: Mon, Nov 4 2019 11:37 AM

Owen Shelton:

We are aware of the issue and investigating it.

As Ruben says, unlinking your resources will avoid the issue.

Thanks Owen.

Posts 11
LogosEmployee
Kamira Rea | Forum Activity | Replied: Thu, Nov 7 2019 11:52 AM

This has been fixed in 8.9 RC1. 

Posts 2080
GaoLu | Forum Activity | Replied: Thu, Nov 7 2019 6:33 PM

On another note, my 8.9.0.0023 highligting has ceased working.  

1. Restarted multiple times. 

2. Rebooted.  

3. Shut down other running copies of Logos (on other computers).

4. Repeated #1 & #2

5. Tried highlighting in various documents and documents types (I.E. Monographs, Bibles, etc.)

5. Tried keyboard shortcuts, highlighter panel, and the popup.  No highlighting is working.

Note:  I had sporadic episodes of highlighting acting strange before this. Could this be related to this update (??)  Anyone else?

Posts 26858
Forum MVP
MJ. Smith | Forum Activity | Replied: Thu, Nov 7 2019 9:40 PM

It would be better to start a new thread as FL believes this one to be resolved.

Orthodox Bishop Hilarion Alfeyev: "To be a theologian means to have experience of a personal encounter with God through prayer and worship."

Posts 2080
GaoLu | Forum Activity | Replied: Thu, Nov 7 2019 11:17 PM

MJ. Smith:

It would be better to start a new thread as FL believes this one to be resolved.

Thanks, MJ. I am not asking for assistance.  Just sharing the issue in case anyone who cares might see it.  This may or may not be the best place.

//==================

More info:  The matter  is Layout related and I have been able to reproduce it.  Killing the layout and starting over fixes the issue.  

Posts 2080
GaoLu | Forum Activity | Replied: Thu, Nov 7 2019 11:17 PM

MJ. Smith:

It would be better to start a new thread as FL believes this one to be resolved.

Thanks, MJ. I am not asking for assistance.  Just sharing the issue in case anyone who cares might see it.  This may or may not be the best place.

More info:  The matter  is Layout related and I have been able to reproduce it.  Killing the layout and starting over fixes the issue.  

Page 1 of 1 (19 items) | RSS