Resetting the "send to PowerPoint" program option in Logos 8

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 4
Yegor P. | Forum Activity | Posted: Wed, Sep 23 2020 7:16 AM

Resetting the "send to PowerPoint" program option in Logos 8

Greeting

First I would like to say "Hello" to everyone here on the forums, to the Logos community. I've been reading posts and responses for a couple of days now, and am very excited to be here.

I've been trying to search in the search box for the issue (I type in: send to powerpoint), but every time I try to search, I receive this error message:

search errorThat is why I've decided to make a post. Hopefully, this post is not a duplicate of somebody else's already resolved issue. So here we go, fingers crossed.

Why I am writing

I love my Logos 8 for macOS and have been using the program for about 5 years now! But since yesterday, I have been having a very silly problem. I would like to get it resolved, to find the fix, and to understand why it has happened. I really hope there is somebody here on these forums that will be able to help me.

Description of the problem

Like I've mentioned before, the problem is sort of silly, but bugs me nonetheless. Usually when I enter the Logos 8 program I head straight to the library section, or the search box, and head on my merry way. Away from the home screen. But yesterday I swayed from my usual habits when I saw a visually appealing picture within the home screen tiles. So I clicked on it. That opened up a workspace with related biblical texts, commentaries and a media tab with the image. I thought that I would like to save that image to my wallpaper library on my computer. So, I right-clicked on it and from the menu kept choosing "save as". But nothing was happening. So, and I do not know why I thought that this was a good idea, I clicked on "send to PowerPoint".

drop down menu

A window came up asking me to choose the PowerPoint program and just for "fun" an idea came to me, to click on Photoshop. At the time I thought "why not", since this is an image. And just like that, Photoshop now opens up everytime when I click "send to PowerPoint" on an image.

I would like to be able to undo this. So it does not open Photoshop everytime. To disable, reset this option. To understand what happened. I cannot find a place to do this.

What has been done so far

  • I've looked through the application's directory in: /Applications/Logos.app/Contents
  • I've looked through the application's directory in: ~/Library/Application Support/Logos4
  • I've looked through all (or most of them) SQLite databases in the application's directories.
  • I've reset multiple times the automation settings in: System Preferences -> Security & Privacy -> Privacy -> Automation
    • With this command here: tccutil reset AppleEvents
    • Also, I've tried to reset every setting just for logos with: tccutil reset All Logos4 But, I am unsuccessful and get: tccutil: No such bundle identifier "Logos4": The operation couldn’t be completed. (OSStatus error -10814.) - I do not know the correct bundle identifier for Logos 8 on macOS to execute the command.

I've spend way more time on this tiny little annoyance than I would have liked to. I truly hope that somebody here will be able to help me.
Thanks so much in advance to everyone who's willing to shed some light on this.
God's blessings to all of you.

Posts 8842
LogosEmployee

Try following the instructions in this article https://www.imore.com/how-set-mac-app-default-when-opening-file to change how .ppt or .pptx files are opened.

Posts 18658
Forum MVP
Keep Smiling 4 Jesus :) | Forum Activity | Replied: Wed, Sep 23 2020 12:48 PM

Yegor P.:
I've been trying to search in the search box for the issue

Welcome Big Smile

Unfortunately a residual effect from thousands of SPAM postings is many forum searches receive "Sorry, there was a problem with your last request1" message (instead of search results that include SPAM).

Logos Wiki => Using the Forums includes 

site:community.logos.com send powerpoint

Internet search syntax also works in other engines: e.g. Duck Duck Go

Keep Smiling Smile

Posts 4
Yegor P. | Forum Activity | Replied: Thu, Sep 24 2020 1:41 AM

Hello and thank you for your reply.

I've looked at the settings straight away, but following your advice I've checked again. 

powerpoint file associations

As you can see from the image, that the file association for .pptx is not the issue. I've written in my original post that the file that I was trying to save is not a powerpoint but an image. Any other ideas? Again, I'm very grateful for your reply! 

Posts 4
Yegor P. | Forum Activity | Replied: Fri, Sep 25 2020 5:00 AM

This is the post explaining the solution

I am writing this post to close this topic and leave behind the solution that I found for anyone else that might come across this issue like me. As it was written in my original post, I just selected Photoshop without paying much attention to what I was being asked or what it was exactly that I was confirming.

To figure out what exactly in Logos 8 was launching Photoshop on my mac I ran opensnoop -p in the terminal. I've appended the process id for Logos 8 after the - p flag for this command. Afterward, I clicked on "send to powerpoint" again in the media tab in Logos 8. Here is the output:

terminal output

As we can see, Photoshop is being launched by a little script inside an application that is called SendToPowerPoint.app within Logos 8.

After thinking about this for a while, and a few cups of espresso later, I came to a conclusion that I must have been looking in the wrong places. I realized that there must have been an entry in the operating system preferences somewhere. So I went looking for it in the ~/Library/Preferences/ directory. Sure enough, after searching the .plist files for "powerpoint", there it was.

Here is the created file that is responsible for associating "Microsoft PowerPoint" with "Photoshop", and it's contents.

settings file
file contents

I deleted the com.apple.applescript.plist file from the directory and restarted my MacBook.
Now when I click on the dreaded "send to powerpoint" link in the media tab of Logos 8:

drop down menu

I am greeted with the initial selection window!

select powerpoint screen

Yes! Sweet victory!

In conclusion, thank you all so much for your willingness and quick replies! God's blessings to all of you! I am very grateful to our Lord for giving me the patience and the perseverance needed to continue in this strange journey, and for helping me resolve this! All glory to Him!

Page 1 of 1 (5 items) | RSS