Page 1 of 1 (8 items)
This post has 7 Replies | 1 Follower

Posts 246
Martin Hall | Forum Activity | Posted: Tue, Jan 5 2021 8:08 PM

The code is not working for me to get my free course. At first, I thought that I still had time on my last course, but when I go to access the last course I had taken, it is locked, so I don't think that is the issue. Is anyone else having an issue using the course code to access their free course? 

Posts 246
Martin Hall | Forum Activity | Replied: Fri, Jan 8 2021 3:26 AM

Bump

Posts 588
Bobby Terhune | Forum Activity | Replied: Fri, Jan 8 2021 4:43 AM

Did your subscription expire?

Posts 246
Martin Hall | Forum Activity | Replied: Fri, Jan 8 2021 8:31 AM

Nope, I paid in September. 

Posts 611
Jesse Blevins | Forum Activity | Replied: Fri, Jan 8 2021 6:20 PM

My course code isn't working either.  

Posts 774
Kevin | Forum Activity | Replied: Fri, Jan 8 2021 10:50 PM

Essentials could have H1 or 1H at the end instead of just 1. This does not seem show as valid (no green tick) for me, but that maybe because I have used it. (I got my course before the website updated showing the new code, I just modified last years on the 1st Jan, but do not remember the format.)

You could also try putting a Q before the 1 in the code, you could also try removing the 1, as both seems valid (Green tick, but no discount for me as expected). The Q would be for the Premier level, (Quarter 1 etc) but I cannot remember if would work for Essentials. With regards to removing the 1, I am not sure which subscription has just one course a year, maybe legacy.

Posts 611
Jesse Blevins | Forum Activity | Replied: Sat, Jan 9 2021 1:06 PM

Thanks for your suggestions Kevin. 

I will give them a try. 

Hopefully Logos will get it straight soon. 

Posts 246
Martin Hall | Forum Activity | Replied: Sun, Jan 10 2021 5:17 PM

I tried your suggestions Kevin, but to no avail. Hopefully I can hear something back from Customer Service soon, as I sent an email on Friday. 

Page 1 of 1 (8 items) | RSS