[BUG] Texteingabefeld

Page 1 of 1 (19 items)
This post has 18 Replies | 1 Follower

Posts 292
Andreas Roemer | Forum Activity | Posted: Wed, Feb 17 2021 5:57 AM

Kann es sein, dass "width" im Text-Eingabefeld nicht funktioniert?

Wenn ich "{{input id=FRA02 | type=text | width=30 | prompt="Ihre Meinung dazu?"}}" verwende, wird das Feld zwar erzeugt, aber eine Eingabe ist nicht möglich.
Stelle ich auf "lines" um, funktioniert das Textfeld und wenn ich dann eine Notiz durch eine Eingabe erzeugt habe, das Feld von "lines" auf "width" umstelle, geht es.
Es funktioniert nur zu Anfang nicht.

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 6:18 AM

Irgendwas mache ich damit sowieso falsch. Manchmal geht es mit 2 Textfeldern, manchmal überhaupt nicht, mit den "Typen" von "Lektionar" bis zu "Kommentar" verhält es sich auch eher zufällig.Wenn mal ein Feld mit einem Notiz-Anker geklappt hat, ist es stabil. Aber "richtig" geht es nicht mit dem Text-Eingabefeld.

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 7:03 AM

Andreas Roemer:

Irgendwas mache ich damit sowieso falsch. Manchmal geht es mit 2 Textfeldern, manchmal überhaupt nicht, mit den "Typen" von "Lektionar" bis zu "Kommentar" verhält es sich auch eher zufällig.Wenn mal ein Feld mit einem Notiz-Anker geklappt hat, ist es stabil. Aber "richtig" geht es nicht mit dem Text-Eingabefeld.

Teile dochmal die Dokumente wo es nicht geht, dann kann man dir vielleicht helfen. Deinen Satz mit den "Typen" verstehe ich ohne weiteres Beispiel was du machen willst, wie du es probiert hast und was rauskam nicht.

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 7:20 AM

Also ich möchte drei Textfelder in einem Persönlichen Buch erzeugen. 

Beispieldatei:6266.Feldertest.docx

Den Typ gebe ich hier an, und der ist mir ehrlich gesagt egal. Es geht manchmal mit "Lektionar" und manchmal mit einem anderen Typ, es geht in Teilen, es geht überhaupt nicht und ich weiß nicht, warum.

Im Bildbeispiel geht es nach dem xten Versich mit Feld (2). Die Felder (1) und (3) funktionieren nicht.
Das erste Posting bezog sich auf die Einstellung für das Feld (3) in diesem Beispiel "width". Das funktioniert zuverlässig bei mir nie. Mit dem "Trick" dann auf "lines" umstellen und wenn es mit der Notiz geklappt hat, wieder auf "width" zurückstellen, funktioniert es dann mit "width".

Wie kann ich also zuverlässig 1, 2 oder x Eingabefelder in einem PB erzeugen?

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 7:30 AM

Andreas Roemer:

Kann es sein, dass "width" im Text-Eingabefeld nicht funktioniert?

Wenn ich "{{input id=FRA02 | type=text | width=30 | prompt="Ihre Meinung dazu?"}}" verwende, wird das Feld zwar erzeugt, aber eine Eingabe ist nicht möglich.

 

Hm. Bei mir gehts. 6138.Test eingabefeld.docx (das war nur schnell hingerotzt)

Bist du dir sicher, dass FRA02 nur in einem deiner Eingabefelder als "Identifier" auftaucht? Datei? Screenshot das zeigt, was nicht geht?

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 7:41 AM

Danke.

Nein, ich habe keine doppelten Felder. Bei Deinem Beispiel bekomme ich Warnmeldungen hinsichtlich der Breite, die wohl auf "80" begrenzt ist. Und auch bei dem geht es nicht. Ich kann nichts in die Felder eingeben.

Spannende Frage: Welchen Typ hast Du angegeben?

Edit: Nach dem xten neuen Buch anlegen, geht es zumindest mal mit dem 2. Feld. die anderen leider nicht.

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 7:45 AM

Andreas Roemer:

Also ich möchte drei Textfelder in einem Persönlichen Buch erzeugen. 

Beispieldatei:6266.Feldertest.docx

Den Typ gebe ich hier an, und der ist mir ehrlich gesagt egal.

Also ich hatte meinen Test oben einfach als Monographie gebaut - der Typ Lektionar würde dir dann etwas bringen, wenn du dynamische Bibeltextfelder (also dtext...) einbaust - eigentlich ist er gedacht für Werke, die nach kalendarischem Tagesdatum indexiert sind. Wenn du beides nicht brauchst, verwirr dich nicht damit.

Deine Datei ging bei mir ohne Probleme, da hattest du ja aber schon mit lines gearbeitet. Ich habe alle drei mit width umgestellt, und ging auch ohne Probleme (habe wie du als Lektionar gebaut, aber wie gesagt das ist bei dem Testfall unnötig)  geänderte Datei: 4062.6266.Feldertest.update.docx 

Screenshot:

Running Logos 9 latest (beta) version on Win 10

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 7:50 AM

Andreas Roemer:

Nein, ich habe keine doppelten Felder. Bei Deinem Beispiel bekomme ich Warnmeldungen hinsichtlich der Breite, die wohl auf "80" begrenzt ist. Und auch bei dem geht es nicht. Ich kann nichts in die Felder eingeben.

Seltsam. Wird das Feld mit Umrahmung und der Frage drin angezeigt? Kannst du mit der Maus reinklicken? 

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 7:55 AM

Danke.
Auch diese Datei funktioniert bei mir nicht. Ich mag jetzt aber Logos nicht mehr deinstallieren und wieder neu installieren. Sad
Wenn es bei Dir zuverlässig immer geht, dann liegt es wohl an meinem Logos. 

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 7:56 AM

Andreas Roemer:

Danke.
Auch diese Datei funktioniert bei mir nicht. Ich mag jetzt aber Logos nicht mehr deinstallieren und wieder neu installieren. Sad
Wenn es bei Dir zuverlässig immer geht, dann liegt es wohl an meinem Logos. 

Deinstallieren hilft idR nicht. Bist du auf Mac oder Windows unterwegs?

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 7:57 AM

NB.Mick:
Seltsam. Wird das Feld mit Umrahmung und der Frage drin angezeigt? Kannst du mit der Maus reinklicken? 

Das Feld wird weiß, der "prompt"-Text verschwindet und mehr geht dann nicht. Wenn ich jetzt xmal den Typ umstelle, dann geht zufällig eines der Textfelder.

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 7:58 AM

NB.Mick:
Deinstallieren hilft idR nicht. Bist du auf Mac oder Windows unterwegs?

Windows, stets auf dem neuesten Stand gehalten. 

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 8:07 AM

Danke aber ausdrücklich an dieser Stelle für Deine Mühen. Yes

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 8:09 AM

Andreas Roemer:

NB.Mick:
Deinstallieren hilft idR nicht. Bist du auf Mac oder Windows unterwegs?

Windows, stets auf dem neuesten Stand gehalten. 

Das ist echt seltsam. Der Typ ist es mEn nicht, habe aber keine gute Idee. Vielleicht irgendwie nur ein Anzeigeproblem?

Verwendest du evtl einen "Programm-Maßstab" anders als 100%?

Letztens gab es seltsame Probleme u.a. im Notizenbereich, die auf einen Bug in der Darstellungs-Middleware von Microsoft in Verbindung mit Intel Gen 11-Prozessoren zurückzuführen sind. Hast du sowas Neues am Start? Manchmal berichten auch Leute was davon, dass irgendwelche Darstellungsthemen auf extrem hochauflösenden Zweitmonitoren auftreten. 

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 8:17 AM

Also ich habe einen HP-Spectre mit einem I7-9750H Prozessor. Ein Jahr alt.

Der Monitor ist nur groß, 49'' bei 5120x1440. Wenn ich den aufs Lappy-Display wechsel, bleibt es mit bei dem Problem.

einzig könnte ich noch eine Sandbox starten, Logos installieren, PB bilden und es darin ausprobieren.
Der Programmmaßstab ist bei 100%.

Posts 11514
Forum MVP
NB.Mick | Forum Activity | Replied: Wed, Feb 17 2021 8:35 AM

Andreas Roemer:
Also ich habe einen HP-Spectre mit einem I7-9750H Prozessor. Ein Jahr alt.

Das könnte es tatsächlich sein - falls dem so ist: es gibt eine Lösung für dieses Thema, die aktuell mWn unter https://support.logos.com/hc/en-us/articles/360052821231 steht und ab 9.3 in den Logos-Standard aufgenommen wird (ein Registry-Eintrag schaltet eine fehlerhafte Hardwarebeschleunigung aus, die sich bei nahezu allen Anwendern ohnehin nur auf Logos bezieht). Mehr Infos, wenn du sie willst, in diesem Thread: https://community.logos.com/forums/t/196185.aspx  

Running Logos 9 latest (beta) version on Win 10

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 8:50 AM

Danke, Danke. Probiere ich aus und berichte dann.Smile

Posts 292
Andreas Roemer | Forum Activity | Replied: Wed, Feb 17 2021 9:02 AM

Soeben ausprobiert, neu gebootet und es geht nicht. Morgen Vormittag probiere ich dann eine Neuinstallation in der Sandbox und wenn es dann nicht geht schreibe ich den Support mal an.

Wäre halt eine schöne Funktion in meinen PBs. 

Posts 292
Andreas Roemer | Forum Activity | Replied: Thu, Feb 18 2021 2:55 AM

So habe die Sandbox-Installation von Logos gemacht. Es wäre hilfreich, wenn man eine Installation wählen könnte, wo man eventuell nur 1 oder 2 Ressourcen installiert.
Selbst minimal musste ich 4GB downloaden, bevor ich an den Test gehen konnte. Die Vorbereitung der Bibliothek dauert dann auch gefühlt eine Ewigkeit.

Ein neu gebildetes PB mit den drei testfeldern verhielt sich genauso, wie in der "realen" Umgebung. Damit kann ich eine Neuinstallation von Logos vergessen. Die würde in der Tat nichts bringen.
Also bleibt als Fazit: Diese Funktionalität von Logos läßt sich auf meinem Rechner nicht nutzen. Schade. Hatte ich noch nie, und ich habe eine Vielzahl an Programmen laufen, dass das nicht klappt.

Page 1 of 1 (19 items) | RSS