Page 1 of 1 (15 items)
This post has 14 Replies | 3 Followers

Posts 10
Reed Mueller | Forum Activity | Posted: Thu, Aug 12 2010 10:49 AM

Anyone else seeing their reading plans but without dates associated? The readings appear but are dateless (actually, the top of the page has the header: "(null)" and a check mark. The plan is fine on the desktop.

To try and fix this I signed out of iPhone app. Still the same problem when signing back in.

Then deleted the reading plan on the iPhone and the desktop, then recreated it on the desktop and synced. Still the same problem. Additionally, the stock reading plan that appears if there are no reading plans in the server account has the same issue.

Any ideas would be appreciated.

Posts 2737
Kevin A. Purcell | Forum Activity | Replied: Thu, Aug 12 2010 7:38 PM

I am not seeing this on mine.

Posts 6
Fabio Papa | Forum Activity | Replied: Sat, Aug 21 2010 9:50 PM

I'm having the same problem ... I figured it was because I have a custom reading plan (I made my own xml and put it into the logos readings database), but that can't really be, because it worked fine for at least a month. The problem seems to have started after updating Logos 4 Mac Alpha to Logos 4 Mac Beta.

Posts 184
lostlogik | Forum Activity | Replied: Sun, Aug 22 2010 7:06 AM

Just tried this and don't see the problem. Sadly I can see dates and am reminded how far behind I am...

Posts 10
Reed Mueller | Forum Activity | Replied: Mon, Aug 23 2010 7:51 AM

Thanks for the comments folks.

I'm still having the problem and have attached an iPhone screen capture in case that helps reveal what's going on (as you can see, there are no dates shown but just a raw list of what's coming up in the next four or so days plus what I read yesterday).

Again, I have iOS4 and everything was fine until recently. I run Logos 4 on my personal laptop and my personal desktop and both those are syncing just fine for the reading plans. However the iPhone is still showing what you see on the screen capture even after multiple logout and logins, reinstalls of the Logos iPhone app, deleting and recreating the reading plan via the laptop, etc. This is occurring in all reading plans I have.

Any solutions out there?

Posts 978
LogosEmployee
Dave Dunkin (Faithlife) | Forum Activity | Replied: Mon, Aug 23 2010 9:04 AM

Reed, I just tested this reading plan and it came up fine. Did you do something else that fixed it?

Posts 10
Reed Mueller | Forum Activity | Replied: Mon, Aug 23 2010 9:15 AM

Nope, still having the same issue as the screen shot on my iPhone. Not fixed here. Thanks for looking into it from your end.

Posts 10
Reed Mueller | Forum Activity | Replied: Mon, Aug 30 2010 10:23 AM

Figured it out. This behavior only occurs on iPhones that have been jailbroken (confirmed on multiple models), it does not occur on the standard install of iOS4. That is probably the reason you could pull the reading plan up without issue. No resolution needed on your part. Thanks for looking into it though.

Posts 6
Fabio Papa | Forum Activity | Replied: Mon, Aug 30 2010 12:12 PM

Hmmm ... indeed my iPad is jailbroken, but my iPhone is not, yet it still exhibits the same behavior. I'll "un-jailbreak" my iPad and see if that fixes things on both devices. If that's the case, then jailbroken devices must leave the readings data in a broken state

Posts 10
Reed Mueller | Forum Activity | Replied: Mon, Aug 30 2010 3:40 PM

I figured out the culprit, at least on the iPhone. Reading plans will report and update correctly if you do either of the following on a jailbroken iPhone: 

  1. Temporary Solution: Put the phone in Safe Mode (enter safe mode through SBSettings, takes about 10 or so seconds on mine). All works fine then as Safe Mode disables mobilsubstrate (and all dependent extensions, but mobilsubstrate is the problem I think). Then, after reading through the reading plan and updating, you can reboot normally (again, takes about 10 or so seconds). This might be an adequate solution for some but if you want something more permanent, see solution 2.
  2. Permanent Solution: Uninstall the mobilsubstrate extension itself (which will of course force an uninstall of all dependent extensions, like SBSettings). It's a trade off here as SBSettings is one of my favorite apps. 

Posts 6
Fabio Papa | Forum Activity | Replied: Mon, Aug 30 2010 6:35 PM

Reed, you are awesomely awesome! Your fix worked for me, even on the iPad!

 

For the record, I did not have SBSettings, so I just removed mobilsubstrate as per your permanent solution. Alas, that also removed my iTether app ... the only reason I had my iPad jailbroken in the first place. So I installed SBSettings in Cydia and use solution #1.

 

For anyone that's wondering, doing that on my iPad also solved the problem on my (un-jailbroken) iPhone. So while mobilsubstrate is definitely related to the problem, it must also have something to do with Logos. I know this is probably way down low on the list of priorities, but maybe one of the Logos developers could have a look to see if this has an easy fix.

Posts 10
Reed Mueller | Forum Activity | Replied: Wed, Sep 1 2010 2:57 PM

Here's a second raised hand for someone to look into it now that some possible issues are identified. 

Glad it worked for you!

Posts 126
Jeff Stephens | Forum Activity | Replied: Mon, Sep 6 2010 9:57 AM

what are u guys talking about with 'jailbroke?' my Iphone will not download my reading plan either and want to fix it.

Posts 6
Fabio Papa | Forum Activity | Replied: Mon, Sep 6 2010 11:06 AM

Hey Jeff,

 

Check to see whether you have an app on your phone called 'Cydia.' If you do, that means your phone has been jailbroken. If you didn't do it yourself (maybe by going to jailbreakme.com), somebody may have done it for you. They may have offered to unlock your phone or make it so that you can install applications for free.

Regardless, if your phone is jailbroken and you want it to work with Logos, just follow the instructions given. If you don't want it jailbroken, then connect it to your computer, in iTunes do a backup, and then a restore. The restore will wipe the whole phone then restore it's apps/data/settings, but it won't have cydia and will not be jailbroken. The process may take an hour or so ... make sure you have the time.

Posts 103
Simon | Forum Activity | Replied: Fri, Sep 10 2010 7:17 AM

Yep sure am,

Ditched the Jailbreak and went to iOS 4.1

Problem solved.

Simon

Page 1 of 1 (15 items) | RSS