Bug: Notes doesn't recognise Bible verses when they are followed by a parenthesis and a period

Page 1 of 1 (5 items)
This post has 4 Replies | 1 Follower

Posts 13419
Mark Barnes | Forum Activity | Posted: Sat, Nov 27 2010 2:58 PM | Locked

I think the title is self-explanatory, but to reproduce, just type in "John 3:16 is recognized (but not John 3:16)." into a notes page. The first reference will be recognised and have a hyperlink added, the second will not.

Note, you have to type it in, because if you paste it, it will be recognised!

Posts 5573
Forum MVP
Rich DeRuiter | Forum Activity | Replied: Sat, Nov 27 2010 4:03 PM | Locked

Mark Barnes:

I think the title is self-explanatory, but to reproduce, just type in "John 3:16 is recognized (but not John 3:16)." into a notes page. The first reference will be recognised and have a hyperlink added, the second will not.

Note, you have to type it in, because if you paste it, it will be recognised!

I get this behavior too. The double punctuation marks (close parenthesis-period, comma, question mark, exclamation point) seem to get in the way. Inserting a space (even temporarily) after the close parenthesis does make Logos recognize the citation.

 Help links: WIKI;  Logos 6 FAQ. (Phil. 2:14, NIV)

Posts 19271
Rosie Perera | Forum Activity | Replied: Sat, Nov 27 2010 4:06 PM | Locked

Mark Smith has documented some other cases where Logos will mess up in recognizing a reference and creating a link:

http://community.logos.com/forums/p/26503/195754.aspx#195754

To work around this bug: type a space after the closing parenthesis, then backspace to delete it and then you can type your period. That doesn't get Logos off the hook; it needs to be fixed.

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Nov 29 2010 9:04 AM | Locked

There is an open bug case on this, and it will be fixed in a future release, however, I don't have an eta. I'll include a link to this thread in the case.

Posts 47
Jason Van Vliet | Forum Activity | Replied: Fri, Feb 24 2012 12:57 PM | Locked

Hello,

Just wondering if there is any update on this bug.  More than a year has transpired.  I use notes extensively and frequently put Scripture references in parentheses, so this issue comes up a lot.  I know Logos has a lot on its plate, but is the fix for this any closer to being delivered?

Thanks!

Page 1 of 1 (5 items) | RSS