BUG: Newly applied highlighting takes up to 10-15 seconds to appear, 100% CPU

Page 2 of 4 (64 items) < Previous 1 2 3 4 Next >
This post has 63 Replies | 1 Follower

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 16 2010 12:10 PM | Locked

Stuart Robertson:

The tone of my last post doesn't read so well...  I'm not stunned in a condescending sense but rather, reading through the stack traces, stunned at the size and complexity of Logos for Mac internally - the surface is easy to use but belies the internal complexity and scale.  So, please don't take my last comment badly.  I use Logos for Mac daily and am grateful for all that the Logos devs have done to bring us this far.  Thanks also for chasing down this "15 seconds to highlight" issue.

The Mono runtime starts a bunch of threads in a ThreadPool for background use by default. We don't actually spawn that many threads in the app code programmatically.

 

Mobile Development Team Lead

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Dec 23 2010 12:14 PM | Locked

This issue has been fixed in the latest build - 4.2a Beta 3 (4.21.4.8572) and newly applied highlighting appears instantly. Thank you.

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Dec 23 2010 12:16 PM | Locked

Sorry... spoke too soon.  Highlighting applied to Merriam & Websters dictionary appears instantly, but highlighting applied to the ESV still takes 15 seconds to appear (and maxes out CPU). :-(

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Thu, Dec 23 2010 1:27 PM | Locked

Stuart,

We figured out the source of the slowness, but haven't had time to fix it yet. It's this way on Windows too.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Dec 29 2010 10:27 AM | Locked

Stuart,

Can you post your VisualMarkup.db so that we can take a look at it? You may need to compress it before uploading.

Mobile Development Team Lead

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Dec 29 2010 12:02 PM | Locked

Tom Philpot:

Stuart,

Can you post your VisualMarkup.db so that we can take a look at it? You may need to compress it before uploading.

Nevermind. I'm able to recreate the issue.

Mobile Development Team Lead

Posts 524
Stuart Robertson | Forum Activity | Replied: Wed, Dec 29 2010 1:55 PM | Locked

This is one of those fixes that I will be truly grateful for... :-)  Thank you for your continued focus on Logos for Mac - it is already the most advanced Bible software that I've ever used - both on Windows and on the Mac, and I'm grateful for it each and every day I use it.

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Feb 14 2011 3:50 AM | Locked

Tom was able to recreate this bug on 29-Dec... approx 45 days ago, yet this bug is still not fixed and is making it basically impossible to apply highlighting as I read.  I am basically at the point of ditching all efforts of trying to use Logos for my devotions, since the tool gets in the way so much, making simple things like capturing a note (slow, unreliable), applying a highlight to a keyword (still 10-15 seconds + CPU at 100%, rapidly running battery down, etc) .. it makes "simple things" like these so painful that I just end up frustrated and want to close Logos and instead go back to printed resources.

I know these are not high-priority bugs for Logos, but such "little bugs" are, at least for me, damaging the user experience so badly that I am almost ready to give up on Logos. Add to that the keyboard and focus-related issues, long time taken to show search results, pressing Cmd+Shift+S and having focus go nowhere, etc. and the result is a lot of little irritations that add up poor usability.

I'm at my wits end with Logos for Mac -- it's sooo promising and yet sooo annoying to actually work with for any period of time.  Yes, reading alone works and the text looks great.  Searching does work, word-studies are good.  But search results/word studies/exegetical studies are so small I can hardly read them...

Logos for Mac is so promising and yet lacking in basic areas that Logos doesn't seem to be paying much attention to, at least not from my limited vantage point.

New features are nice, printing is nice, but I would far rather have working highlighting, proper keyboard handling, proper focus handling, etc.  Basically get the foundations working and then add, rather than keep adding new features while basic parts of the app are still broken (and remain broken).

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Feb 14 2011 4:15 AM | Locked

Reading my post, above, and reflecting on my tone in it... please accept my apologies for "whining" or sounding ungrateful.  I am, indeed, grateful for Logos (both to the LORD as well as to Logos and its staff).  But I'm simultaneously frustrated as I use Logos, which I do daily, due to the issues I've mentioned above and elsewhere.

I'd like to ask, though, if Logos has an internal bug tracking system where bugs are recorded, weighted, etc to ensure that bugs don't just slip under the carpet, so to speak...?  And if there is a bug tracking system (I'm assuming the answer is 'yes'), then how much priority is given to fixing bugs vs adding new features?

Posts 524
Stuart Robertson | Forum Activity | Replied: Tue, Feb 15 2011 4:21 AM | Locked

Any word from Logos as to when this bug might be resolved?

Posts 1861
LogosEmployee
Tom Philpot (Faithlife) | Forum Activity | Replied: Wed, Feb 16 2011 10:12 PM | Locked

Stuart Robertson:

Any word from Logos as to when this bug might be resolved?

We as a general rule don't comment on when a particular bug will be fixed. The exception is after a dev has fixed it we might say "in the next release" in a forum post. As far as I know, this is still an outstanding bug that has been assigned, but hasn't been fixed.

 

Mobile Development Team Lead

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Mar 17 2011 6:03 AM | Locked

I'm not asking for a date, but simply wish to point out that this bug is still preventing any meaningful markup of Bibles... :-(  Any focus that this bug can be given, especially since the cause is known, will be appreciated.

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Mar 24 2011 7:52 AM | Locked

Any word from Logos?  It's awefully quiet here on the Logos beta forum lately... 

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Mar 28 2011 8:02 PM | Locked

ANY chance someone from Logos will comment on this?  It is (still) driving me crazy, making Logos basically useless as a tool to mark up the Bible with.  It's been 3 months since the bug was reproduced by Logos, with LOTS of new features and other bug fixes since, but no fix for this seemingly easy-to-fix bug... Please will someone from Logos at least say "Aye, we hear you and feel your pain..."?

Posts 4077
Melissa Snyder | Forum Activity | Replied: Tue, Mar 29 2011 8:05 AM | Locked

Stuart Robertson:

ANY chance someone from Logos will comment on this?  It is (still) driving me crazy, making Logos basically useless as a tool to mark up the Bible with.  It's been 3 months since the bug was reproduced by Logos, with LOTS of new features and other bug fixes since, but no fix for this seemingly easy-to-fix bug... Please will someone from Logos at least say "Aye, we hear you and feel your pain..."?

I'm checking on the status of this case.

Posts 524
Stuart Robertson | Forum Activity | Replied: Thu, Mar 31 2011 4:27 PM | Locked

Love to hear what you can find, Melissa.

Posts 524
Stuart Robertson | Forum Activity | Replied: Wed, Apr 6 2011 3:25 AM | Locked

4.3 beta 2 just came and went without any mention of this bug (which is still a BIG, BIG problem).  Any word from Logos on when this will be looked at?

Posts 524
Stuart Robertson | Forum Activity | Replied: Fri, Apr 8 2011 1:55 PM | Locked

Bumping this issue again - I know now that there are many "serious" issues with the 4.3 beta series that this might not get fixed for a while, but it really, really, really is killing the Logos joy for me... Any word from Logos will be appreciated.

Posts 4077
Melissa Snyder | Forum Activity | Replied: Mon, Apr 25 2011 10:52 AM | Locked

Stuart Robertson:

Bumping this issue again - I know now that there are many "serious" issues with the 4.3 beta series that this might not get fixed for a while, but it really, really, really is killing the Logos joy for me... Any word from Logos will be appreciated.

This should be fixed in the next beta. Let us know if the behavior continues after Beta 3 is released and installed.

Posts 524
Stuart Robertson | Forum Activity | Replied: Mon, Apr 25 2011 12:09 PM | Locked

Thanks Melissa - looking forward to seeing this bug dead...

Page 2 of 4 (64 items) < Previous 1 2 3 4 Next > | RSS